FRITZbox 7590 ax issue with Wi-Fi smart lock 3.0 pro

Same issue here, Fritzbox 7590AX (Germany) with 7.56 and Nuki Smart Lock 3 with 3.6.9. Here as well the Nuki is the only device (among ca. 30 others in our home) which does not connect to the Fritzbox WLAN anymore (neither in WPA2 nor WPA3). Dear Nuki team - please sit together with AVM to get this fixed.

Read this for solve Momentarily.

To do this you must install the beta 3.7.1. If you are not in the beta program and want to solve it you will find above how to enter

Just installed the 3.7.1 and can confirm that the Nuki has connected successfully with the Fritzbox 7590AX (7.56). Connection is stable now since ca. 10 minutes. With the stable connection the Nuki can again be reached from outside. Looks good so far.

1 Like

installed the 3.7.1 the Nuki has connected successfully with the Fritzbox 7590AX

@Juergen
Hi, the problem is solved on 3.7.2?
If it hasn’t been resolved, in the latest firmware 3.7.2 is it still possible to turn the problem around in the same way by putting the Energy Saving in medium setting?
Thx

The “problem” was created by AVM with their software update. They are the only ones that can solve it. So far they did not provide a firmware update that fixes the problem.

Yes.

@Juergen

Ok thx

@Juergen

Hi, the problem has not yet been solved by AVM or NUKI with the latest updates. You rightly tell me that it was created by AVM and only it can fix it. What I don’t understand is why among hundreds of peripherals only NUKI doesn’t work. Actually only smartlock 3.0 doesn’t work because there are no problems with the bridge. Is it a WIFI chip hardware problem?. Thanks for the clarifications

This weeks 3.7.4 beta contains an automatic detection for the Fritz!Box 7590AX which turns on the fix that was already present in recent betas.

But yes, AVM did not fix the problem yet.

Because the problem is related to the power saving mechanisms the Smart Lock uses to run for months on 4xAA batteries. The fix we applied reduces the power saving and therefore works around the problem AVM introduced.

In general you can with 3.7.4 now reduce the power saving for all WiFis when setting the Smart Lock > Settings > Features & Configuration > Battery > Energy-saving mode to “Medium”. In the past this was restricted to the 7590AX (and alike) access points.

1 Like

@Juergen

very clear. Thank you

(Offensive post deleted)

Please stay on topic and provide meaningful feedback and input which helps us to resolve the problems. Thank you!

That post wasn’t offensive it was just direct but I see criticism isn’t welcome here.

Would you still be so kind to tell us the exact problem that AVM introduced?
The firmware on AVM routers can be changed, so if you know what exactly is wrong with the AVM firmware to only affect a single product out in the market, please let us know so we can fix it ourselves.

And would you still please so kind to provide your temporary fix for your public customers and not forcing them to apply to the beta?
That would be much appreciated.

The answer is in this post: FRITZbox 7590 ax issue with Wi-Fi smart lock 3.0 pro - #70 by Juergen

We do not know what AVM changed. That‘s something they have to look into. We did of course provide detailed failure reports to them.

It‘s going to be part of the next release which is scheduled for September. Still some more feedback would be welcome. E.g. no one gave any feedback to the recent 3.7.4 release.

I have about 70 wlan devices and currently Nuki 3 is the only one having problems. So whatever AVM changed, only Nuki has a problem with it. That’s at least my own experience.

What I’m wondering, if it is a powersaving problem, why you go into power saving mode while setting up the wlan connection? As written it says password wrong constantly after retrying often enough it works.

Do you have a release plan for the 3.7.4 is going into the stable version? To be honest I have problems being a test candidate risking my property to be exposed to everyone.
Also reading the thread there is no success post that it now works instead even more strange problems are raised which if we would have them at home my wife would loose her trust and the device has to returned.

3 Likes

@Juergen

Hi, with new fritzos 7.57 problem seems to be solved.

Can you confirm?

Thx

No Connection with FritzBox 7590AX FRITZ!OS 7.57 2,4 WLAN and Nuki 3.0 Pro Firmware 3.6.9.

Habe das Schloß heute erst in Empfang genommen und bin erst hier auf dieses Problem aufmerksam geworden. Schicke das Teil gleich wieder zurück, ist ja traurig nach so einer langen Zeit noch keine Lösung parat zu haben, die nicht BETA ist.

Have the lock today only in receipt and have only become aware of this problem here. Send the part right back, is sad after such a long time to have no solution ready, which is not BETA.

1 Like

Auch eine Verbindung über eine Nuki Bridge schlägt fehl. Das Nuki Smartlock 3.0 Pro ist definitiv nicht online zu bekommen. Retoure ist beantragt, mit Verweis auf dieses Forum (tink).

Also a connection via a Nuki Bridge fails. The Nuki Smartlock 3.0 Pro definitely cannot be brought online. Return is requested, with reference to this forum (tink).

The Bridge is not affected by the same power saving problem caused by the latest Fritzos firmware. In fact, when the smart lock 3.0 does not connect directly to the Fritz, I worked via bridge. Not even in the official version. If it doesn’t even connect to the bridge I think there is some other problem

You can not test this with recent firmwares, because the FritzBox fix overrides the settings you choose in the battery saving menu.

We’re currently testing 7.57 and do not have a final assessment yet.

@Juergen
Ok thx. I’m waiting for your news