FRITZbox 7590 ax issue with Wi-Fi smart lock 3.0 pro

I have the 6690 cable version with 7.5 fw. I am able to connect, but MQTT does not work maybe something related? Will not downgrade my FB as this would have involve too much configurations. Nuki FW 3.7.0. BTW why is there no downgrade option for the Nuki lock?

Hi all,
I would like to inform you that I have received this response from AVM.

We are currently investigating the issue you described, where smart locks from Nuki are unable to maintain a permanent Wi-Fi connection to the FRITZ!Box after the FRITZ!OS update 7.50. Our current findings suggest that the problem has already been resolved in the current FRITZ!OS beta version (07.51-1045xx), available for download at avm.de/labor.
Therefore, we kindly request you to install the FRITZ!OS beta version from avm.de/labor.
We are very interested in learning whether the beta version successfully resolves the issue for you. Please provide us with feedback via email, even if the issue has been resolved.
If the FRITZ!OS beta version does not fix the problem, we kindly ask you to provide us with the support data of your FRITZ!Box, which should be generated immediately after experiencing the Nuki lock’s login problem. Additionally, please share the MAC address or IP address of the Nuki smart lock with us.

So this issue should be resolved by new beta version.

Hi, if you install the beta let us know how it works.
Unfortunately I have no way to try it these days.
Thx

I tested it right now and unfortunately it seems it doesn’t work. I already answered with the new support data to the AVM support.

Let’s wait.

I have version 7.51-105597 BETA and sometimes it was connected, sometimes it was not connected. Therefore I would say it is not working.

Same issue here (I live in Austria). Also just tried the lab version 7.51-105597 BETA and it didnt fix the problem. Wifi is shortly connected, gets disconnected and thats it.

Maybe a hint having a 7590 with latest 7.51 beta: I have no prob with my Nuki 3.0 pro, however the issue described above sounds identical what I have with my Netatmo outdoor camera starting 7.39 (=7.50 beta) until now. AVM did an analysis with this result: „After analyzing the transmitted data, the FRITZ!Box logged off from the client, stating that the channel conditions were poor. Unfortunately, the client does not support 802.11k/v. Therefore the FRITZ!Box cannot move this client to another less busy AP. In this case, the choice of AP is a client decision that the FRITZ!Box cannot influence“. Maybe it helps.

The latest Smart Lock 3.0 Pro beta firmware 3.7.1 contains a workaround which could improve the compatibility with the FRITZ!Box 7590AX.

In order to activate it you need to set the Smart Lock > Settings > Features & Configuration > Battery > Energy-saving mode to “Medium” and afterwards connect the Smart Lock to a 7590AX Wi-Fi network. The Smart Lock will then use less aggressive power saving settings and consume more battery than it usually would (Batteries should still last several months, though).

Please report back in the poll if the workaround works for you:

  • Smart Lock connects and is stable afterwards
  • Smart Lock connects, but looses connection afterwards
  • Smart Lock does not connect at all

0 voters

1 Like

Hi Jürgen,
thx a lot for the hint. Seems to work fine now. Just want to point out that I had the setting on “fast” and not on default setting.

@Juergen
Hi, like JHL i use setting “fast”.
I try also medium and seems works in both method.
Thx

Using Smartlock 3.0 Pro with fw 3.6.9
Setting energy-saving to “Medium” solves my problem.
Connection to Fritzbox 7590 seems to be stable now

with the beta fw 3.7.1 and Energy-saving mode “Medium” it works fine
thx

Hey guys,
today I got a mail notification from my 7590ax telling me FritzOS 7.56 is available. I recently downgraded from 7.50 to 7.31 losing all my settings. Did anyone try the NUKI 3.0 Pro with 3.69 and FritzOS with 7.56?

Thanks
Matthias

Yes, and it seems the problem is back. Its more stable than before but I started losing the connection again…

Put setting on medium.
@juergen writes:

The changes are only active when “Medium” is chosen. Fast (or Slow) do not change anything to the status from before.

Ye, I had it on medium and with 7.50 this also solved the problem, but with 7.56 it doesnt help. Already resetted the Nuki and the wlan settings. Did unfortunately not help.

I mounted the 7.56 in the ftitz 7590 ax. In fast mode still problems but in medium, after a few hours it seems stable as with 7.50. In a previous post a user wrote to AVM that he claims to fix the problem with the upcoming 7.51 beta. It still seems to be there though with 7.56. Let’s hope Nuki fixes it before AVM.

It seems that the latest labor version has been released as 7.56.

I can confirm your findings: 7.56 did not fix the problem and the workaround in the latest Smart Lock Beta FW still works.

1 Like

The workaround “battery medium” doesn´t work with fritz os 7.56 and Nuki 3.6.9. When will Nuki 3.7 be released?

Thx Tom

Hi, workaround is only in beta 3.7.1. Are you in beta program?
If not, here is the link with instructions