FRITZbox 7590 ax issue with Wi-Fi smart lock 3.0 pro

@Juergen @Stefan_Reiterer
hello, unfortunately my wifi in the smartlock 3.0 pro no longer works (firmware 3.6.2).
After the first problems just bought with iOS and FRITZbox 7590 worked without problems for months.
Now the FRITZbox 7590 AX has automatically installed the firmware 7.50 (previously 7.31 without problems) and since then there has been no way to get the wifi to work. I’ve tried everything but nothing.
The connection through Nuki bridge works correctly.
Do you have ideas or solutions? Thank you

Which WPA mode do you use? WPA3 only could be a problem. Ideal is “WPA2 + WPA3” mixed mode.

You might also try a fixed WIFI channel (e.g. 1). Taking out the batteries of the Smart Lock, rebooting the fritz!box and inserting the batteries afterwards again, might also help.

But generally speaking there are no know problems with FritzOS 7.5x nor with 7.3x.

1 Like

I also have problems with the fritzbox 7590x and the updated to fritzos 7.50. My nuki smart pro 3.0 connects to the wifi network, but after a certain amount of time it disconnects and I can no longer wake it up remotely… the only way to get it to reconnect is via bluetooth and reselecting the wifi connection. … but after a while it disconnects again. With the previous version of fritzos 7.39 I never had a problem at “waking it up” remotely. I have the nuki firmware 3.5.12


Same thing for me

I did all possible tests, I also tried to change SSID and pwd. Only going back to firmware 7.31 everything works.

Did you try 7.51 (labor)?

Yes, same issue.
Downgraded to firmware 7.31 works perfectly


I have the same issue with the Fritz!Box6660 Cable after the update to Fritz!OS 7.50 with my Nuki Smart Lock 3.0 Pro.

@Juergen @Stefan_Reiterer
I try 2 another router, Fritzbox 7490 and 7590 (not ax)
Same issue with firmware 7.50.
I think it is appropriate to investigate given the further reports.
Among dozens of wifi devices, the smartlock is the only one that doesn’t work

Please report the problems also to fritz. At the end it seems that their software update causes issues under certain circumstances (We have fritz!boxes running with 7.5x without problems too), which is something we might not be able to debug.

Here AVM’s answer:

Thank you for your request to AVM support.

He writes to us that since FRITZ!OS 7.50 has been installed on the FRITZ!Box 7590 (AX), it is no longer possible to connect a Nuki Smart Lock 3.0 pro to the FRITZ!Box via Wi-Fi.
This issue was reported in the Nuki betatester forum. I therefore assume that the manufacturer has made available a beta version of the new Smart Lock operating system, with which the connection failure occurs.

It is unusual for the problem you describe to occur with the FRITZ!Box.
In fact, such behavior is not known to us nor has it been reported to us by any of our other customers.

In the following guide, I have collected detailed information on all the operations we suggest for successfully connecting a Wi-Fi device to the FRITZ!Box:

A wireless device cannot connect to the FRITZ!Box

If it still fails, I suggest you report the problem directly to the manufacturer Nuki, who will eventually be able to develop and release a new beta version or an official firmware update more compatible with FRITZ!OS 7.50.

Best regards from Berlin

@Nightwind @Z0mbiel0ne

Have you set italian language in your Fritz with 7.50?


i’ve been struggling too with Nuki and Fritz, perhaps it was the same unknown issue.
I had the 5530 and since I upgraded from 7.31 to 7.39 (it’s the 7.50 beta) Nuki wasn’t able to connect to the Wifi.
Then I had chance to buy the 5590 and I haven’t got any problem even with the same fw 7.39 or now with the stable 7.50

@gioparmy btw do you have a new Smart Lock?

The ID you sent me some time ago (2C2B…) is constantly online since >10 days without a single reconnect (which is super stable and very seldom).

Same smartlock.
I confirm, it is super stable but because while I had installed the 7.50 firmware and was testing with the various routers at my disposal, I was forced to use the Nuki bridge due to the impossibility of establishing the connection even for a single moment. I then reverted to firmware 7.31 and directly reconnected the smartlock pro to wifi.

The doubt arises that the problem is the Italian language and some restrictions regarding the 2.4 GHz Wi-Fi. The names of the users who complain about the problem in the chat are Italian. That’s why I doubted. I had a similar thing happen to me with a DJI drone


The problem also started for me with the 7.39 Beta. However, I had attributed the defect to a bug of the beta. I reverted to stable 7.31 and everything is fine. He then reappeared at 7.50

I have exactly the same problems and the same constellation as Francesco.
Language is German
The Smart Lock works fine with FB 7490 + FB 7590ax (7.31)

@Juergen @Stefan_Reiterer

Now we know the problem is not Italian language

I had the same issues on a Fritzbox 7590 AX with FW 7.50

I downgraded to FW 7.31 and the Wifi connection is now very stable. I hope AVM is working on this issue.

Nuki too.
It is the only device that does not work with this firmware version. For all the others no change

1 Like

Apparently there are different hardware variants of the FRITZ!Box 7590AX in the market. Can you please vote which one you have?

  • FRITZ!Box 7590AX v2 (without ISDN)
  • FRITZ!Box 7590AX v1 (with ISDN)
  • FRITZ!Box 7590AX v1 original (with ISDN and small housing)

0 voters

Here is a video detailing the different versions: Fritzbox 7590 AX: v1, v2, v3: Innenleben, Antennen, WLAN-Tuning: FriXtender, REFBox, Poynting - YouTube

ISDN Port:

1 Like