Smart Lock (4th generation) Firmware Beta 4.3.x

Smart Lock (4th generation) Updates

Smart Lock Beta 4.3.1

  • Bugfixes and stability improvements
    • Minor change to improve MQTT connection handling

Smart Lock Beta 4.3.2

  • Bugfixes and stability improvements
    • Bug Fixes and improvements for the MQTT connectivity
    • Some users reported a bug concerning the activity log: When paired with a bridge, lock actions that should sync via the bridge connection were not visible via Push Notifications or Nuki Web. We fixed this bug with this firmware update.

Smart Lock Beta 4.3.4

  • Improvements regarding the intelligent lock actions of the Keypad 2
  • Bug fixes and stability improvements

If you have problems with the WiFi connection of your Smart Lock, please follow the advice in the FAQ before you post here in the forum.

2 Likes

@Stefan_Reiterer
for my smart Lock (SL4) I can see only the 4.2.6 beta version as update. Is it correct?

I had to first update to 4.2.6 then the upgrade to 4.3.1 was proposed.

2 Likes

What is the changelog from 4.2.6 to 4.3.1?

Same ****. My lock just became unavailable again (home assistant/MQTT).

What beta version you used !
What Is your setups

I cross my fingers, for now i have 2 hours without “unavailable” with this firmware

SL4 Pro (wifi + mqtt + homeassistant)

Not quite sure whether this is related to this or the previous beta firmware, but my smart lock (4 pro) today isn’t coming back alive after a battery pack recharge at all. When I insert the freshly charged battery, it does its usual routine of discovering its current position (spinning the motor until it hits resistance in fully locked position), but then seemingly doesn’t connect to WiFi, MQTT, Bluetooth, or Thread at all. The device appears as offline everywhere, including in the Nuki app. I guess I’m going to have to completely factory reset it.

Connectivity via Thread and MQTT has been very consistent for me over the past week or so FWIW, but the battery drain has been insane. I’ve had to recharge the battery pack over night multiple times since I opted into the beta — it’s like 3 days of battery max, and our usage patterns aren’t abnormal.

Edit.: The previously paired Nuki Keypad (with fingerprint) also is no longer functional now. The lock doesn’t react. When turning the lock manually, it shows the expected lights. Lock / unlock via the lock button also still works.

Edit 2: after another few power cycles the lock now connected to everything as expected, somehow. It’s working well again for now. Weird!

Correct - The Nuki App is always offering the next higher firmware version. Resulting you are getting first version 4.2.6 before receiving the update to the most recent Beta 4.3.1 (assuming that you are having Beta 4.2.5 installed currently).

SL4 Pro, firmware 4.3.1, matter + mqtt + homeassistant

Do you have Sonoff Border Router ?? What model are you using?

Ok, here is the result of today and sadly it’s not very good : i unlocked the lock with homeassistant after 8 hours without any “unavailable syndrom” during the day (of no use) but during the unlock, it blocked during the turn of the key (became unavailable) and so it was also in the nuki app, it appeard online 1 minute after so i was able to enter… I tried this evening too, i unlocked but this time the latch was blocked in open position after unlock, so it was exactly the same “unavailable” problem on applications. There is no more “unavailable” when it’s not used, but it’s worse in a kind of way because it can now happen when you use it (and need it). Hope you will be able to fix that soon.

PS. Now it’s “unavailable” for no reason and not coming back online by itself
PS. It came back online by itself like 10 minutes after.

A ZBDongle-E with the open thread firmware for NAT64 support:

Pesonally, as the SL4 is my only matter device, I’ve set it up via Apple Home, so it’s using either my Apple TV 4K (which is like 2-3m away) or my homepod mini (which is a bit far away). AFAIK, these are the only two border router devices in my home.

Reset the lock and then set battery Energy saving to medium. In this way i solved the issue since 4.2.5

I have apple tv 4k with matter when used apple tv for playing video the smart lock 4 pro disconnect from matter but if apple tv in stand by mode the matter work again
Apple tv with tv ps 17.5 Beta
Smart lock 4 pro with v 4.2.6 beta

This is a known problem. Looks like the AppleTV reduces the Thread radios reach when in use. Problems with Matter and Apple TV

Is the MQTT Problem with Home Assistant fixed with 4.3?

Can’t say for sure yet, but it seems a lot more stable.

Sounds good, when 4.3. will be released as stable Update?