Problems with Matter and Apple TV

I connected my new Nuki 4 Pro finally to matter. It works good until I turn on the Apple TV. When the Apple TV ist on the Nuki Thread Matter connection goes offline. 5 Minutes after turning off the Apple TV it works normal like before.

WLAN works for all the time.
I stop WLAN of the LG TV but the situation stays the same.
I restarted Apple TV, Nuki an Router, but the situation stays the same.
Apple TV, Router and Nuki have the latest Firmware.
My Apple TV supports Matter with Thread :slight_smile:

Do you have any idea?

When the AppleTV is off, which device is your Apple Home Hub / Thread border router?

The Apple TV ist the only Border Router I have. It’s always online but in use the Nuki goes offline. After use it comes online again.

Thank you, now i understand. Looks like the AppleTV is cutting of the Thread connectivity or its Matter controller functions when it is actively used. This ist most likely an Apple problem and not related to Nuki. Please contact Apple support. They are the only ones who can draw logs from the AppleTV and check what is going on.

Don’t you have any related messages to this problem? You could offer WiFi als fallback if there is a problem with Matter. Philips hue or Govee offer that. → Even you offer this for Alexa…

Would there be a chance for direct Homekit connection? At the moment the Nuki 3 Pro would be the better choice for me :frowning: ?

In fact I would like to say thank you for the product itself. That is a great option :slight_smile:

I have the same Problem with Matter. I lost the connection in Homekit several times.
I have Apple TV and Homepod Minis. The other Matter Products in Homekit don’t lost the connection.

That’s bad. Can you desribe when the connections get lost?

→ Is it when you use your Apple TV? Is it another trigger?
→ Can you say which other products work good? I would loke to know if it’s Thread via Matter or something else.
→ If this is also the case, it would be interesting what is the default border router? Home → Settings of the home → Bridges…

For your Information: Nuki uses Matter via Thread. Govee uses Matter via Wifi… Eve for example uses Matter via Thread and there I can find similar problems…

No. There is no known problem with the Matter integration in combination with AppleTVs or HomePods. As mentioned above, please report bugs to Apple too.

No. Such an option is currently not possible with the Matter standard.

Apple Home supports to connect devices via HomeKit (using BLE, Thread or WiFi) and Matter (using Thread or WiFi). SL2&3 support HomeKit via BLE and SL4th Gen supports Matter via Thread. This is not changeable.

I can reproduce that problem: Nuki and Apple (ATV 4K 2.Gen, TVOS 17.2 even after reset of the components to default) are unfortunately not compatible at the moment:

Apple TV in Standby → Nuki is online
Apple TV is On and the resolution is Full HD or 4K with 24 Hz → Nuki is online
Apple TV is On and the resolution is 4K with more than 24 Hz → Nuki goes offline.

What can wie do, because this should be a supported constellation?

We’ve been able to partially confirm your findings: When watching TV on the AppleTV with 4k/50Hz, the reach of the Thread network drops significantly versus when the AppleTV is off. Roughly to the reach of Bluetooth (i.e. ~5-10m).

Report this to Apple. There is nothing Nuki can do about this. It also affects other Thread devices, not only Nukis.

P.S.: Might be that the problem is already known to Apple

If you suffer from the problem, please try the latest 17.4 beta for Apple TV and report back if you still have it or if the situation improved.

I’ve just updated to tvOS 17.4 and the Thread Signal seems to be strong in the Nuki App but the Apple TV shows the lock often offline. By clicking on the icon the function works or the battery level will be shown… I’ll test another time tomorrow.

i have 3 homepods at home and apple tv 4k latest
never seen any problems …before my lock was with bridge…now with matter and bought code from nuki
never offline even when apple tv is On or OFF no difference