Nuki 3.0 Pro looses connection despite AP is next to it

Having the same problem for some time now with Nuki bridges that have connectivity issues with Unifi APs. Took some time to find out what the real problem was. Bridges are running firmware 2.17.0. They won’t connect to my Nano-HD APs, no matter what I do. However, when I move them next to an older model AP (AC-M), the connections is perfect again.
A factory reset (hence old firmware) solves the problems also for about 1 day with the Nano-HD AP, and then after the automatic firmware update the problems start again.
So, my conclusion is that there is a firmware issue causing problems with the newer Unifi APs. Hope this gets solved soon…

Hi Stefan, I can confirm that both the Web App and the Nuki iOS app have been working without problems since I updated to the beta firmware 3.8.2

There are 2 things I kept since before I updated. I did a full charge of the Nuki battery and I kept the Nuki in its own Wifi SSID.

I’m sorry to hear you’re still struggling. I hope you figure it out.

Nuki products do not downgrade their firmware by factory resetting them.

Do you mean that the Nano-HD AP downgrades and stops working after an automatic update?

Interesting to know that the firmware does not downgrade by factory reset. The nano-HD AP works just fine, is up-to-date, and has no issues with any other clients. Only the Nuki bridge will not connect to it (same problem on two different locations). It worked just fine for over a year, and now we have these issues. That is why I suspect the newer firmware.
I will do some more testing to see if I can get it connected to the nano-HD AP by changing the settings. It definitly has no issues connecting to a AC-M AP, what makes it strange.

Ok, now here it comes my UNIFI-SOLUTION on the Nuki disconnect issue (testing 24h). Just right before selling all stuff at ebay I got it running. :grinning::sparkles::balloon:

1. Summary what DOES NOT WORK:

  • Setting up the network like it’s shown above or here…
  • Set a ping every 15 seconds to the smartlock (works bether then without, but finally not helpfull).
  • A fully open Firewall
  • Every possible DNS-Server-trick or tweet
  • fixed IP address

2. Solution: THIS WORKS on a Nuki 3 Pro (using build in WLAN) & Unifi Express and AP U6+:

  • Firmware 3.8.2 (right now it’s beta).
  • No ping to the Nuki nescessary
  • Battery Save to “middle” (seems that this triggers the secret nuki solution of a Seems that also works on Unifi. It does not work on any other battery setting! @Juergen can that really be or is it a kind of conspiration-theory?).
  • Own WLAN SSID only on 2,4 ghz (but this is not nescessary, it just safes battery-time of the Nuki)
  • Network: The game-changer was: 802.11 DTIM Period to 3 (and hey, it took so long to touch this parameter, because unifi warns you to really let the fingers off, stupid)
  • Network: Lowest speed set manual to lowest speed.
  • Bind Nuki to the AP next to it (no roaming)
  • Network: all other cool stuff to make speed or frequ change or things: Just switch it off. Or let it in default settings, just don’t care

Here is my network:


Open Issues:

  • Screenshot: The offline time at night shows another issue: After booting the Unifi router the lock needs really long to get online again. Maybe issues of the ISP dissconect and with that a new WAN-IP / DNS thing or so…
  • Smart Lock 4 Pro doesn’t work with regular firmware
  • Why does the support is not able to help me for days and days? And do the support know about our infos here? How can we give theres infos to the developer to help other customers? @Juergen

I tell if that stays stable. Thanx to all!

This …

… and this …

are because of that: Nuki 3.0 Pro Connectivity Issues with MQTT Broker on Home Assistant - #6 by Juergen

Essentially by setting the DTIM to 3 you align the power saving of the Smart Lock with the power saving of the network. This is in most networks not needed, but some routers (esp. the ones who try to learn and steer devices based around on some secret measurements they do) throw devices off the network if they think they need to act.

This is also why this …

… helps. Could also be responsible for this …

… if it is the network that does not allow the SL to connect, which is a behaviour we’ve also seen with Unifi configurations.

This is far too technical for the standard Nuki support. The best way to have this findable is flagging the working solution in the forum and having a separate, properly named thread for your Unifi problem. Google will index it and other customers will find it.

1 Like

I have been testing this for the past weeks and I can say that there is some magic behind the scenes that I can’t understand.

I’m trying to find solutions and I like nuki products, but fault is definitely on the Nuki’s side, not on the wireless vendors, in this case, unifi.

I have a network with 50+ devices and every single time a network config changes, a reboot is made, etc (even just rebooting the SL itself because I had to charge the battery) will result in a long period of no response from nuki’s side.

It happens on both my Nuki bridge connected to a 3.0 standard and my Nuki 3.0 Pro directly connected to the wlan.

It doesn’t matter how you play with the settings for dtims, uaspd, proxy arp, basic data rates (actually, the auto just so you know, applies the minimum so manually setting to the minimum is the same).

I’m on the latest stable, and from my tests these are the conclusions that I made:

Smart Lock 3.0 Pro

  • Everytime a minor change in the network happens that results in the AP provisioning, it will throw the nuki’s into the reconnect loop.
  • sometimes rebooting the nuki fixes it, but most of the times doesn’t. It may take 1 to 5 reboots to fix it. Sometimes going into the nuki WiFi settings and removing the network and joining again, fixes it.
  • if for some reason the lock doesn’t stay connected to the AP for more than 5 minutes, you better reboot/fix it, it will be hard for it to stick on its own.
  • as soon as it crosses the 10 min uptime in the AP, it will be 100% online working as intended, no disconnections or whatsoever until you reboot it or change any network config.

Nuki Bridge

  • same behavior of the pro 3.0 with the difference that it remains online in the AP but it doesn’t connect to the servers.
  • while you can’t reach nuki in the nuki app, you can through MQTT or webhooks (funny, isn’t it?)

My guess: nuki has a really hard time reaching the nuki servers when it boots or lost connection (disassociate from the AP) and it starts going havoc into a non recovery process. Typically the bridge recovers on its own after a few hours, but the pro doesn’t.

So bottom line is: nuki understands a lot of locks, but it’s really bad on networking so it seems. Again, I don’t have any other similar issue on all my other iot devices, some of them are even cheap stuff from AliExpress that I’d expect to work worse than premium smart locks.

I’m getting tired of working around this issue for a long time now, but I’m too lazy to search another lock vendor and sell my nukis. So I guess I’ll have to live with it and hope, with all the respect, that Nuki engineers hire someone that understands networking or find a fix. I’m sorry to put it this way, but I think you’ll understand the frustration.

Edit: Just to add an example of my lock today:

Basically yesterday I changed some network config (not related with the Nuki network) but since the AP had to re-provision, it dropped the Nuki connection like I’ve described. Then, it start its “re-connect loop” until today earlier this morning, I went to it, removed wifi, removed mqtt, removed battery, re-added battery, wifi/mqtt etc. played a bit with it and it got connected. As soon as I saw it was connected for more than 5 minutes, I knew it would stick. Now it’s more than 2h up and I know, that unless I change anything in the network, reboot the AP/lock, it won’t disconnect and it will be fully green 24/7. It has been like this for the past 3 months or so but it’s really limited that you have to deal with this struggle whenever a network change or reboot to lock happens. To prove my theory, I can post a screenshot tomorrow and it’ll be full green.

1 Like

Update: I got my Nuki bridge connection again stable with the nano-HD AP, after some fine-tunning. It appears that the Auto power mode of the AP is too much for the Nuki bridge. I turned down the power on the 5 GHz band and also on the 2.4 Ghz (-7 dB more). Also made sure that neigbouring APs were tuned down as needed. After this, the bridge had no problem connecting again. So, conclusion: bridges with firmware 2.17.0 are sensitive to the transmitting power of the nearby Unifi APs!

Just another coincidence, I’d say. Like I mentioned in my previous post, I’ve been watching/monitorizing the Nuki’s on my environment where I have little to no interference with multiple Unifi APs all tuned. Sometimes it appears that playing with some settings triggers an immediate result, but that’s just a coincidence because based on my experiments, Nuki will eventually connect and keep stable after a few reboots/re-configs. But of course, interference may play a role if it’s too much.

Following my previous post, like I said yesterday, here it is how the lock is currently:

So once again, my theory is correct.

If Nuki wants to fix it, it needs to understand that the issue happens when lock needs to start the connection with the Nuki servers and it fails or has a hard time. After that is achieved, it sticks until the AP reboots/reprovisions or the lock itself reboots. So problem is always associated with first connections or re-connections to Nuki’s servers.


for my Unifi-Solution to Nuki Pro I have thise Update:

Nuki Pro 3 on Beta 3.8.2 works fine with my last Post-config.


But reconnection after me booting the router in the night takes tooo long (like described by @Miguel_Ruivo )

Smart Lock 4 Pro (Beta 4.1.1.) with my configs mentioned solution shows this:


@Juergen is there the same wlan fix in that 4 pro beta?

Thanx so much, but - to be honest - why do I have to do the job of Nuki research? Battery-safe-mode-WLAN should not be this magic for a company dealing with battery devices for years. :cry:


If you mean the less aggressive sleep behaviour by setting the battery-saving to “medium”, yes this should behave the same in the latest betas of 3rd and 4th generation locks.

There’s a miriad of different configurations of APs, routers, firewalls, ISPs, internet tarifs and new softwares … and so little WiFi devices that need to run for months on a set of AA batteries. Nobody is perfect. We’re doing our best.

P.S: Unifis WiFi experience should be taken with a grain of salt (in general, but especially when trying to judge the online availability of a Nuki lock)

@Juergen You’re right when you say that unifi metrics can be sometimes misleading or not the most accurate. But in this scenario the uptime and experience seem to reflect exactly how nuki is available in the nuki app or not.

One more update that proves my theory. You can see now that uptime is 2 days and 23h (so 3 days already) and connection is rock solid. Problem is always after a reboot from lock or AP. Ok

Any update on this? I just recharged my battery and now it won’t connect to my WIFI whatever I try… I use firmware version 3.8.7, all my other devices work just fine on WIFI!

any update on this i’ve changed the battery to medium, i’m connected to the network, it connects works for like 1 minute then drops it. I’m on the beta program to try and get the update but it doesn’t work

Suffering from the same issue, using Nuki 4.0 Pro.
TP-Link Deco as well

You might also contact TP-Link, last time I did it I was not lucky because hard to know when connection becomes less stable but if we are a lot to contact them and also ask for the ability to change DTIM we can hop they will do something.

I also hop one day a setting implemented in the Nuki smart lock 4 pro will be implemented, within setting level to high but nothing is sure and I don’t know if it finally works for people who have been able to test it.

Hallo, I’m having similar issues with my Nuki 3.0 Pro. I’m losing Wifi connection from time to time. Since I use the Nuki to unlock a holiday apartment, this is really annoying because my guests can’t get into the apartment (I’m using MQTT via Wifi to unlock).

Reading all the discussion here, it seams the best for me is to use a Nuki Bridge and disable Wifi on my Nuki 3.0 pro. Then all communication with the Nuki runs via Bluetooth, and the bridge is constantly powered, so no issues with power saving on Wifi. This should be a reliable, stable solution, right ?

@Jürgen: is this correct ? I assume the Nuki Bridge supports MQTT ?

Thanks and regards

I have the same issue, but for me the issues started after updating to firmware 3.9.5, before that it worked perfectly fine. I’m also using Ubiquiti Unifi accesspoints. I’ve tried all suggestions in this thread, but none of them helped. I’ve now connected my Nuki Pro 3.0 to an old Nuki Bridge I had laying around and the Internet connection is stable again, but of course this is not how it should be.