Nuki 3.0 Pro Connectivity Issues with MQTT Broker on Home Assistant


I have recently set up two Nuki 3.0 Pro smart locks and integrated them with Home Assistant. I’m using MQTT as the middleware, specifically Eclipse Mosquitto version 1.6.15, hosted on Docker. My Wi-Fi signal strength is satisfactory, and my remote PC is able to interact flawlessly with the MQTT broker using mosquitto_pub and mosquitto_sub commands.

However, I am experiencing intermittent connectivity issues with both of the Nuki smart locks. Reconnecting occasionally produces errors, requiring multiple attempts to successfully log in. I have tested this on two different Wi-Fi routers with varying specs and hardware, but the issue persists on both.

Interestingly, these problems began after a firmware update to version 3.7.7 on the Nuki devices. Previously, with an older firmware version (the exact version is unknown as I had enabled automatic updates), I did not encounter these issues.

Any assistance in resolving this problem would be greatly appreciated.

Thank you.

1 Like

Do you mean it takes several attempts for the Smart Lock to connect to the MQTT broker?

Can you name the brand & model of the routers?

Do you mean it takes several attempts for the Smart Lock to connect to the MQTT broker?

Also, it takes several attempts to connect to the wifi router’s. sometimes he shows password incorrect for some unknown reason, and sometimes he just don’t let me to connect. after several connect attempts he gives me to connect

Can you name the brand & model of the routers?

Tried with:

  1. TP-link Archer AX50 hardware v1.0 firmware v1.0.12
  2. Router called “HotBox5” model GR140DG hardware version 3NTRGW14964U01 software version 3GN8020700r15. (I presume you can’t get this router cause its company specific vendor not sold anywhere)
1 Like

I have also tried hard reset and still have connectivity issues

Mentioning that this only happens in the new firmware version.
in the old version (I guess 3.6.x) it didn’t happened
also worth mentioning my home is completly surrounding with home automation devices and only Nuki’s having problems. so it is must not be because of the wifi/server equipments

1 Like

Most WiFi problems stem from the power saving that the Nuki Smart Locks have to apply & use in order to survive for months on 4xAA batteries fully connected.

With firmware 3.7.7 you can change the aggressiveness of the WiFi power saving by setting Smart Lock > Settings > Features & Configuration > Battery > Energy-saving mode to “medium”. If you also set the DTIM interval of your router to 3, no (extraordinary) power saving will be applied at all. Your Archer AX50 should support changing the DTIM interval, so you can give this a try.

Another thing worth mentioning is that some router put a sort of “penalty” on devices that try to connect too often. It’s therefore better to let the Smart Locks own reconnect mechanism try to connect to the WiFi rather than turning it off and on with the App all the time. You can trigger an immediate reconnect try through a lock command (e.g. locking with the button).

I want disable “Energy-saving mode” completly (I have paurchased 2 backup batteries, I dont need saving mode)
Set the Energy-saving mode to “fast” meaning that it disabling the power saving ?
Can’t custom DTIM configuration in my wifi routers (both tplink Archer AX50 & HotBox5)

tried both medium and fast, but connectivity still unstable and getting disconnected often

I experienced the same issues which KFIRER described. Nuki cannot connect to access point (which is only 3 meters away!) or looses connection.

My hardware:
NUKI smart lock 3.0 pro
Home Assistant on intel nuc, MQTT connection between HA and NUKI smart lock
TP Link Access Points

I have tons of smart devices in my house and only NUKI causes problems since two day (probably caused by firmware update).

I hope we can solve the problem soon. Thank you in advance for any support.

Walter from Austria

1 Like

Here is the user guide from tp link: Archer AX50 V1 User Guide | TP-Link

Do not change energy mode to “fast”, but to “medium” as mentioned above. “fast” does not have an impact on the wifi power saving parameters.

I have set to “medium” power-saving, and also “DTIM Interval” to 3:

But the connectivity problems still exists

I have the exact same Problem.

My hardware:
NUKI smart lock 3.0 pro
Home Assistant with MQTT connection between HA and NUKI
Speedport 4 (Deutsche Telekom Router)

So but the problem is not the MQTT connection, the Nuki Pro 3 is loosing the Wifi connection everytime after several minutes.

The problem started after the fimreware update to 3.7.7

I also already tried to reset the Nuki Pro 3 and used the suggested settings for the Battery but this didn’t solved the problem.

I hope that there will be a fix for that

Kind regards
Vitali Braun

1 Like

Something new? its quite crucial
If we can revert to previous version it will be good

1 Like

same here
can we downgrade version ?

something new ? any progress ?

1 Like

Using 3 pro with HA and mosquitto broker, my MQTT disconnects every hour or so, fails to reconnect, even though wifi connection to lock works fine. I have 130+ mqtt devices all working fine throughout the house, some next to the lock. Joining the party wanting to try a downgraded firmware or available to help test a fix.

it’s been a while since then , and nothing have changed.
im in the beta 3.8.1 and still getting disconnections from the mqtt broker.
what’s going on ?

1 Like

fix it or give us ability to return to any firmware we want
it’s was pricey and i have bought 2 nukis and 2 keypads…
it’s crucial.



I also use MQTT connect from three Nuki 3 Pro to Home Assistant (HA) via the guest network of AVM FritzBoxes.

Since some weeks the locks tend to become unavailable at random times. Sometimes they come back available, sometimes they stay offline for HA. All the time the locks themselves work fine using the Nuki app, Nuki web or the button.

Reconnecting to MQTT via the admin menu then again is difficult, most times it will not work directly or even only after powering off the lock.

This is really annoying for any use in automation scenarios. Thus I fully agree to the predecessors’ wishes to fix the problem soon.