Nuki 3.0 Pro looses connection despite AP is next to it

Hi,
I had Nuki 2.0 + Bridge for approx. 3 years. Worked like a charm with same WiFi Settings and Access Point (AP) constellation.
A few weeks ago I have bought Nuki 3.0 Pro with integrated WiFi and since then I have problems with loosing connection.
I have a Netgear Orbi setup with 1 Router and 2 Satlites. One Satlite is 1m away from our door in 1st floor with installed Nuki 3.0. The Router/AP constellation did not change, I just changed Nuki 2.0 + Bridge to Nuki 3.0 Pro

Everyday I have connection issues, sometime push notifications from Nuki (Door Sensor) will not be send for hours and than all together within one second. Is there any solution for this? How can I dive deeper into logs to check what Nukis problem is?

I thought that maybe Orbi WiFi connection between Router and Sat is too weak, I have installed network cable between Router & Sat but Nuki still looses connection almost every day for several hours.

Once in a while Nuki connects to the Satlite farer away (2nd floor), I can see this in Orbi Overview.Why is it not connecting to the Sat with better signals?

I don’t want to buy a Nuki Bridge just for “testing”.

1 Like

The Nuki Bridge is mains powered and therefore behaves completely different in a WiFi network than the battery powered Smart Lock which has to minimize WiFi activity in order to conserve its batteries.

During our initial testing some Orbi routers showed strange behavior. Joining the Smart Lock beta would allow to have a deeper look at what’s going on (because of enhanced logging). The latest beta firmware does also have some improvements in how reconnects are handled. If this does not help and you continue to have problems, please contact customer support through the Nuki App.

1 Like

Hi Jürgen,
please tell me what I need to do to get beta firmware, I would give it a try :slight_smile:

Thank you :slight_smile:

See: Nuki Smart Lock Beta - Nuki Developers

Had exactly the same issue with a full Unifi setup (DM Pro + AP6’s). Problem has to do with power management issues, switched to the Beta firmware which seems to fix it (one week in).

Update: not so much unfortunately - last night the connection dropped again for a couple of hours. Will report in firmware topic as feedback.

Same here with latest Beta firmware 3.4.9, WiFi is, after setup in the iOS App, short connected (about 2 min) and then the smartlock loses the wifi connection forever…

Unifi Setup with U6-Lite AP‘s

Since yesterday’s update to 3.4.9 I have permanent issues with WiFi on my 3.0 Pro. Previous version 3.3.5 was flawless for me.

I have the same behavior with the currently released firmware version 3.4.9. It has permanent disconnections and does not hold the connection. Sigal strength to the AP is very good. With the previous firmware version 3.3.5 I never had such problems.

Tried everything, reboot, SSID searched and added again and did also reset the device. No change in the connection behavior.

Please fix this bug asap and release a hotfix. I don’t want to test with a BETA version.

Or, is there any way I can revert to the old firmware (v3.3.5)?

1 Like

My AP signal is also strong. I also tried placing dedicated AP next to the Smart Lock. Smart Lock disconnected itself within few minutes after setting up WiFi. I ended up disabling WiFi for now as it has no value before it gets fixed.

Nuki, please, allow for firmware downgrade.

Does anyone know if you use Apple HomeKit, if Nuki sends data via BT to HomeKit Hub (AppleTV) or must have WiFi connection? My workaround would then be Nuki to integrate in HomeKit and use AppleTV as Gateway.

It’s using BT and I have it set up this way now with ATV as Home Hub.

And you’re still getting notifications when door sensor status changed like “wife opened the door” and so on?

Sorry, I’m not using notifications at all.

I am having same problem with wifi disconnecting constantly, auto lock not working after auto unlock and missing events from log. This is second Pro 3 as first changed due to similar problems. I have been informed by customer service that the latest firmware solves the problem which is obviously not the case by reading this thread!

3.4.9 is broken, WIFI errors “d11 RC reserved”, rollback your firmware changes “Bugfixes and stability improvements for the WiFi connection of your Smart Lock 3.0 Pro” its a shame that your “improvements” is broken WIFI improvements…

I cannot open my door or manage it without being home, became totally useless

Provide really fast fix or I will send it back !!!

1 Like

Nuki Bridge solved my problems with Nuki 3.0 PRO wifi connection problems… (not cheap solution)

1 Like

Honestly, it’s not a solution at all.

5 Likes

Any progress here?
How can I downgrade to the previous version of the firmware (v3.3.5).
Since the version 3.4.9 is not working for me.

4 Likes

I buy a Nuki Bridge only if Nuki payback the difference between Nuki 3.0 and Pro version price, np

Now Nuki 3.0 Pro is totally broken. If there is no fix until end of month, I send back the product and buy another product but nomore Nuki ones

2 Likes