SL4P MQTT Problems since Nuki FW Update 4.1.8

Fixed with 4.2.5 Beta :slight_smile:

It seems to work with 4.2.5…
In the last two days no issue…

I have the issue again with 4.2.5.

Can you explain this a bit more please? In this|my Thread various problems I had where discussed and also fixed all the time.

(From my side there is, BTW, only one last minor problem existing: Sometimes there is a delay of handling MQTT LockActions, which a) can be seen in an traffic capture and seems to be related with the MQTT KeepAlive process and b) is also already under investigation by Nuki)

still have MQTT trouble with 4.2.5 :frowning:

What problem exactly?

First problem, I have a raspberry PI 3B+ near to the nuki (~50cm) ; WiFi is perfect on my raspberry (RTT 5ms) but signal is medium/poor with my SL4 (RTT ~900ms).

I manage my SL4 via MQTT by sending the payload 1 or 2 to the topic nuki/XXXXXXXX/lockAction

Second problem, The SL4 randomly disconnects from the broker (mosquitto) and very often. Moreover, and there is a lag between the MQTT command and the lock action (sometimes my request is even lost).

After some days i can say that with 4.2.5 mqtt seems to work …

RTT of a ping is not a proper measure of WiFi quality. The Smart Lock runs on batteries and RTT times >1.000ms are normal. If you have problems with frequent reconnects follow the steps described here: Smart Lock WiFi/Thread/MQTT connection troubleshooting / FAQ

Update from my side:
After the latest updates to 4.2.6 and the beta version 4.3.1 it is still not stable.
It is beter then before the update, but still not good enough.

Best regards,
Jacob

Give 4.3.2 a try:

Done, Let’s hope it is the final fix, for this.

Since three days not a single delay - Seems to be fixed with 4.3.2 :slight_smile:

A possible new “type” of issue with 4.2.6 that I didn’t have with 4.1.8.
I can unlock via MQTT almost always, but locking almost never works. The lock blinks, indicating it’s unlocked, I issue the MQTT command to lock it and it flashes white once, but doesn’t lock. After this, it doesn’t blink anymore, possibly indicating it “thinks” it’s locked now?
If I rotate the lock manually (as to unlock it) it starts blinking again and I can then lock it with MQTT.

This doesn’t happen if I lock with the app, so pretty weird.

Looking forward to 4.3.2 (waiting for stable though). For me, 4.1.8 was better than 4.2.6.

Thanks everyone

Then please open a new thread for it and do not write in the 4.1.8 thread.

You could check what the Activity log of the Smart Lock says to this lock commands.

Update: Today, one of the locks was disconnected from the WIFI. After repower hem, it was back.