Ritto 4630/01 compatible?


is my Ritto 4630/01 compatible with the opener?



I received Opener combo with Smart Lock today. I also have a Ritto 4630/01 and although it seem to be in general compatible with newer Twinbus-Systems from Ritto (https://www.elektrikforen.de/threads/ritto-4630-tauschen.19426/) I couldn’t make it work with Opener today. With the alternative configuration Opener seem to receive the open command, but it doesn’t open the door.

I will try again tomorrow, but it would be great if the Nuki-Team could confirm that I can e.g. use the 17630 model in the setup dialog.

Here is some more detailed info (s. page 4) about that Twinbus generation:

Best regards

Still not working. I tried again with the alternative configuration (i.e. switched polarity), this time using the generic twinbus-config for Ritto. Now it seem to work a little bit better. Currently I am stuck in the setup wizard where you first time have to open the door from the app. Nothing happens, so I hit the retry button. Also second attempt without effect. The third attempt suddenly triggers the opener but then the wizard get stuck in an endless loop.

Hi Patrick,
I just sent you a PN for further details.
Best regards

I´m the owner of an RITTO 4630/02, but it does not work.

What can I do to change? IMG_4906|666x500

Olaf from germany

Hallo PatrickB78, I have also a Ritto 4630/01. It‘s working?

Unfortunately no…at least not yet. I have the feeling that it is just a software problem which can be fixed. I am hoping for help from Nuki-Team :slight_smile:


Hi Georg, any news on this?


Hi Ole,
this issue is currently under investigation. Results will be released soon.
Best Regards


Thanks for the quick feedback! Really looking forward to using the Opener as I think the Lock is an excellent product.

Helle Geog_S,
is „soon“ past?

1 Like

There’s going to be a new beta firmware 1.2.2 today which should resolve the problems mentioned here:

1 Like

Hello PatrikB78,
do you have time to verify?

Hi Jürgen,

I just checked in the app if I can update my Opener to 1.2.2 but it says that there is no update available. I send Stephan a PM with my Opener ID and asked him to become part of the beta program.

best regards

1 Like

Hi, I‘d also like to test it.

I sent a request to contact@nuki.io with my opener ID, is this correct?

no progress for me so far with … Opener 1.2.2 and RITTO 4630/02 …

Since 1.2.1 the Opener can handle my Ritto 4630/01 intercom. But at this time it can only open the door via app, ring to open is currently broken.

Stephan added me to the Beta program and I updated my opener to 1.2.2.
fyi @Georg_S @Juergen

I connected Opener according to the wizard and selected the new Ritto profile for 4630. The wizard fails with a timeout-message (and later with a configuration failed message) when ringing from the outside. It doesn’t even recognize that I am ringing.

I also switched port a/b with similar result.

Hi Erol,

did you select 4630 from the device list or do you use the generic model? …and could you please share an image of how you wired the opener?


Hallo Patrick,

I send a picture of my wired intercom today

I’ve used the Ritto from the device list