Poor Wifi connection Nuki 4th gen Pro

Ok done, I’ll test it in the next hours and I’ll let you know.
Thanks for now.

Nothing to do, it looks like worst than before… :sweat_smile:

Hmm, thats bad :frowning: You made a restart after deactivating the log?

Yes, I restarted everything: the smart lock, my iPhone, HomePod mini and Apple TV but nothing changed…

Actually disabling the logs is not changing the connection handling of the Smart Lock, thus I assume that the reboot you mention in your post was “healing” your connection.

To verify that I’m asking you to apply following steps:

  1. Enable the activity logs again
  2. Perform a manual reboot
  3. Check if the connection is (still) working stable

If this is not resolving the stated connection problems you can try to disable Nuki Web by deleting the Smart Lock via the Web-Frontend (Nuki Web).

Please report your findings here - thanks for your investigations.

I had enabled activity logs, reboot device connection not stable as the same.
I had disabled and deleted Nuki Web user, reboot device but connecting still the same: not stable.

It’s quite frustrating…

By clicking on the icon, it‘ll get connected and lost later. That is a Thread problem from Apple with 17.4 tvOS… for me it should not be related with the other problem? With Home Assistant it works even if it‘s behind the Apple TV.

Another problem is that now HomeKit ask me to confirm some automation, I don’t know why… I set automation “when the last persone leave the home, block the Smart Lock” but every time I go out the app home sen me a notification to confirm the automation, never do before…

Anyone has new about the 4.2.6 release? Does it solve the issue properly?

for me, yes (at the moment) - lets see. But i think it was the first step to solve the problem.

4.2.6 installed this morning (CEST) ; it seems WiFi is more stable (only 2 ping lost rather than >300 for a same period)

i have change my app in (beta version) but i cant download new firmware can anyone help me??

it’s really annoying it keep disconnecting

As also mentioned here, the release is rolled out in stages, thus it can take several days until you receive the update.
If your Smart Lock is online (via WiFi, Thread or by a Nuki Bridge) the update will be installed automatically overnight once available.

So is it normal that trying to manually install 4.2.6 from 4.2.5 beta the app just closes ?

my nuki is always offline due to this firmware problem :pensive:

Solved taking out battery and truing again

I installed the new Firmware 4.2.6 some days ago and it broke my wifi connection more or less completely. I had to reset the Nuki because of calibration issues after the update. The calibration now works again, but the Wifi does not connect. I get always a message that it was not successful and if I go back and open the Wifi menu again the spinning circle stops after a few seconds.
I saw in my Home Assistant that the Nuki seems to be connected sometimes but it cannot be used in a stable way. I also see on the dashboard of my access point that the Nuki is connected to the WIFI and a IP-Adress is given.
Does anyone else have the same issue, or ideas what to do?

(With the firmware 4.1.8 MQTT was not so stable but at least the WIFI)

I also updated to the newest firmware and it haven’t improved my situation. The lock connects to WIFI for a few minutes and then drops the connection.

I’m really annoyed about it. I bought this expensive lock to be able to open the door remotely when I’m not at home. It’s not working for me right now.