Poor Wifi connection Nuki 4th gen Pro

I have a Nuki 4 pro. I have established a WIFI connection with it but it is always displayed with a red signal in the app. I think the signal means that the connection is weak.
I have a distance of 2 metres to the router (no wall in between).
What is the reason for this?


Same here. Strong wifi, but nuki os losing it very often. No idea why.

1 Like

Showing the connection always as “weak” could be a bug in the current firmware. We’ll be checking this and report back once we know more.

I have a similar problem! My Nuki 3 Pro was replaced by a Nuki 4 Pro and since then the Nuki regularly loses the wifi connection.

1 Like

The bug is in the meantime confirmed and fixed with yesterdays 4.0.31 release.
It was a pure software bug in displaying the signal strength. This did not have any impact on the way how the integrated WiFi performs.

Hallo, bisher konnte ich das nicht feststellen. Aber ich werde es beobachten.

I can confirm this bug. My accesspoint is about 2m away. But still the Nuki 4pro is always disconecting.

1 Like

I have the same problem. Smart Lock 4 Pro, wifi connected to AP 3m away, very strong wifi signal, but the smart lock keeps disconnecting…

Any new firmware planned to fix this?


i’ve bought the 4 Pro a few days ago and everything looks good - but yes, the WiFi has some serious issues for me too.

The general connection seems very bad and it constantly loses its connection completely

i tested wifi at that exact spot with several different devices (2 laptops, my smartphone, there is also a esp32 there), and all of them have < 10ms stable connections.

I have the same problem. The Nuki loses the WiFi connection at irregular intervals. I see this very well in the home assistant timestamp. The device usually comes back online after a few seconds, sometimes only after a few minutes or even hours.

1 Like

Same issue here, just got Nuki 4 pro and WiFi dropping out constantly, showing offline in the Nuki app but I can still control it via Apple Home, pretty Infuriating.

I bought the Nuki 4 Pro and it’s now at 1 mt. from a wifi repeater while it’s far away from the router. In this position the repeater’s signal is, of course, very strong while the router’s one is weak.
In the APP, I can configure the Wifi parameters but the connection doesn’t work: the signal indication in the APP is red and also the “Connection Status” doesn’t show the link to the WIFI icon.
The only workaround I found is to switch off the repeater, configure the wifi, let Nuki to connect to the router’s weak signal and after some minutes switch on the repeater.
In this way the smart lock keeps the connection, even if weak, with the router.
If for any reason Nuki or the router restarts, the connection isn’t restored automatically (I have to repeat the workaround).
I tried the official and the 4.2.0 Beta firmware.

Is there any restriction in the usage of wifi repeaters?



You can try to set the “Battery saving” of the Smart Lock to “Medium”. This reduces some WiFi power saving mechanisms to be less restrictive and could help with problematic WiFi routers.

I have already tried with the “Battery saving” to “medium” but the behavior is the same.
I have also tried with a another wifi repeater model without success.
Another test was with a different SSID for the extender (the usual xxxx_EXT) but also this failed (now I’m using the same SSID for the router and for the extender).

Same for me, wifi connection is unstable and not reconnecting by itself.
So by reading previous posts… maybe still a firmware problem?

Again, I have now 4.1.8, the app says in the Built-in WIFI" that I am connected, 2 out of 3 “bars”, but in the connection graphic it is not visible as connected - only via BT.

What is the vendor ID for the Mac address, so I can check with my router?

Very sorry this is so unstable!

I did a factory reset and now wifi is connected again. Also changed battery management to medium. Nuki is more responsive now.

You can get IP & MAC with this: Cannot find Nuki IP address - #2 by Juergen

The smart lock 4.0 pro is in 80-90 % of cases offline, when online connection is good being router at a distance of 2 m without obstacles. This means that if you give Alexa a voice command 9 times out of 10 it doesn’t work and, much more seriously, if you have an emergency and you are far from home you are helpless. I believe that for a lock that is defined as smart to be often offline and controllable only if you are within Bluetooth range, a serious shortcoming. I hope they fix it by updating firmware because it’s not the user’s job to go by trial and error. I also own an echo show 10 third generation compatible with Matter, but unusable because Alexa (I think the most widespread smart home) is not yet supported, I hope as soon as possible it will be supported and using Matter in addition to battery saving also improves connection stability

Same here. I installed the Nuki 4 Pro on Thursday, but it has hardly been online ever since. It’s mostly offline even with using a guest network, which I keep for the IoT things, and even when my router sees it online.
The remote functionality was the main reason for buying it, so I’m very disappointed.

1 Like