Open door function problem


Same problem here with nuki 2.0 firmware 2.4.5. Once in a while, after an open door command, the door latch remains 2 or 3 mm outside the door frame. I.e. It doesnt completely slide in the recess. I never seen that problem before on the nuki 1.0. I tried the “optimize locking” menu but there is not setting for adjusting the turn angle for an open door command. The advanced calibration adjustments setting are not cristal clear by the way (a help menu would be welcomed). So I am bit a clueless on how to solve this problem.

Is there a fix?

“Optimize locking” just tries to reduce the locking distance to save energy and time.

If the latch remains outside the clutch must still be engaged. Do you see any error in the activitly lock (like battery warning or Motor blocked?)

Although I did not have a battery warning or anything,but,after replacing the batteries I have not had that issue occur again.

Thanks for the feedback; then this could point in the direction of a problem with the battery warning threshold for your unlatch-case. We will try to adress this as soon as possible.

Is it possible that it happens to me with brand new batteries from the box?

On calibration it always unlatches but then on door opening, it never does

Insolved the problem. The actual option was hidden as Open door instead of just unlock.

I also noticed that i wanted the door to auto open when i got close by. If inset this as an expert option, the auto unlock with geolocation feature wouldn’t work.

I have now setup my door as if it didnt have a handle on the other side so every time it opens it with gps it tries to open the latch too, without requiring me to add any expert configuration.

So i suggest in the next firmware to allow open door instead of just unlock as part of the auto unlock with geofence

I had seen that also some months ago, when I adjusted my latch slightly (moved easier afterwards), the problem was gone. I have never had that with V1.0 - either V2.0 doesn’t have enough torgue or it stops too early.

Oh god, i found the same problem.

im having the same problem… i bouth nuki a month ago. At first… i was using auto-unlock… when i was close the door opened without problem.

A week later i started to use the phone app and the fob (because i bought nuki for guest on my home and i needed to prove it and check it), at first, no problems, but 2 weeks ago it started to fail…

first try… no open,
second try opened the door.

Now, this week its different,

first try, no open
second try, no open
Third try opens.

I Dont know what is the problem, but its shame because i bought it to not share my phisical key, and the guest do not feel “confortable” (even im not feeling confortable neither) using nuki and trying always to open and fail.

Nuki Firmware 2.5.2 and app update.

Sorry for my english, im from Spain and english is not my strongest language…

Sorry for the late answer:

It seems you have general liabilty problems with Auto Unlock if I understood you correctly?
Then best check out the tipps at:

If you meant there have been issues with opening directly from the Nuki App: Make sure to have the latest App version for your OS and if you still can reproduce the problems please send a log-file with a short description of the problem and the exact time when it occured to our support team at, so they can check the details of what happend.

I seem to have the same problem, I installed the Nuki smart lock yesterday, with the latest firmware updates (2.6.4).

When the door is closed, and I try to open it with the app (open door), it doesn’t open it completely. When the door is open, it works as it should. Locking and unlocking seems to work correctly, but opening the door (which I need to get in, because I don’t have a handle on the outside) doesn’t work…

“Open Door” drives the motor (& pulls the latch) until a certain resistance is measured. Usually this is about how hard you can turn the key with one hand (with the 2nd hand in your pockets, not pulling or pushing the door at the same time).

I.e. if the door does not open, your latch is too hard to retrieve for the Smart Lock. Most likely you have to physically adjust it in order to be fully compatible with the Smart Lock.

I have identified my problem. It was indeed that sometimes, the latch is stuck, because the door is hanging down a bit. I’m going to get that repaired now, and I think it should work then.

If I apply upwards pressure on the handle, Nuki opens the door as it should.

Thank you for your reply.

I would like to thank a person who mentioned that replacing the OEM Duracell batteries solved the issue. I replaced the batteries that came with Nuki with regular Duracell batteries from a nearby store and the issue is resloved. Now it pulls the latch 10 out of 10 times. Previously it was 1 out of 10.

1 Like

I have been having this issue…now 2 months that I own the Nuki. I changed the batteries from OEM to new panasonic batteries. It worked for some weeks and then it happened again…now i use the key to open which is not what I want.
Seems that if the batteries are not at 100% the door wont open. I checked the status of my batteries in the app and it says it is ok. Have you solved this issue with any software update…somehow to pull the latch with more strength when opening??

I use Enerloop rechargables.

You should give the latest Smart Lock Beta a try:


I just got the Smart Lock 2.0 Beta with the sensor for the Euro profile cylinder. My door comes with a double lock. When it calibrates, it locks the door twice but only opens once, leaving the door unlocked. it have tried setting it to 360 and 720 but still no luck. am i missing something. Please help.

Please contact our support via or for direct help on your issue.

This forum is focused on developer related issues.

Firmware 2.8.15
Fresh batteries (1 week old) - alkaline battery level 86%.
Calibrate: detects the closed position and open position (Unlatch position) correctly. But not unlock position, most of the time the door stays locked.

When I unlock the door, it does not open (lock sticks out about 4-5mm ).
When I turn the knob manually (small margin), the lock opens completely without any resistance.
When i tune the lock (optimize locking -> Custom and set Unlock to -10) then the unlock works as expected every time.

Is there anything you can do with the detection during calibration?

If not, using “optimize locking” is a good solution, but it would be more intuitive, if I manually open the lock from the dial and press a button to set the unlock position.
For example in the “optimize locking -> Custom -> Unlock” (so I do not have to guess how many degrees i have to change) or in the end of Calibrate Smart lock.

Thank you!

Calibrate the Smart Lock with closed door.

If that does not help, please contact our support via or for more detailed information.

This forum is focused on developer related issues.