Smart Lock Firmware 2.8.x Beta

Updates:

Smart Lock 2.0 Beta 2.8.0

  • Performance improvements
  • Several minor bugfixes

Smart Lock 2.0 Beta 2.8.1

  • Battery in percent calculation

(can currently only be tested with the Bridge API for Bridge Firmware 2.7.0./1.17.0 or with Homekit)

Hi,

Did something change to the firmware update process? When updating to this version, I didn’t have to push the button on the lock anymore for several seconds to start the installation. It downloaded and installed the update immediately without touch the lock. Also, the lock didn’t do a recalibration after the reboot when the update was finished.

Regards,
Frank.

Hi Frank,

the firmware update was indeed generally improved, both on the firmware (already since the 2.7.x release) as also on the app side.

The improved update flow is available with following beta versions of the Nuki App:
Android: App Update: Nuki Android App 2.6.9 Beta
iOS: APP UPDATE: Nuki iOS App 2.6.7-Beta

Best regards
Stefan

Hi, thanks.

Nice feature.

It would be nice though if you gave more information on such changes in the release notes. Now it only states ‘Improved firmware update for Nuki Smart Lock’, which is quite general and it’s a pity that such a major improvement doesn’t get more attention.

Frank.

Funktioniert in dieser Version, das Nuki nur zeitgesteuert zusperrt wenn Nuki anhand des Türsensors erkannt hat, dass die Türe auch geschlossen ist? Also nicht nach einer eingestellten Zeit zusperrt wenn die Türe z.b. zum Lüften länger offen steht.

Hi @Rembrand,

locking the door automatically is possible by using the Auto Lock-feature in one of the following ways:

  1. Using Auto Lock with a defined timeout
    Hereby you have to enable the Auto Lock in the settings (/bla) and set the preferred timeout - if the smart lock is unlocked, it locks itself again after the set timeout.

  2. Using Auto Lock in combination with the door sensor
    You can also combine the feature described above in combination with the door sensor. To do so, you simply have to activate the door sensor and to enable the setting lock immediately after closing (Sofort nach dem Schließen sperren). By doing that, the door is either locked automatically after the door is opened and closed once after getting unlocked or after the set timeout expired.

This feature is neither new nor was it changed by the current beta version, therefore you can also check it out with the latest public release version 2.7.30! Check the linked release notes fur further information:

Danke für die Antwort, aber das ist nicht genau meine Frage gewesen.

Ich versuche die Frage noch mal anders zu stellen.

Nuki 2.7.30 installiert.

Türsensor in App deaktiviert.
Autolock aktiviert Nuki sperrt nach der eingestellten Zeit zu.
O.k…

Türsensor in App aktiviert.
Keine Zeit eingestellt.
Nuki schließt direkt nach dem die Tür ins Schloß fällt.
O.k…

Türsensor in App aktiviert.
Zuschließen nach 10 min.
Nuki schließ 10 min nach dem die Tür ins schloß gefallen ist.
O.k…

Jetzt mein Problem:

Türsensor aktiviert.
Zuschließen nach 10 min.
Tür steht weit offen.
Nach 10 min schließt Nuki zu, obwohl die Tür nicht im Schloß ist und der Sensor offen zeigt.
Jetzt geh ich, schmeiß die Tür hinter mir ins Schloß. Geht aber nicht, da schon zugesperrt. Komme
nach einer Stunde zurück Tür steht ganz weit offen.

Mein Wunsch:
Tür sensor aktiv.
10 min eingestellt.
Tür zu, Nuki sperrt nach 10 min o.k.
Tür offen Nuki sperrt nicht nach 10 min zu sonder erst 10 min
nachdem sie ins Schloß gefallen ist und der Sensor meldet Tür geschlossen.

Hi,

I found a small glitch with this 2.8.x, and SL2.0.

In case SL locks automatically after door closed (sensed by magnet), it does not release the clutch. So it’s not possible to unlock manually after auto-close.

Seems reproducible, at least I’ve tried more than 2 times. Is this intentional?

Updated with the information for the new 2.8.1 Beta which contains the experimental feature Battery in percent calculation.

Note that you can currently only test this with the Bridge API for Bridge Firmware 2.7.0./1.17.0 or with Apple Homekit.

See:

Is 2.8.1 released as beta yet? My lock should be in the beta branch but just updated to 2.7.22.

/Edit: Nevermind, the update process seems to have been changed to a multi step one.

The process hasn’t changed. When you’re coming from an older version sometimes intermediate updates can’t be skipped due to necessary migrations that come along with the update.

Hello Juergen,

Thank you for the heads-up. Development shortcuts are perfetly fine. However, they should be either completely transparent for the user or at least indicated in the ui (“subsequent updates possible”) to avoid confusion.

Patrick

Hi, just updated to the new beta (2.8.1). The automatic recognition of what type of batteries are used doesn’t work for me anymore. It says alkaline batteries but I’m using eneloop pro. Than it started to tell me the battery status is critical because of that, so I changed it manually to rechargable now for the time beeing

Had the same issue with the battery type recognition. Setting once correctly in non-auto mode, re-starting the lock and app and setting back to auto solved this.
One other thing: There is stated that the battery indicator can be tested in Homekit, but somehow I don’t find any battery indicator in the home app. Do I oversee something or do I need to delete and re-add the lock in my home?

Thanks, this worked for me

Same behavior here Akkus installed and Automodus tells alkaline. Set to Akku and back to Auto works to geht Akku back

No, you don’t need to readd it.
But the placement is quite hidden:

Hi, that was the first location I checked, I have some other devices with battery indicator. But, anyhow, it’s not there:

Ok, thanks. So it seems that there is a case where it disappears again. It’s also gone for one of my locks. Thanks for the feedback. This is why we call it “beta” … We’ll look into it and will report back once we know more.