Open door function problem


So I succesfully installed my new Nuki 2.0 with Nuki bridge but I’m experiencing very strange behaviour when using Open Door function that makes it almost unusable. When I try the function when the door is open (either locked or unlocked) everything is fine - it always unlocks the lock and pulls the latch all the way in so the door can open. But when I use it when the door is closed it only opens the door every 3rd attempt or so. On the unsuccesfull attempts to open it keeps turning but probably not long enough or strong enought to pull the latch completely in and the door stays closed. Only on the 3rd attempt in a row it opens the door. I tried to calibrate the lock when the door was open and also when the door was closed but that didn’t help.

It seems quite strange to me, because apparently the power needed to open the door is there it is just not applied equally all the time. I’ve been trying it and watching it for some time so I can confirm that the 1st attempt to open NEVER works. The 2nd attempt sometimes does (30-40%) but mostly doesn’t. The 3rd attempt almost always works (90%).

How to fix this?

App version 2.0.5., Lock firmware 2.3.1.

1 Like


I have seen similar problems and no solution yet, but I didn’t spend a lot of time.
I have Nuki 2.0 with the latest firmware installed.
When the door is open, I can see that the latch pulls back completely.
When the door is closed, the Nuki turns and pulls the latch, but you can’t open the door.
When I open the door from inside (while the Nuki still holds the latch), I can see that the latch is 2mm out - this means the door can’t open. If I turn the button of the Nuki, I can easily turn pull back the latch completely. I am not sure about the reason for that: Nuki 1.0 never had that problem. I don’t think that the power needed to pull the latch is too much. Turning the key manually, I don’t feel that more power is needed for the last 2mm. Can it be that, for whatever reason, the Nuki stops before the last 2mm?
Maybe I should try a new beta firmware to test if that changes something?

You should upgrade to FW version 2.3.11 (which is public now).
Please calibrate again after updating and check if this solves your issues or not.

1 Like

Tried that, the problem ist still existing. One out of three (or so) trials works - the latch is pulled back completely. During the other two, the latch stands out 1-2 mm, as described in my earlier post. This does not happen when the door is open.
I have dropped my debug report to

I got also a message that the batteries are nearly empty - after few calibrations and trials with the door; but this is not the cause of the problem, it existed also with good batteries. Not sure though why batteries are empty that fast.

1 Like

O.k., then please follow up with our support team as this seems to be an individual problem.

Please make sure there is no mechanical “obstacle” that prevents your latch from fully opening under certain circumstances.
I had a similar problem when I tested the Nuki Smart Lock at my parents house and it turned out the latch itself somehow got blocked after the first 80% of its full way into the door.
The cause for this was a very small edge inside the door mechanism (the part where the latch gets pulled into) that prevented the latch from getting pulled in completely in some circumstances. Especially when there was still pressure on the latch coming from the door frame.



1 Like

Hey! I upgraded to firmware 2.3.11. I noticed that under Optimize locking is now Custom option which allows to offset the key rotation in both directions. Is that a new feature? I haven’t seen it before I think. I played a little bit with that and found out that although it says that these settings do not affect in anyway Open door function for me they actually do. I have a safety door that uses extra safety hooks on the side that come out when the door is locked and they hook into the door frame (see on the picture). The problem was with the hooks - when I used Open door the latch was probably always pulled in but the hooks remained sometimes a few milimetres out which prevented the door from opening.

I changed the settings on unlock motion to turn extra 20 degrees in the unlocking direction and it fixed the problem. Now the hooks get pulled in completely and the door opens every time.

But I also noticed that the 3 preset modes in Optimize locking (Normal, Reduced, Extremely reduced) don’t work correctly. With Normal the latch comes out 1,4cm when locked, with Reduced 1,6cm and with Extremely reduced 1,8cm. I would expect the opposite.

No, this is not a new feature. Has been there in earlier FW versions too and is also available for Smart Lock 1.0.

Your door uses a so called “multi point lock”. In this case reducing the locking distance can lead to an engagement of the “multi points” while the door latch is still not engaged, thus it is not possible to reduce the locking distance in such a scenario. Interesting is that in your case the “normal” setting which are our “known to work with as many locks as possible” default values, already seem to engage your multi point latches a little bit.

Hi Christian,
yes, I 'll look into this.
I suspect this might be the case. If the door is open, then the force required is equal, but when the door is closed, then the resistance is a bit higher during the last degree of keyturn. Even though, this was never an issue for Nuki 1.0

Thanks Jiri, I will try if I can find the option to turn extra degrees and if that solves my problem.

I have seen the same situation. FW 2.3.11, calibrated. But time to time it stuck, does not open. Also like battery claimed, new batteries were inserted yesterday!?

Please send a log-file with a short description of the problem and the exact time when it occured to our support team at, so they can check the details of what happend.

I have adjusted the lock mechanism of my latch, so that less force is needed. it works now
I haven’t seen the need with Nuki1.0, it seems that 2.0 has less torgue, but that’s just my judgement.

I have the same problem with my Nuki 2.0. Nuki v1 could open my door without any problems, but with Nuki v2 I have to pull my door while Nuki turns the key so that It needs lees force to open my door. Alternatively I need to submit an open door command 3-5 times…eventually Nuki opens my door correctly.

I tried to detect a schema when it works on the 2nd or 3th attempt, and when I have to try 5 or even more times. Without success. I even changed my new batteries, that didn’t help either. Software version is 2.4.5 and I’ve turned off the lock optimization.

Strange, I had no problems with my old Nuki 1… Any Ideas?

Hi. Reviving a relatively older discussion. I recently bought Nuki 2.0 and seem to be facing the exact same issue every now and then. Is there a way to configure Nuki to keep turning till there is resistance rather than a pre configured degrees. When it does not work I am attaching a picture of the situation. 20190403_205342

This seems to happen mostly if somebody used the key to lock&unlock the door. And who are using the key to manually unlock&lock I cannot ask them to use the app.

Just to be clear about your setup:
Do you want the latch to be pulled in these cases and it doesn’t pull far enough? (Which would hint on a battery problem, as for “open door” it always turns until there is full resistance and not to a certain point.)
Or do you just want to unlock and the latch gets pulled unintentionally? (Which would hint on a lost calibration due to manual usage before.)

Which Smart Lock firmware are you using atm?

I would want the latch to be pulled all the way. I did not know that it does should turn all the way. Looking at the situation I thought it turns a certain degree. I just bought it a few weeks ago and using the included batteries. Thought they should be good enough. I will replace the batteries and update. Will have to wait till Friday as I am out of country till that time.

BTW firmware version is 2.4.5.


Same problem here with nuki 2.0 firmware 2.4.5. Once in a while, after an open door command, the door latch remains 2 or 3 mm outside the door frame. I.e. It doesnt completely slide in the recess. I never seen that problem before on the nuki 1.0. I tried the “optimize locking” menu but there is not setting for adjusting the turn angle for an open door command. The advanced calibration adjustments setting are not cristal clear by the way (a help menu would be welcomed). So I am bit a clueless on how to solve this problem.

Is there a fix?

“Optimize locking” just tries to reduce the locking distance to save energy and time.

If the latch remains outside the clutch must still be engaged. Do you see any error in the activitly lock (like battery warning or Motor blocked?)

Although I did not have a battery warning or anything,but,after replacing the batteries I have not had that issue occur again.