Open and Ring To Open doesn't work automatically


My Opener and Smart Lock are working fine, but unfortunately my Opener with activated Ring to Open doesn’t work as expected.

If I enter the geofence area I get a notification on my smartphone, that my opener is listening for an incoming ring and will open it automatically for me. “Cool that’s working” I thought but when I press the door bell, the opener doesn’t open it. There’s nothing in the protocol history. I have to manually activate “Ring to open” in the app and after that I can ring the bell and the Opener opens the door for me.

How can I fix this so that the Opener will open the door automatically for me?


I checked the protocol again and found something interesting.
Here is the scenario of today:

  • I entered the geofence area at 01:05 pm
  • I got a notification on my smartphone that “Ring to open” is active and opener will open the door for me
  • I rang the bell at 01:06 pm
  • Opener didn’t react
  • I started “Ring to bell” manually in the app
  • I rang the bell at 01:07 pm
  • Opener opened the door for me

in the protocol history there were following entries:

  • 01:06 pm unkown person rang the bell
  • 01:07 pm Opened (Ring to bell) through me

So opener didn’t know that I was near the house at the first ring, but I got a notification on my phone. So any ideas what is going wrong?

Try to set the Geofence up to 200m.
Then get the Nuki App more time to synchronize your positions with your opener.
Your Opener App Notifications “Bell” doesn’t shows notifications? Means all needed Android settings are correct, like Android Battery management?

Ok, I raised the geofence area up to 200m - let’s see what’ll happen next time.

Well my opener app shows a notification that “Ring to Open” is active, but after I rang the bell, the opener in my home didn’t realize that I’m near my home and thought that someone else activated the doorbell. Maybe you are right and the bigger geofence area gives the opener more time to finish synchronization. I’ll keep you up to date.

Battery management is set up correctly.


btw. do you know what’s up with the energy saving settings in the opener app. Currently the value is set to “automatic” and the description says, that this setting only relates to the bluetooth scan interval. Does it also affect communication via the bridge when I’m not at home? Maybe I should change the setting to a mode, where the opener syncs with the app more frequently.

When the energy saving is automatic then could this be a reason for a not correct working Ring to Open… For example, at the beginning of the Nuki App it was very difficult to get Huawei devices working together with Nuki (Android 8 & 9) but it seems they did fix this problem.
The energy saving need to be Manuel and all three sliders to on. This setting & and the Geofence up to 200m should fix your problem :blush:

1 Like

Last entry today worked as expected…keep your fingers crossed that this fix is permanent…anyway I’ll mark your answer as accepted solution :wink: thx

1 Like

Unfortunately I still have problems with Ring To Open. My app notifies me that RTO is active, but the opener doesn’t open it. If I manually active RTO on the phone, it works.

I now tried something different. I disabled RTO activation in the app and set up a node-red flow in my home assistant system where I start a HTTPGET request to the nuki bridge


If I enter the geofence area, I trigger the RTO activation via the bridge. Sometimes the request fails with Http Status Code 503 (Unavailable) and therefore my flow tries to activate RTO several times. Maybe this is also the problem with the NUKI app !? Sometimes the call succeeds the first time, sometimes not - very strange.

The last 5 unlocks with node-red and activation of RTO via the bridge were all successfully and very promising for me.

If someone is also struggling with a non working RTO and want to control this feature self hosted via node-reed (geek-alarm) feel free to contact me :wink:

Had always a good experience with a open delay of 1sec.
Without delay I had problems with non working RTO and with a delay more as 1 sec I had also problems.

1 Like

This (opening delay = 1 sec) did the trick on my installation. Much aprriciated!

1 Like

In my case it works only with 3 seconds delay. Will try with other values and see if something has changed with latest updates.

I’ve activated DEBUG mode two weeks ago and since then my opener works flawlessly. I don’t know if it is just a funny coincidence, but trust me - as it works, I dont’t care about it! :wink:

So if anyone is also struggling with a non working opener, try to enable debug mode.

1 Like

cofirmed. Debug mode seems to permantly deactivate the deepsleep.

Hey Peter, I have the same Problem, where can I enable the debug Mode?

Here are the instructions:

btw. my opener is working as expected the last few months - debug mode is activated

Hey there,

now I have installed the 1.6.4 Firmware and the general issue is still present. Setting a higher delay or activating Debug mode seem not do have an impact anymore. Can anyone confirm in 1.6.4 or is this issue only on my installation?


I have a problem with the “Ring to open”. Indeed, it does not work. That is, when I leave the Geofence zone (100m) and come back to this zone. If I press my building doorbell: nothing happens when my apartment doorbell should open my building door.

If I put the continuous mode, I manage to open the door of the building with my bell. Same thing via the application on my mobile.

Operator software version 1.6.4

I tried debugging mode but nothing helped.

Thank you