Callback from Opener to bridge slow

I have the latest betas installed on the bridge and the opener and did some testing with bridge callbacks when the opener recognizes a doorbell ring. Sometimes it takes up to twenty seconds till the callback actually is executed by the bridge. My connections are all shown in green in the app. Anything I can do or anywhere to check if connections are alright? The time to actually trigger an external ring notification is way to long like it is now.

I’ve had issues with delays or the bridge getting “stuck”

Read the thread here. One thing that seemed to help was to enable all notifications. But I still have issues

I also read in another thread that activating debug mode should be helpful.

How to:

Thanks, going to check that out although I really don’t want to get all notifications.

Same here. I just did the debug mode and that seems to fix it so far. Try starting with that. I’m gonna try to remove the notifications and see if it still works

I don’t get it: will I get some kind of confirmation after tapping 7 times? Seems like nothing changes.

Yes. You get a pop up where it says something like “checking debug status” or something. It’s kinda hidden/not obvious. But yes click the “Nuki Opener” headline 7 times

Maybe I am doing something wrong. I have activated debug mode under help, then I go into the Opener settings and tap its name (the headline) seven times? Nothing happens, I mean the screen isn’t that big you could miss anything.

It’s not the name of your opener, but the text that says “NUKI OPENER”

Thank you so much, got it. Sorry for my stupidity.

Since the latest opener beta 1.6.0 the callback from the bridge got almost instant. Way faster than before.

1 Like

May I kindly ask «how instant» it is for you? Less than 10 seconds? I’m not there yet on my end unfortunately…

Honestly it’s sometimes almost instant, sometimes like 15 seconds. I can’t test it though properly as I can’t ring myself and then speed up four floors - have to wait each time someone rings. The thing is: I have no idea how long the opener takes to recognize the ring. I just know for sure it’s not anything past the callback as I tested that manually and this works instant.

Ah I see. That’s what I thought — Instant is indeed very subjective.

I can confirm that it’s also around 8-15 seconds on my end. Unfortunately, that’s about 7-14 seconds too long for my expectations. I used to have the door opener which would send you Apple Push Notifications in less than 1 second anywhere in the world. My upper limit is 3-4 seconds maybe and I hope we’ll one day get there.

The best way for me to test the reaction of Opener is to turn on the sound. When ringing it detects the sound within about 1 second or less. It’s very fast. And then the big waiting begins.

Some of the delay is obviously known: No notifications before the delay, opening and sound have happened. This means if you have ring to open active, you will not receive a notification in less than Delay Time + Opening Time.

The other component is probably due to the interaction between Opener and Bridge. This is something Nuki has tried to fix in 1.6.0 apparently. I thought it’s still broken as 15 seconds is inacceptable to me, but in that case it was even worse before.

p.s. another way you can test the reaction: activate Ring to Open and then ring, and see how long it takes to open the door. It’s usually pretty fast and it confirms the speed for you.

Ring to open takes about 3 seconds for me.

Had the nello before too and was expecting the same response time from the Opener. :frowning:

Is there an explanation of the debug mode notifications somewhere? I have a similar issue in that my Nuki Opener on a Ritto Twinbus 7360 installation used to work fine, then out of the blue Ring to Open stopped working - I’m not sure when, but it was several weeks ago.

No amount of reconfiguring or re-cabling made a difference. I enabled debug mode and I get both “O” and “R” type messages for the Open buzzer and Doorbell rung case respectively, but the opener does not seem to register it “consciously” and doesn’t act on it.

Any hints are welcome…