Nuki Smart Lock 3.0 Pro Wifi issues with Fritz Powerline 540e

Hello together,

I’m using a new Nuki SmartLock 3.0 Pro together with an AVM Fritz Powerline 540e Wifi network.
I noticed that the Smartlock is from time to time not reachable via the Nuki app. I saw in the Wifi log that the Nuki Smartlock loses it’s connection many times per hour.

I tried out the latest beta firmware 3.7.4 with Medium power settings but it did not solve my connection issue. All other devices connected to that wifi do not have such an issue. I’m also using a second Smartlock connected to a Telekom Speedport Smart 4 Wifi without any issues.

Could the issue be related to FRITZbox 7590 ax issue with Wi-Fi smart lock 3.0 pro ?

Best regards

I got the same problem with TP link set.

Most likely has the same issue since the newer fritz versions are rolled out to other devices as well.

Not much we can do right now except to wait until either AVM accidentally makes it work again or until nuki gets a Firmware working with AVM products again.

AVM isn’t working to fix it anytime soon though, since they don’t see a problem on their end and neither can we expect a fix from nuki since they say it is an AVM issue.

Best thing you can do for now, is find a wifi router that works with nuki and use it’s wifi to connect your nuki devices, while attaching it via cable to the normal fritz network.
Seems to be the only solution for getting a reliable fix atm.

This is not correct and it is mentioned in the respective thread that AVM as well as Nuki are looking into it. Furthermore the latest Nuki beta firmwares provide a workaround which fixes the problem.

We did also look into the problem of the original poster in this thread and it does not seem to be related to the 7590AX problem.

Hi Juergen, sorry this is not correct. I have this problem with the 7590AX and no NUKI beta Firmware solved the problem until yet.

Then you should report your problem in the correct thread so that someone can have a look at it.

Hi Juergen
I reported my problem.
Tickets 304025, 313057, 313787, 321584, 324884.
It was solved by sending me a bridge.
But using the bridge is hopefully only an interim solution and the Smart Lock 3.0 pro will again work directly with a WLAN connection without a bridge in the future.

Your Smart Locks haven’t been online via WiFi since 3.7.2. Please give 3.7.4 a try and report anything you notice back in the Smart Lock 3.7.x beta firmware topic. Thank you!