Nuki Opener Handset GDX 23121 - Ring not recognised

Hi all I’ve seen a few similar topics but seems that no one has got to the bottom of this set up

I have ordered a Nuki set and I’m trying to set up Nuki Opener for my intercom GDX 23121 (pictures of schema and handset below). I am having problems with ring detection (automatic unlock)

Handset Below
handset

Established that on the schema

  1. Speech in (microphone)
  2. Speech out (speaker)
  3. 0v
  4. 12v

Tried a few things and this set up almost seems to work I’ve configured it as Generic Analogue mode
1 - Red
2- Orange
3 - Ground Purple & Black
Blue arrow - Blue Cable (Top right pin on the open button as suggested in the other topic )
Green arrow (TR2 pin) - Green Cable (As suggested in the other topic (GDX5 Intercom integration - #19 by danc)

If I ring up the flat and then manually open the door it unlocks, however automatic ring detection unlock feature does not work. So If I ring the flat message pops up “Call answered” but door does not unlock

I’ve measured TR2 Pin (which I use for ring detection) voltage which is coming through is 4.8v (Is that enough to capture the ring detection on green cable?)

Hey, not sure if that’s a typo - but I suggested using the red cable rather than the green for TR2. it sounds like the voltage is passing so you’re close.

Try going to the “Configure Opener” menu and pressing “Brand” item 5 times.

Although this has continued to work for me, I’ve found nuki firmware updates have reset my settings - specifically “Comparator invert” which is required. This flips the wire to mean that current = ring rather than an absence of current = ring. Here’s what my screen looks like - 4500mv is working for me.

Thanks for the info just wondering why did you use red and not green cable for ring detection?

I think that “Comparator invert” option was the last peace to the puzzle I will email Nuki to get this enabled and update the forum once I’ve tried it out

I believe it is because in the hidden analogue mode, the cables behave in a different way than standard documentation. You can see another example for another intercom here:

Basically red and black are bus+ and bus- for ring, and blue and purple are bus+ and bus- for opening.

I think that “Comparator invert” option was the last peace to the puzzle I will email Nuki to get this enabled and update the forum once I’ve tried it out

If you already emailed Nuki to enable the hidden analog mode, you can just access this menu yourself, as described in the previous post.

It sounds to me like maybe you didn’t enable hidden analog mode from step 1 which is why this might not be working.

Hey Dan, after Hidden analog mode got enabled I was able to finalise my set up. Manual open is working as well as automatic ring detection unlock

Final set up looks like this
3 - Ground Purple & Black
SW3 - Blue Cable (Top right pin on the open button as suggested in the other topic )
TR2 pin - Red Cable (As suggested in the other topic (GDX5 Intercom integration - #19 by danc ) (I have also tried Green cable and Yellow did not work)

Hey, i tried to open the hidden setting on my iphone. Seems that it is not possible anymore :frowning:

Does someone know how to open it on ios?

BW,

Patricia