Nuki doesn't open lock wth latest update android pie

Since I updated my Samsung s8+ the lock won’t open after I got the geo fence entering notification.
It opens when I wake up my mobile

This is a known problem (see Auto unlock problem with Android Pie) and we are working actively on a solution.
Samsung did some very strange things to the battery saving features in that update.
You can help us by sending us a Debug Log of your device. (We got Samsung S8+ here to test, but more information always helps!)

in the battery saving features also entries for “Bluetooth” and “BluetoothTest” can be found. Could it be helpful to turn off the battery optimisation for this both entries too?

For which device? I have never seen this yet.

Galaxy S8
I will try to change to “not optimized”

Thx, just checked it and saw the option on the new Samsung phones here too. Very strange that they would auto-optimize a system-function, but nothing surprises me anymore with the battery-saving “features” from some vendors. :disappointed:

EDIT: Our developers are aware of this and are already testing if this changes anything.

I tried the battery saving setting “not optimized” for the two bluetooth entries for a couple of days. For me this seems to have no measurable affect. Unfortunately no improvement :frowning:

Are there any news how to solve the android pie issue? Thx


Please check our new Android App Alpha:

We are looking forward for your feedback, if you want to test it out.

Seems to work fine again with the new version. No problems within the last week. Thanks for the fast solution.

1 Like

Same for me. Sometimes I have to wait in front of the door about 15 seconds and then the opening starts. Most of the times it opens as it should.

After the last beta update the behaviour of the lock is the same as I reported last time. Most of the time the door opens correctly but every now and then the opening delay is approximate 15 seconds.