Auto unlock problem with Android Pie

I applied for the beta app to test the new auto unlock. Since update to Android Pie (Samsung Galaxy S9+) the auto unlock isn’t working as expected (with Android Oreo everything was perfect). When i get in range of the geo-fence, i get the Auto unlock notification. But no matter how long i wait in front of the (still closed) door, nothing happens. I have to, at least, wake up the phone (unlock not neccessary) to get the auto unlock running. Befor Android Pie, i didn’t have to take the phone out of my pocket - the door just unlocked. I can provide a time protocol of the events if thats helpful in any way.

1 Like

Hi Martin,

The battery optimisation for Nuki App is turned off also on Pie right?


Hi Nirmal!

Sorry, forgot mention. Battery optimisation is turned off.
At least if there is no other “hidden” setting for app optimisation other than this:

Exactly the same for me. Also Galaxy S9+ and since Pie-Upgrade.

Also the notification is ON right which says “Nuki Smart Actions sind aktiv”?

Yes. Notification is always present. I also hear the notification sound when entering the geo fence with the additional notification that I am in range of the smart lock. But as long as i dont activate the phone in any way, auto unlock is not executed.


thank you very much for the feedback.

First of all, please make sure you have the Debug Mode enabled. This can be done via “Menu -> Help ->Debug Mode”.
After doing so, make sure you tried at least one AutoUnlock, so the events will be written to the logfile.
Afterwards send the Logfile via “Menu->Help->Send error log” and replace the email with "" so I will receive the logfile directly.

If possible, please also add additional information about when the unlock was supposed to happen and when/if you woke/unlocked your phone, as this also helps us at finding the issue.

Kind regards,


Just sent the debug log to the requested email address.
Also added a protocol with timestamps. Hope that helps.

Regards, Martin

The same for me. Galaxy S9 (without +) and since Pie-Upgrade.

You may find a solution with the Doorman app.

This is not a solution, at best a workaround!

We are currently investigating this issue and working on a fix for it.
In the meantime you can help us by providing a debug log and detailed information about your current energy saving settings (screenshots if possible) via

Kind regards,

Same for me, also using a galaxy s9. Auto unlock worked in a few cases after upgrading to pie. I have the feeling it works when the screen in the attached image isn’t shown when opening nuki over the status bar. I will send a debug log later.

Hi, facing the same issue with S9+ and Pie. I receive the notification that I’m near at “house” and the door will be unlocked when the phone will connect the BT of Nuki but nothing happens. When I unlock my phone or open Nuki app the lock start to open the door.

Good afternoon,

we have exact the same problems using a Mate 20 Pro. Sometimes the door opens, mostly not.

Will send some more Infos using the debug mode to you.



Hi, With the new update from Samsung (patchlevel february 1.) it is working again for me. Im not using auto unlock but only smart notifications.

With Samsung S9+ (and some others, I think), there is no improvement. :frowning:
By the way: The mentioned patch was already installed just after its deployment in 02/2019.

Try Doorman if you want the seamless experience. Keep Nuki for all management features.

I have the same issue on Samsung S8.
Is there already a fix?
I can not use doorman because I have no bridge…