Nuki 3.0 Pro looses connection despite AP is next to it

Bei Nuki für die Smart Lock Beta angemeldet ,freigeschaltet worden .
Manuell Firmware installiert ,keine Probleme mehr mit der neuesten Firmware :grinning:

Same here, I already traced the issue to the lock trying to contact sse* and which seemed unsuccesful causing a reconnect loop with your home wifi. Since a couple of hours the issue is gone. It’s obviously a cloud issue at Nuki side.

1 Like

For me it’s still not keeping a persistent connection. I can see it’s reconnecting often and the connection quality is very poor (around -50 dBm RSSI) even though there is an access point right next to it. The reconnection process ends with the SSE server that can not be reached (you can see this info by pressing 7x on the network header under the WiFi settings). I’m curious if more people are seeing the same.

Came from public release to beta 5.3.2 in hope to get rid off issues with wifi connection, yet it did not resolve… I have Unifi system (no changes in settings) but since last public release my wifi connection keeps disconecting on the lock…

Plus, I am unable to click on the title to enable debug, as the title is not visible? Or am I missing something?

The Apps UI has been reworked with the last release. To enable debug you have to Smart Lock > Settings > Features & Configuration > Tap 7x on the “Features & Configuration” headline.

There is a new beta available:

Same issue here since bought. I have created label for return it.

Tried different APs, reseted many times, just updated to 3.5.10 and same problem without solution.

Too expensive for so big issue.

Are you on a Unifi network setup. It would be nice to identify a pattern.

I am on Unifi and all seems working pretty nicely with the latest beta. M

@Juergen could you elaborate on what the Nuki SL3 Pro does when trying to establish a WiFi connection, specifically the step when it’s trying to connect to the SSE server. I have tried every thing to fix the unstable connection of my SL3 Pro but at certain times it just keeps failing to keep a connection and the debug wifi log tells me it’s either trying or has failed to create a SSE connection. I’d like to understand what is happening.

I must say that after update to 3.4.10, reset SL and App and connect it to a guest wifi, it is working perfectly now.

1 Like

There is nothing specific. It does the usual steps that any other product does when starting up WIFI and connecting to a server: scan for wifi accesspoint > join & authenticate to wifi > get an ip via dhcp > resolve ip of nuki server via dns > open tcp socket to ip of nuki server > establish secure SSL link > start to transfer data.

Your case is specific and different than all others because it works for some hours perfectly fine and then completely stops to work and then comes back after some hours, while usually stability problems result in frequent reconnects. → Therefore it does not make sense to discuss your issues here in the forum. Should be done either via DM or with Nuki support.

I can confirm that.

Reporting back here in case anyone is experiencing the same. The issue is caused by a Unifi UAC-U6-LR access point. Replacing this with a Unifi UAC-AP-Pro resolved the reconnection issue instantly. Apparently the Nuki SL 3 Pro doesnt play nice with this access point.

Reporting back here in case anyone is experiencing the same. The issue is caused by a Unifi UAC-U6-LR access point. Replacing this with a Unifi UAC-AP-Pro resolved the reconnection issue instantly. Apparently the Nuki SL 3 Pro doesnt play nice with this access point.

I’ve got nanoHD and the same problem.

we have a Unifi-Network at Home with a DreamMachine-Pro and four UAP-AC-M’s.

The new SL3 Pro loses the Wifi-Connection every few minutes.

Du you know a solutaion or a helpful configuration in the CloudKey?


I have a Nuki 3.0 Pro in use since yesterday and also have regular wifi connection drops.

However, I have found a way to establish a stable connection, at least for me.

What I have tried so far:

I tested with 2 different access points. With a TP-Link Archer C80 and a Netgear Nighthawk R7000. The Nuki lost the connection to the access points within a few minutes and did not re-establish it.

Both access points are actually configured as access points and not as routers. The CPE of my internet provider is still used as router/gateway (NAT, DHCP, …).

This was all without noticeable success.

An actual improvement brought the following:

I configured the Netgear R7000 as a router. So the router gets an IP address from my CPE, creates its own private network (with its own NAT and DHCP, no IPv6). This brought the desired success. The Nuki did not lose the connection over a period of 2 hours (before after a few minutes). The configuration of the wifi interface did NOT change!

Currently I have the following suspicion:
My provider (A1, Austria) uses a “ZTE MC801A 5G” as CPE and IPv6 support is enabled (cannot be disabled). If now the CPE is configured as router, then all clients also get IPv6 addresses (beside the IPv4) assigned (also for DNS).

This is currently my thesis why it comes to these connection drops with the Nuki.

I will now try to reconfigure my network so that the CPE no longer acts as a router.

Hope this helps someone.


Hi again.

Now. I call this a SUCCESS!

My nuki lock has now a stable wifi-connection (over the last hour or two).

What did I do:
I’ve reconfigured my CPE (ZTE MC801A 5G) to act like a bridge and not like router.
So the CPE is not doing NAT anymore. This is now done by my TP-Link Archer C80 (now configured as router, previously access-point) - so NAT is now done by the TP-Link device.

This change “removes” IPv6-support from my private network.
I’ve checked this by opening

My results now:

I didn’t make a screenshot before reconfiguring my network but I had some IPv6 connectivity before - I promise.

As I already mentioned … my ISP is A1 here in austria. And they are using a so called “IPv6 dual-stack”-setup. Find more about it here:

(all in german)

If you have any connection issue you might check if you have “IPv6 connectivity” available in your network. You can do a simple test by opening

@panu: Is this a known issue?



The problem in your case does not necessarily have to be IPv6 (which is unsupported and completly ignored by the Smart Lock), but could also be that the ZTE NAT solution does not allow/offer stable, low traffic tcp connections. In some scenarios we’ve seen tcp connections dropping as frequent as every 5 minutes, which leads to reconnect attempts of the Smart Lock. This overhead leads to a significantly increased power consumption of the Smart Lock.

With the current implementation the Smart Lock does also reconnect to WiFi in case of a tcp connection drop, which could lead to problems with the WiFi router if it’s done too often. It could have been the reason why you did not get a “stable wifi connection” too. There will be some changes to this logic with the next release, which is already in beta since some time.

I don’t have information on how the Nuki-lock handles IPv6. However, it is clear that this is a significant difference between the environments where the lock is functioning and not functioning (at least for me). And … a typical customer would have likely returned the lock instead of spending hours trying to resolve the issue.

I am already using the beta firmware v3.5.6. Upgrading to the latest beta version was my first step and unfortunately, it did not result in a better (more stable) Wi-Fi connection for me.