Nuki 3.0 Pro repeating Log on/ Log off at Fritzbox

After surviving the very annoying “position detection” issue, I have identified a different problem with the internet wifi module that starts to p***s me off.

My 3.0 Pro permanently log on and log off at my AVM Fritz box 7590, which drowns the battery quite fast. Within two weeks battery back is down to 52%.

Distance between router and smart lock is less than 5 meters.
And once again, I can’t image that the internal wifi module has such a weak antenna signal.

Sadly my 30 days return guarantee have exceeded yesterday…

I was absolutely satisfied with my 2.0 and am so disappointed by the 3.0 Pro!


Such a behavior can have several reasons. If the Smart Lock can not hold the connection to the Nuki Servers it completely shuts down the WiFi connection and restarts it after some time. So, it could be a broken internet connection or problems with your router.

Nuki put together things you could try:über-das-WLAN-Modul-verbessern
Also fritz has suggestions: WLAN-Gerät stellt keine Verbindung zur FRITZ!Box her | FRITZ!Box 7590 | AVM Deutschland

Jürgen, thanks for trying to help me.

Even with WPA2 enabled (WPA3 disabled) and going down to 802.11b the lock ist not able to hold the connection (as the only device in my network). Even with established link to my router, the lock is not able to connect to your Nuki servers.
I tried all your “good practice” but nothing works for me.

When i was facing the position detection problem, i placed an old Fritz!WLAN 310 close to my Nuki 3.0 and the frequency of position detection was reduced.
I assume, that either the WiFi module shuts down to early or the internal WiFi module is showing some malefunctions.

Bridge and Nuki 2.0 showed absolutely no connection losses…

Looks like a problem with the internet connection and not the router itself. I’d try it with a different uplink (e.g. a hotspot from your mobile phone) and check if that fixes the problem.

I had the same problem, but no response from Nuki support. Lock 3.0 Pro and Fritzbox router. Hundreds of wifi reconnections, web lags (lock was unlocked and I was notified after 45min). I have even tried different router and it was the same. Useless…

As I check now, my topic about this disappeared??? URL was:

I resolved the problem with Nuki Bridge and turn off builtin wifi. Now it seems everything ok…

1 Like

@ChrisNes are you maybe using the fritzbox labor firmware? Interestingly I have the described issue with my Netatmo outdoor, but not with the Nuki 3.0 Pro

Currently, I am using Fritz Labor. When i was facing this issue I was on 7.29.

Since Nuki has implemented some server improvements, connection to Nuki servers and the wifi connection in general is more stable.
Battery drainage has improved as well

Ok, for me it started in mid of the 7.39‘s while HomeKit moved to iOS 16.
But the WiFi of my Nuki is running smoothly

What can help was to set the 2.4GHz network to a fixed channel and not use auto-channel. Whenever the fritzbox changes the frequency most devices are disconnected and need to scan and reconnect to a network (including DHCP, setting up sever connections again and so on).

This fixed for me all disconnect issues with Netatmo devices on 7.3x.
It also helps the Smart Lock to be more energy efficient and to experience less disconnects.

Same issue here.
Just detected that my nuki 3.0 is continously logging on and off on my fritz repeater 2400. The distance of the two devices is 2m. No wall between them.
The 2400 is in a mesh net with with two other 2400 repeaters. Master is a fritz 7590.
Any ideas how to improve?

Good day to you all! Same problem here:

I own the Nuki 3.0 Pro since yesterday and I did immediately experience the same issues described here (or in the “Nuki 3.0 Pro looses connection despite AP is next to it” thread) with my 7590 (non-AX).

This afternoon I tried the current beta firmware (3.7.2) and setting battery energy saving level to middle, but the result you so see above: no change.

From all I’ve read so far, the basic version of the Nuki with the external bridge would have been a working and safer bet.

Is here a fixing planned? In the works? Are there other things to try out currently?

Edit: I would not care much about all those reconnects, but of course within the app I have to wait minutes until I can perform things again. And the Web Interface reacts not at all or delayed, too…

@Joda1987 @Haughton

Do you have 7.50 or 7.56 on fritzbox?
If yes look here:

7.56 and thank you, but there seems to be no valid solution in that other thread.


Workaround function is only in medium energy saving and i have still 3.7.1 on nuki smartlock.
Although I’m in beta tester, I still haven’t received the firmware 3.7.2 notification. I wouldn’t want the old solution implemented in 3.7.1 to not be in this one

I uploaded the 3.7.2 to the NUKI yesterday. But I can not recognice any improvement. Maybe the duration between the log on/ log offs is a bit longer as with the old FW.
With the new FW the period is between 5 -20 mins.
Any other ideas?

The workaround is only for 7590AX and does not have any effect on other Fritzbox models. Please follow the beta firmware channel for further updates or changes.

This 25eur investment would most likely solve it: OpenWrt settings for Nuki Smart Lock

Meanwhile any solution? I thought its solved. Just saw its still happening all the time…

The issue with Fritz Box 7590AX (and a few other AVM models) should have been fixed within latest FritzOS releases.

Then of course there can be other problems stemming from other products/providers involved in your setup. If you have not yet tried it, this should could help: Nuki 3.0 Pro Connectivity Issues with MQTT Broker on Home Assistant - #6 by Juergen