Nuki 3.0 Pro Connectivity Issues with MQTT Broker on Home Assistant

Again had to reset the mqtt connection, it took 5 consecutive attempts for the device to finally re-connect, is anyone actually looking into it? Its so flacky its beyond useless

1 Like

You are posting in a Smart Lock 3.0 thread. There is a seperate topic for 4th gen and yes, there have been many changes in recent betas:

There are still problems with the MQTT connection.
The Wifi connection is stable, I use ubiquiti AP’s

After my weekly update and restart of Homeassistant and MQTT Broker, my locks become unavailable in Homeassistant.
24h later they are still unavailable.

Locks are on version 3.8.7

After I re-entered the MQTT password in the mqtt settings, the entries in homeassistant/lock/… were published again and the locks were available in Homeassistant


And like it is always at Nuki if you have Problems… Nothing real helpful happens.
Since Months I have Problems with my Android Phone to simply open the Nuki if i am at my Door.
About 1 Year ago the Nuki worked fine in that case with older Firmware!
To me it feels like with every new Version there are more Bugs than it would be an Improvement!

Seems that unfortunately I have to join the discussion. I have the same problems mentioned above. SLP3.0 has firmware 3.9.5. It’s in a stable Wifi connection, but MQTT disconnects constantly. Sometimes reconfiguring fixes the problem for a few hours, but it definitelty loses it’s connection to the broker (Home Assistant MQTT Integration) everytime soon or later! Does anyone have any hints how to fix the issue? I bought the SLP 3.0 just for the reason that it has MQTT Integration directly implemented, but at the moment it’s more than useless… :frowning:


P.S.: Energy Saving Mode of the SLP3.0 is medium

You might try the latest beta: Smart Lock 3.10.x Beta - #23 by Juergen

And energy saving fast: Smart Lock WiFi/Thread/MQTT connection troubleshooting / FAQ

Thanks for your fast reply @Juergen
I will give the beta a try an will report back, if the issue still exists.


The Beta FW has fixed the issue.


1 Like

With firmware 3.10.1 and at the same time upgraded my Fritzbox 7590 to labor firmware 7.90-113459 Beta, seems that my Nuki work better in term of stability. I’ll test it for several days before before singing victory. Anyway we are in the right way

Hi there,

I had similar WiFi issues. I am using a mesh WiFi. After disabling mesh in my WiFi system for the IP of the Nuki smart lock, it is stable now. The Nuki is firmly linked to and locked into the closest mesh router.

It may help if those who have problems here, inform whether they have 1 single WiFi router or use mesh technology as I do.

Regards, Horst

updated to 3.10.2 was ok for a few hours, ths morning again no connection to MQTT and Home Assistant, then it came back. I think it is on the right way but not yet stable.

As I wrote this it’s gone again…
It is the only MQTT device that makes porblems over 140 Zigbee iwth no issues. My net is Unifi Router, AP & Switches.

While 3.10.1 worked finde with my HA setup, 3.10.2 brings all the MQTT drop.offs back. Thank you for this downgrade…

I have WiFi and MQTT issues. On 3.9.5 with 3.0 pro and the WiFi drops everyday and seems to forget the connection details.

I have to try and connect to the WiFi a few times before it would accept the username and password.

I cannot get it connect MQTT at all.

It didn’t use to have this problem and I have automatic updated turned on.

MQTT worked almost a year for me (Nuki Pro 3.0), then the device regularly lost connection to Home assistant. For this reason I installed 3.10.1 that was reliable. I forgot to switch off the auto update function. Now, I am on version 3.10.2 and the same problems occur as before.

I bought this device so I do not have to hide my key outside during jogging. Today I could not even open my door with the Nuki app on Apple Watch (I had Wifi connection and mobile data on). Now, I know that the device fails its purpose. I will now look for other products on the market.

I agree. The lock offers MQTT interface that does not work. If support would be as quick as they’re deleting negative posts in this forum, they might be able to solve the issue and provide the functions they’re providing and selling…

Is this possible with a FritzBox Mesh (to take one single IP out of the mesh)?

After too many drops due to restarting Home Assistant, I decided to setup my MQTT broker outside of home assistant.
It looks like I now can connect to the Nuki 3.0 but I don’t get the battery data in home assistant.

Main Battery (sensor.main_battery)
MQTT discovery data:
Topic: homeassistant/sensor/nuki_1234A_battery_percent/config
   availability_topic: nuki/1234A/connected
   state_class: measurement
   entity_category: diagnostic
  device_class: battery
  state_topic: nuki/1234A/batteryChargeState
  payload_not_available: 'false'
  name: Battery
    identifiers: '[1234AC]'
  unit_of_measurement: '%'
  unique_id: 1234A_lock_battery_percent
  payload_available: 'true'
  platform: mqtt

How can I fix this ? I don’t have that problem with my Nuki 4.0

Sadly, not.
I use a dedicated Fritz Repeater that isn’t part of the mesh now, with a different SSID.
This works fine.

I think almost all of these problems people had over the past year (problem with specific IP ranges what took very long to fix, MQTT problems that are still not fixed) arise from the custom Network stack that Nuki implemented to save battery, instead of using reliable and well-proven standards.

I disabled updates months ago and my setup with dedicated AP + more default IP range works flawless since that time.
Won’t update this setup anymore, as long as I’m not forced to.

I still got this issue even if you use a specific repeater out of the mesh, seems to be hopeless.

Version 3.10.3 solved everything for me. Not a single connection loss since the update. Its stable on my fritzbox modem with MQTT and works fast. 3.9.5 was hell and failed MQTT after 5 min or so connected