Nuki 3.0 Pro Connectivity Issues with MQTT Broker on Home Assistant

While 3.10.1 worked finde with my HA setup, 3.10.2 brings all the MQTT drop.offs back. Thank you for this downgrade…

I have WiFi and MQTT issues. On 3.9.5 with 3.0 pro and the WiFi drops everyday and seems to forget the connection details.

I have to try and connect to the WiFi a few times before it would accept the username and password.

I cannot get it connect MQTT at all.

It didn’t use to have this problem and I have automatic updated turned on.

MQTT worked almost a year for me (Nuki Pro 3.0), then the device regularly lost connection to Home assistant. For this reason I installed 3.10.1 that was reliable. I forgot to switch off the auto update function. Now, I am on version 3.10.2 and the same problems occur as before.

I bought this device so I do not have to hide my key outside during jogging. Today I could not even open my door with the Nuki app on Apple Watch (I had Wifi connection and mobile data on). Now, I know that the device fails its purpose. I will now look for other products on the market.

I agree. The lock offers MQTT interface that does not work. If support would be as quick as they’re deleting negative posts in this forum, they might be able to solve the issue and provide the functions they’re providing and selling…

Is this possible with a FritzBox Mesh (to take one single IP out of the mesh)?

After too many drops due to restarting Home Assistant, I decided to setup my MQTT broker outside of home assistant.
It looks like I now can connect to the Nuki 3.0 but I don’t get the battery data in home assistant.

Main Battery (sensor.main_battery)
MQTT discovery data:
Topic: homeassistant/sensor/nuki_1234A_battery_percent/config
   availability_topic: nuki/1234A/connected
   state_class: measurement
   entity_category: diagnostic
  device_class: battery
  state_topic: nuki/1234A/batteryChargeState
  payload_not_available: 'false'
  name: Battery
    identifiers: '[1234AC]'
  unit_of_measurement: '%'
  unique_id: 1234A_lock_battery_percent
  payload_available: 'true'
  platform: mqtt

How can I fix this ? I don’t have that problem with my Nuki 4.0

Sadly, not.
I use a dedicated Fritz Repeater that isn’t part of the mesh now, with a different SSID.
This works fine.

I think almost all of these problems people had over the past year (problem with specific IP ranges what took very long to fix, MQTT problems that are still not fixed) arise from the custom Network stack that Nuki implemented to save battery, instead of using reliable and well-proven standards.

I disabled updates months ago and my setup with dedicated AP + more default IP range works flawless since that time.
Won’t update this setup anymore, as long as I’m not forced to.

I still got this issue even if you use a specific repeater out of the mesh, seems to be hopeless.

Version 3.10.3 solved everything for me. Not a single connection loss since the update. Its stable on my fritzbox modem with MQTT and works fast. 3.9.5 was hell and failed MQTT after 5 min or so connected