Keypad stops working after a few days

Dear all,

Apologies for posting on here as I’m not a developer, however I’ve got absolutely nowhere dealing with Nuki support.

I have been using a couple of Nuki smart locks for the past 3 or 4 years. One of these I’ve been using with a Keypad with absolutely no issues. However, towards the end of last year the Keypad stopped working correctly. The Keypad would work fine for a day or two, then simply stop working. The lights would come on, the top LEDs would light up from side to side, and then it would simply flash all LEDs and give up. The activity log does not show anything. The only way I can get it to work again is to power cycle the Smartlock, after which the Keypad would work for another day or two before it would stop working again.

I went through Nuki support and after a lot of backwards and forwards and endless resets of both the Keypad and the Smartlock, they eventually sent me a replacement Keypad. Unfortunately, the new Keypad suffered from the exact same issue. Nuki support then gave up.

I then bought a new Smartlock v3 to replace the original v2 in the hopes this would solve it. To my dismay, the problem persists.

I recently discovered the Bridge was playing up and struggling to connect to my WiFi. No idea why, as again this had been working fine for years. I’m guessing component failure. So again, I’ve replaced this with a new model. The new model connects fine and I can’t see any problems with this. The Keypad appeared to be working ok, however after a few days, once again, I found it wasn’t working. Power cycling the smart lock resolved the issue, again.

So I’m in somewhat of a quandary. I have replaced the Keypad, the Smartlock and the Bridge, and yet the problem persists. The Keypad is very close to the Smartlock, with the signal only partly travelling through the doorframe. However, it had worked for years without issue. I can only assume a firmware update has caused something to break, however I can’t find anyone else experiencing this issue and Nuki support are tapped out.

I have a second Smartlock v2 on a different door that works fine, however this doesn’t have a Keypad. I also use HomeKit, which works fine. It is only the Keypad I struggle with.

Has anyone seen this issue? Does anyone have any ideas? At the moment, the only way to keep it working is to power cycle the Smartlock every couple of days, which is clearly nonsensical.

1 Like

We were able to replicate the issue just recently in our Lab and a fix is coming soon. I don’t have more information to share for the time beeing, but disabling HomeKit reduces the likeliness of it to happen. Once the Keypad is stuck only a reboot of the Smart Lock helps.

We will update this thread once an update is available.

Amazing! Progress! I predominantly use HK to control the Smart Lock with the Keypad mostly being used for guests, so I’ll just have to continue to endure until the fix is released.

I’m happy to beta test any new firmware if that would help.

Hi Richard,

The announced beta is available as of today.
Just send me a PM with your Keypads Nuki ID and I’ll enable the beta for your device.
The Nuki ID can be retrieved inside the keypad management within the Nuki app.

best,
Marc

Thanks. I’ve sent you a PM.

You should now be able to update your Keypad to the beta version.
Looking forward to your feedback.

Thank you, I have now updated to version 1.9.0. I will let you know how I get on.

1 Like

My apologies, I am also not a developer but only here I found a topic about a problem like mine.
For the past few weeks, no user has been able to unlock using a keypad that behaves as if everything is fine, when entering with a PIN, the LED lights light up from left to right and back as if the lock will be unlocked, but nothing happens. When I want to lock with the < key, the lights work the same as if they would lock, again nothing.
I reset Smart Lock to the default settings (not the factory), but still nothing.
I’m hoping for a firmware release soon because it drives us crazy that when we work around the house and every time we want to get in for something we have to carry a phone with us.
Thank you for any advice.

Smart Lock 2 HomeKit + Keypad- all updated

If you’d like to test the new keypad firmware as well just send me a PM with the Nuki ID of your keypad.

I am pleased to report back that having updated the firmware back on Friday, the Keypad has continued to work without fault for the past 5 days. Previously, it would’ve stopped within 2 days, so it would appear the problem has been solved.

3 Likes

This is great news. Thanks for the update.

I’ll update this post once this beta had been released to the public.

It appears I spoke too soon. The Keypad worked great for a week, however when I went to use it this morning the problem had returned. The lights moved from side to side then all the lights flashed. No errors, just nothing happening.

There seems to be a few issues going on. The door sensor is also being sporadic. The door didn’t recognise it had been closed. However now appears to be working, again.

Did the Keypad now fail only once or did you try it multiple times this morning?
Have you changed anything on the Keypad or the Smart Lock to get it back working or did it just work again on the next try?

Regarding the Door Sensor, is this new or did you experience this behavior already earlier?

The Door Sensor might have been a temporary disconnection, as it subsequently started working again. This is new to me, as I previously had a Smart Lock v2, so I don’t know how it usually behaves.

In respect of the Keypad, I left it all day and unfortunately it didn’t work. I tried it numerous times throughout the day and it wasn’t working, just like before. In the end I power cycled the Smart Lock and the Keypad started working again. Unfortunately, it appears the problem is still present, albeit it doesn’t appear to manifest as quickly.

Hello,I have the same problem since today with the keypad, is there already an update?

Right now you can only try our Keypad beta firmware if you send me the Nuki-ID of your Keypad as mentioned above.
But as pointed out by Richard it seems to not solve all cases yet.
However, any feedback is appreciated so if you want to test it, just let me know.

1 Like

@Cardo Have you been able to unlock the door with the app in that case or did you use the key to open the door?

When the Keypad stops working, everything else seems to carry on working correctly. I can use the Nuki app or HomeKit to lock/unlock quite happily. I haven’t used keys in years.

After power cycling the Smart Lock on Friday, the Keypad has continued to work. Last time it worked for 7 days before it failed, so will see what happens over the next few days.

Buenos dias. Desde ayer tampoco funciona mi Keypad. No consigue conectarse con Smart Lock.
Qué solucion hay ???