Keypad stops working after a few days

An update to this. After power cycling the smart lock back on the 25th March, the keypad has continued to work as expected and has now been working continuously for 10+ days. I don’t know what happened last time, but things seem to be looking better. I shall continue to monitor and update if there’s any further issues.

2 Likes

Gracias Ricardo. Pero al apagar y encender el Smart Lock, se pierde la configuracion previa ???

Hola de nuevo Ricardo. Siguiendo tus instrucciones, he quitado y vuelto a poner la bateria, y el problema se ha solucionado. Espero que dure !!! Muchas gracias por la informacion.

Having posted the above, today things aren’t working. I am completely unable to connect to the Smart Lock. The Keypad doesn’t work, but neither does HK or the Nuki app (directly or via the Bridge). I have locked the door with a double press of the button whilst I go to work and will see if the Smart Lock comes back to life by the time I return home.

I’m so happy I found this thread (only because I have the exact same issue). The only way for me to solve it is by rebooting the smart lock every few days. A real pain. Are we looking like we’re getting closer to a solution?

Same problem here…keypad just stopped working,replaced under guarantee worked for a day and then died on me again.
Any news on the firmware release?

Make sure that you join the beta channels of Smart Lock and Keypad Firmwares. There are new versions for both devices available that aim to fix the problem.

Interesting. I believe only my Keypad is on the beta firmware. I have asked for my Smart Lock to be added to the beta firmware list.

thanks for the reply!where do i join?

It is described here for every platform: Nuki Beta Program - Nuki Developers

1 Like

@Juergen
I‘ve got the same issue - every few days i have to restart my Nuki 2.0 so that the keypad works again.

Is this fix „already“ available in any stable firmware versions?

@Mucki
Yes, there are dedicated beta versions available for Smart Lock 2.0 as also for the Keypad. Please DM me if you want to join this beta.

Thanks - but is there any timeline to get this fix without joining beta versions?

@Stefan_Reiterer
@Juergen

Any timeline for a fix without the need of beta?

I have been having this issue since late last year as well. It has been so frustrating because I have been using the Nuki lock with the Keypad since day 1 for the last three years. It was rock solid up until like early winter late year. At first I thought the batteries were borderline and on cold days it just didn’t get enough current to power the connectivity antenna.
Battery change had no effect and only a power cycle of the Nuki lock unit fixes the problem. Sometimes it goes a week or more without issue and then it sometimes reoccurs after just a few days.
I’m so happy that I finally came across this thread because I was thinking about replacing the Nuki lock to see if that would solve this. The keypad is very important to us and I’m hoping this update that fixes the idea releases from beta soon.

Hi @Mucki and @Caleb_Alexander ,

currently we have a bugfix implemented on both the Keypad and the Smart Lock.

For the Keypad the firmware including this fix has been publicly released this week (version 1.9.2), therefore you should be able to install this update by using the Nuki app.

For the Smart Lock 2.0 we are currently in the verification phase as we have a potential fix available within the latest Beta version. Usually Nuki does not share any insights on the release timeline, but in this certain case I can tell you that the public release including this fix will be available until latest beginning of June.

Ok, I installed the update for my Keypad last week on Friday. Happily I have not had any cases where the keypad didn’t open the lock since then. It has been a whole week, and I think this update has solved the issue. Thanks Nuki team. I can now continue being a vocal evangelist for your products!