Calibration through the app is not possible anymore

Unfortunately after charging the power pack of my Nuki 4.0 pro, the Nuki lost its calibration…

Re calibration via the app is not possible, the app says: „Bluetooth connection required“ of course there is perfect Bluetooth connection.

I tried it with 4.2.6 and 4.2.8

The lock runs on Mqtt over thread connection.

What the heck is wrong here - it’s very poor when re calibration is not possible anymore.

Seems that Nuki in general is still beta. For such a pricy product this isn’t aceptable.

Brand new 4.0 pro and got the same problem. Next to the lock with internet and Bluetooth running. Keeps popping up. Without calibration no way to use the lock. Tried to reinstall etc etc… :frowning:

I had similar problems with a SL4. Do you use an iPhone? I found out that if I turn off Wifi and mobile data the calibration worked without the connection problems. As if bluetooth is disturbed/interfered by the WLAN and/or cellular signal.

Sorry for the inconvenience. We’re having a look into this at the moment. Keep you updated.

In the meantime: please enable flight-mode on your iPhone and enable Bluetooth when performing the calibration as a workaround.

1 Like

This issue will be fixed with the next release, a beta will be available later this week.

1 Like

I got the same issue with a new pro 4.
The airplane mode workaround does not work for me as it claims that I need to update the firmware but cannot, unfortunately. Says Bluetooth is not in range (it is).
I also charged the batteries for 10 hours. To be sure.


The firmware update is a different issue. We’re currently looking into this issue. Sorry for the inconvenience.

Well then, I have both issues as I cannot calibrate a brand new lock since it claims I have to update the firmware. And obviously I can’t and getting the same bt message as everyone.
In addition - if I just reopen the app - the settings page says the firmware 4.0.7 is “up to date”. That is until I try to calibrate.
Hope this helps in debugging.

Is this a P1 issue internally yet? I would feel it is: New locks are beeing returned because buyers think the unit is broken.

(And I cannot blaim them…)

You do not have the same issue than posted here. Firmware 4.0.7 requires a firmware update before the lock can be properly used. → This topic is already covered here: Smart Lock 4.0 Error During Configuration

As mentioned, we’re looking into it. Please follow the topic linked above for updates.

The latest public beta of the iOS app fixes the calibration issue: APP UPDATE: Nuki iOS App 2024.5.1-Beta.