Smart Lock 4.0 Error During Configuration

I am trying to set-up a Nuki Smart Lock 4.0 at my cousin’s house, but there is a problem. I can find the Smart Lock and start the configuration, but when it’s time to calibrate the door, the app says that I have to update it. I click on “update”, but then the app says “you must be in the Bluetooth range to do that” (error 500). The problem is that I am in front of the door, so there are no Bluetooth issues.
If I skip the update step (and don’t calibrate the door), I can enter in the Smart Lock options and see the status: the door is correctly connected to my phone Bluetooth and to the server, but as soon as I try to make another action, a message saying “the phone is not in the Bluetooth range” appears.
I have done the configuration process with both iOS and Android, the result is the same.
Anyone has a solution for that?


No solution but I am experiencing the exact same error at this moment. New lock, just out of the box but I did charge the battery.

I cannot get it to download and install the firmware: Error code: 500 comes up.

I’m guessing, but since we are having the same issue right at the same time: server issues.

1 Like

i’m having the exact same problem…


i am also experiencing the same problem. The support team told me to set the lock to maintenance mode, but it didnt help… I cant update to the latest firmware and i cant find the lock in the BT search… What can we do guys???


I also tried to install the beta version of the app, guessing it was an app bug, but nothing to do. I have no idea about what to do now.


Thank you for reporting the problems. We‘re looking into it and will report back when we have more informations.


While i try to configure Wi-Fi through the built in activation i get a message " To scan for WiFi i have to be in a BT range " " Error Code FF". This message is in an Android app… I also try with Iphone. :confused:

1 Like

Same as me, I tried with two iPhones, an iPad and an Android phone

Edit: Works fine after devs actions. 23/04/24 ///
I’m glad to read that it’s not just me… The same with me, Fourth generation Pro device new out of the box - I wondered what the problem could be, until I contacted support as already listed here… They wrote that the issue is known and taken care of and to try to perform a voltage discharge + reset to the device for 15 minutes. None of this currently helped - I tried to connect to different 2.4 internet networks, without success, it doesn’t seem that the connection to the network is saved at all on the device even though a message appears that it is. The thing is that the bluetooth also doesn’t respond either. The most often received errors are 500, 506 with text that the device must have an internet network, or there is no direct connection to Bluetooth when the phone is 0 meters from the lock. Waiting together with everyone for a solution


Same problem since last friday. New out of the box.


The issue has been resolved. Please try again and report back if the issue still persists.

I can confirm that the setup now works, firmware can be installed, etc.

The instalation proccess is going through.The new firmware have been updated. Now i can enter in the built in WiFi menu and connect in the wifi. Though will i try to finish calibration i still get another error " you have to be in a BT range in order to finish Calibration… I have already unstall the app once but didnt work. now i try to do the maintanance mode once again,hopefully it will work…

I still cant finish calibration… While the lock turns the key around, it stops and shows the message " to calibrate this Smart Lock you have to be in BT range". What can i do???

Do you use iphone or Android device??

I have a Android Fairphone 5.

I was able to do everything, from calibrartion to door sensors, etc. No error’s anymore.

Finally, it works both in Iphone and in Android device! Thank you Nuki team, you are great!!!

All is ok now. All working with Android phone and iPhone.

Great Job !

4.0 Pro, fw 4.2.8., iphone iOS 17.4.1

I can’t start a new calibration, it said I’m within range of BT (I’m a few cm from it).

This is an iOS App bug, which is discussed here: Calibration through the app is not possible anymore

1 Like