Auto unlock problem with Android Pie

Anyone else with feedback for us on the new Alpha?

@ Stepehan.

It looks that it also solved the problem with my samsung S9. 2 times it didn’t work, because my Phone didn’t noticed it was inside the geofence area. I think it didn’t had that problem with the app 2.1.5. So i raised the geofence area back from 50 mtr to 100 mtr. I will look if this solved my problem. But when it noticed it is inside the geofence area it is a 100% opening door. :+1:

1 Like

Looks good. First tries where successful. Didn’t need to wake up phone. Door was auto-unlocked as soon as i was standing in front of it. Will continue to observe, but for now I am happy. :wink:

1 Like

Sorry, but I don’t get it. You say, you would be “on it”. Andorid Pie developer is out since March 2018. You do have a developer team, hence you should be “on it” since more than a year now. The final version was released August 2018 - half a year ago. For me as an effected customer it looks like that your team missed something important here and all you suggest is “be our alpha app tester and send us debug reports”. Seriously?

When I come home with two persons and the other is auto unlocking the door, after a while, already sitting in the sun on the balcony, I pick up my phone and the door opens again. Another scenario: Coming home late, going straight to bed, picking up my phone to set the timer for the next morning: open door at night. If not permanently thinking about it the door could be open for hours before realising it. S*cks BIG TIME.

Having paid for your product, I as a customer don’t want to be a beta or even worse alpha tester for your stuff. I would like to have a working product and no, not somewhere in the future. Thanks.

PS: I am happy to test stuff for you and provide debug logs and feedback. You may send a PM if you would like my address for sending me the nuki opener…

Using Galaxy S9… Its now (Alpha Version) working better then ever!

Thanks a lot
Christian Felsch

1 Like

As stated above this is not an issue with Android Pie in general but with undocumented changes from Samsung how they handle BLE scanning in sleep modes.

We use our Developer Forum to coordinate Beta tests by volunteer helpers. We appreciate this support a lot, as it helps us to test new features and fixes on many more devices and in many more setups when we could easily do ourselfs, in a shorter amount of time.

For customer support please go to: https://nuki.io/en/support/

The guidelines for this forum can be found here: https://developer.nuki.io/t/guidelines/5

@MrLee99 Thanks for your feedback. Please keep us updated on long term behaviour.

But aren’t the changes in BLE scanning in sleep modes in done in Android Pie? I mean, even your team and you are using “Android Pie” in reference to this auto unlock problem.

And I do understand what a developer forum is for. And it is nice, when you announce a feature and people are willing to try it out before final release so you can make some necessary changes. For a feature, which is already implemented and has been since Gen 1 for years now, which then just fails to work - this is something totaly different! Basicly saying: If a customer is ending up in the developer forum, because he is looking for a solution for such an enoying issue where your support team is not able to help, something is serously wrong with your product and support. And yes, I realize that you don’t like to hear that…

Btw. your alpha App didn’t open my home eihter. I even opend the App, went to Auto Unlock settings, opened the map, all connection icons where indicating that auto unlock could happen, but it didn’t. I opend the door via Nuki by hand then. As soon as I was inside auto unlock was triggered and the door opened again (Phone was in my pocket). It was the first time trying out the alpha and your team wrote the very first time it would be possible that you have to unlock the phone again, but I thought auto unlock should be triggered then.

There are 3 things to consider here:

  1. Device specific battery saving modes: They have been here for some time and getting (from an App developer perspective) worse with every update. Setting the “battery management” to “not automatic” (or similar depending on UI) normally helps here and we give warnings for this in the Nuki App if someone activates Smart Notifications. Though some devices still seem to ignore those settings in some cases (see https://dontkillmyapp.com)
  2. Android Pie general battery saving / handling of background tasks for Apps: To solve problems here we introduced a solution which resulted into a (permanent) notification that the Nuki app is running in the background
  3. Samsung Galaxy specific BLE issues introduced with their new flagship devices (and Android 9 updates for the older ones): That’s what the current Alpha version adresses (only for those devices)

As you commented in a topic which was before focused on the 3rd point I assumed you faced the exact same problem. My apologies if this was a wrong assumption and I therefore may have answered confusing for you.

Still it would help us if you send send a log-file with the exact time when it occured to our support team at contact@nuki.io, so they can check the details of what happend (if you haven’t already done!).

When will the fix officially released?

Hi!
Seems to work again but the unlock is a little late for me, I think I wait several seconds in front of the door, so I would really like to set the sensitivity manually.
Bye
Till

Feedback is good in general so far. We will have a small UI-adoption to be able to deploy it for everyone. But hopefully soon™. (Sorry, can’t give you an ETA yet)

We have some generel tipps for Auto Unlock optimization you could check (if not already done):

@Stephan, we have a Oneplus 3, which seems also to be in deep sleep. Usually AU doesn’t work.
The One 3 is not on Android Pie yet, but still on A8. Pie is going to come soon.
Is it possible that your patch also improves other phones than S9 (note that we have followed all other recommendation to improve AU)?

auto unlock is working fine for me with the latest beta.
Device: Samsung Galaxy S10+ with android pie

The fix in this Alpha is focused on a problem we only encountered with those Samsung devices with Android 9 yet. So it will most likely not fix issues you got with any other device.

If you got a persisting issue please send a log-file with a short description of the problem and the exact time when it occured to our support team at contact@nuki.io, so they can check the details of what happened (if you not already have done so).

With the alpha firmware the unlock function works again.
But it is way slower than before. I already set the signal strength to normal.
With the old version of Android the door opens approx. 10m before I arrived.
In the new alpha version I arrive at the door and need to wait 5 seconds.

Can you increase the speed?

Thanks for the feedback. With the fix where should be no difference in general with BLE connectivity (and thus the moment when it unlocks). It could be a different factor like GPS also triggered later due to a slower background-job. Can you check the details for the last Auto Unlock (in Auto Unlock Settings) if there is any difference there?

Based on the stats in the app, the door was unlocked 7 sec after it was recognized.

O.k., this seems far to long.
Please send a log file to au-test-feedback@nuki.io if possible, so we can check this in detail.