Auto-Unlock an hour after entering the flat

Hi all,

Today I had a weird encounter with my Smartlock 2.0:
After a long day I drove home from work with only ~7% battery remaining on my phone. I had it plugged to the car and was navigating trough android auto, so the location was up to date. Ring-to-open on the opener was triggered, but the flat door didn’t open and there was no auto-unlock notification, so I opened the door manually from the app (at 19:38, didn’t ask me “Are you sure, you are not near the door”, so the app must have known that I’m in the geofence). I put my phone on the desk and plugged it in later at ~20:35. At 20:45 the phone triggered Auto-Unlock.
This totally killed the peace-of-mind thinking for the moment. Technical info and preanalysis:
The Nuki app is excluded from the battery-saver (which was on at 7%). The geofence for the opener is set to 200m (b/c the garage is a bit more than 100m away), the geofence for the smartlock is set to 100m. Probably the os based location did not update after stopping the navigation in the garage and did only update when the battery saver went off at 20:45. So in my understanding, this is more an Battery Saver issue than a direct app issue. But it still is a big issue and the app should take this situation into consideration.

In my opinion, the app should not trigger auto unlock if

  • Battery saver is on
  • the phone has not been moved in a longer time (maybe use accelerometer events)
  • the phone entered the geofence while charging
  • the phone entered the geofence while being on battery saver
  • location did not change for a longer time
  • the door was unlocked manually from the phone before with the upper conditions in mind (I know there is a dead time of 2? minutes that prevents auto-unlocks after unlocks, but that does not help here)

Phone: Oneplus 8 Pro, Android 11 | App: 2.7.4 | Smartlock FW 2.9.10
I also had this issue once with my older HTC U11 (Android 10) ~2 months ago

I also took a error log from the app after the Auto Unlock that I can share.

Any input is appreciated, I really don’t want to turn off Auto-Unlock, but unlocking way after entrance is a no-go

BR,
Leo

1 Like

Please send the log-file withthe exact time when it occured to our support team at contact@nuki.io, so they can check the details of what happend. This really helps us investigate the reasons for your case.

This is also not triggered if you are in bluetooth range. - Which is handled separatly of Geofence state changes.

Please send the log-file withthe exact time when it occured to our support team at contact@nuki.io, so they can check the details of what happend. This really helps us investigate the reasons for your case.

Sent as 59356

This is also not triggered if you are in bluetooth range. - Which is handled separatly of Geofence state changes.

Didn’t know that, thanks for the hint and quick answer

1 Like

With Samsung Note 20 i have also similar problems! I have activated to auto open when device is very close to lock , but sometimes it will open when device is 3 floor down of the lock! Sometimes it will close auto lock waiting time within 4-5 minutes till i want to reach my door from the garage. It is totally unstable.

We have similiar problems. Sometimes auto unlock is too slow (which is okay, I don’t expect it to be perfect) and we end up using a key. But then it opens the door after we are inside. Auto unlock should remember that the door was opened manually (with the sensor) and then not activate if this was within the last x minutes.

All with Samsung phones? Note 20 has big issues with auto unlock!

Same happens with my lock. It’s so annoying, I can’t use auto unlock anymore.

Samsung and Huawei. But to be honest it’s okay if auto unlock sometimes isn’t fast enough. What’s not okay if it opens the door behind us when we are inside already.

Or opening far away! 3 floors away when i am in garage! I then run fast to be first im my opened door! If this won’t be fixed i will deactivate auto unlock…

You can change the distance (called “unlock speed” iirc) in the smartlock settings. When I switched from my HTC U11 to the Oneplus 8 pro, the recognition distance extended a lot (I guess due to better phone-BT hardware). I played around with the app settings and don’t have this issue anymore

Yes i have choosen the slower choise there , but still sometimes has problem! It is not everytime… Bug 100% …

Any updates for this, any developer comment? The easiest for my problem (auto unlock activates after using a normal key to open the door) would be deactivate auto unlock for a couple of minutes after the door was opened (no matter how, just use the sensor).

Hello?!

Any dev comment on this issue?

Auto Unlock is already blocked for a few minutes after an unlock/open action happened.
But at the same time we can not filter out those extreme cases on Smart Lock side by too extreme filters, as this could decrease user experience with AU again.
So for unwanted openings it is very important to send log files from the Nuki App to our support to check the root-cause on the smartphone (which handles most of the logic).

Thanks for your feedback Stephan.

So for unwanted openings it is very important to send log files from the Nuki App to our support to check the root-cause on the smartphone (which handles most of the logic).

I already did that twice. I guess it’s obvious that it’s a phone releated problem (deep sleep / slow location update or sth likek this regardless of battery optimisation being turned off).
I can collect logs again and send them in, but the result will most likely be the same

Auto Unlock is already blocked for a few minutes after an unlock/open action happened.
But at the same time we can not filter out those extreme cases on Smart Lock side by too extreme filters, as this could decrease user experience with AU again.

The easiest solution would be to add an expert settings to configure the timeout for AU after the door was unlocked (regardles of how and by whom). I understand that changing the default value to a higher one makes the usecase worse for other users, but making this configurable would solve the problem, as I (and probably others) don’t mind setting it to 1h or 30mins or sth like this to prevent the door from randomly opening

Edit –
It’s also clear for me that such a filter timeout is set on the SL and not on the phone, thus affecting all users. Still it’s a better option, at least when it’s configurable.

1 Like

The easiest solution would be to add an expert settings to configure the timeout for AU after the door was unlocked (regardles of how and by whom). I understand that changing the default value to a higher one makes the usecase worse for other users, but making this configurable would solve the problem, as I (and probably others) don’t mind setting it to 1h or 30mins or sth like this to prevent the door from randomly opening

This! The smart lock should register when the door is opened by others means than the smart lock itself. And this

Auto Unlock is already blocked for a few minutes after an unlock/open action happened.

Is clearly not the case for us atm. Otherwise Auto Unlock wouldn’t open the door a few minutes after we opened it with a regular key.

I rechecked the exact current value. It is 2 minutes; see also Auto Unlock – Nuki unlocks your door automatically – Nuki Support

But this isn’t what we are trying to describe.

If I open the door without any involvement of the Nuki app (reason doesn’t matter) and then Nuki registers me inside the geofence it shouldn’t open the door again. And currently it does.

In example: What behauvior do you expect when I activate flight mode before entering the geofence, open the door with a key, close it again and deactivate the flight mode? Auto unlock will open the door, right? Now I want a setting where it doesn’t. It should register the manual door opening and then deactivate Auto Unlock, because obviously I’m now inside and don’t want the door to open again.

Hi Stephan, just as I wanted to send a log , it happened again some mins ago. Sent a request (ticket id 81695). 2 mins just are not enough. Pls make this time configurable.

1 Like