App Update: Nuki Android App 2023.4.1-beta (MQTT)

We released a new Android app version 2023.4.1-beta .

What’s new?

2023.4.1-beta (730) 20.03.2023


  • Enable and configure MQTT on your Smart Lock 3 Pro. Requires Smart Lock firmware version 3.5.11 and above.

2023.4.1 (737) 27.03.2023

Updated Smart Action Center

Auto Unlock is one of the most popular features among our users. In this release we have focused on an even better user experience.

A clear structure allows you to easily adjust settings to your individual needs. The user experience is also improved by the supportive design of the Auto Unlock feature.

New feature “Consider nearby devices” for Auto Unlock

Users who use multiple Nuki devices in their home will be happy about the new feature “Consider nearby devices”.

With this feature, Nuki automatically unlocks the door when you come home. At the same time Auto Unlock is canceled for other devices nearby.

The advantage is obvious: With this feature you can make sure that Auto Unlock is only executed where you enter your home. The other doors remain securely locked.

This is how the new feature works “Consider nearby devices”: An example*

Your house has a front and a back door.
At each door a Nuki Smart Lock is installed.
Today, you enter your home via the back door.

Of course, Nuki should only unlock the door you use to enter your home. In this case the front door should stay securely locked. This is exactly what you can achieve if you enable the feature for both devices:

As soon as Auto Unlock is executed for the back door, Auto Unlock for the front door is canceled. You can use the back door and be sure that the front door remains locked.

Please update your Nuki app and share your experience and describe unexpected behaviour in the comments.


You can disable debug mode on your Smart Lock when enabling MQTT with this app release.

Done successfully, thanks for this release! :slight_smile:

  1. I disabled debug mode
  2. I set my MQTT credentials using the Android app
  3. My smart lock connected successfully very fast
    And my Mosquitto log confirmed the hard-coded connection has been maintained until I set the new credential, so only a second of interruption.

The procedure is OK for me.

Just a question I would like to ask even if it won’t be useful for me :wink: if I only wish to switch allow locking or Home Assistant discoveries, do I have to delete the connection and begin the process from the beginning so type MQTT credentials again?

If you like to update your configuration, e.g., turn of HA discovery or disable “Allow locking”, you have to provide the credentials (at least password) again - as the app does not store the password.

1 Like

Thanks, sure it is better not to store the password :slight_smile: and it is a setting which won’t be changed so often.

Now all is OK and clear for me, nice to see it is now easier to integrate our Nuki smart lock, in my case in Home Assistant.

@Nardol thank you very much for your feedback! :slight_smile:

I don’t seem to be able to connect to my server.

My server is running on the same VLAN as the lock, however, the mqtt setup in the Android app won’t work.

I tried the IP of my server, the DNS entry “server” for said IP, IP:1883, server:1883, … Nothing worked. The credentials are definitely correct. Any idea what may prevent me from successfully establishing the connection? Can I pull an error log somewhere that may provide more information than: “The action could not be executed. Please try again.” Or “An error occured while changing the settings. Please try again.”

If it helps, my MQTT server is running mosquito 2.0.15.

Any help is appreciated,

Hi @tmesserschmidt, please use the IP or hostname without the port (:1883), the Smart Lock connects per default to port 1883, so there is no need to provide it.

Additionally if it does not work, you can send us a more detail report via Help → Contact customer support an we will have a look at it.

Thanks! Things seem to work now. After disconnecting the bridge and joining the WiFi via the in-built WiFi, I had to close the app and reconnect to my lock before I was able to make a successful connection with my MQTT server.

I did notice that the connection dropped twice and the lock didn’t seem to attempt to reconnect. Is this a known issue? My server/the MQTT docker container did not restart or drop the connection on their end.

I also checked my network and the WiFi signal shouldn’t be the issue:

Was there a reason why you connected your Smart Lock 3 Pro to a Nuki Bridge? Looks like your Smart Lock has issues with your WiFi. Please contact our customer support vial the app (Help → Contact customer support).

Yep! The bridge had a more capable local API I used for Home Assistant. Now that MQTT is supported (and hoping those WiFi challenges can be addressed), I’m making the switch to the Smart Lock 3 Pro’s WiFi instead.

I didn’t see any additional disconnect in the past 5 hours, so I’m hoping things are more stable now.

I have firmware 3.6.1 installed, debug mode enabled, Android app seems up-to-date but I cannot find the MQTT configuration. What am I doing wrong?

You need to install version 2023.4.1 (which is available in the open beta). To verify which version you’re running open “Help” and scroll to the bottom.

Once you have the beta version installed, you can disable debug mode for your Smart Lock.

My app version shows 2023.3.1 (725) and I can’t get another version. I am a beta tester in the play store. Removed the current app and installed a new one but the version remains 2023.3.1.
Everything updated automatically up to now so I’m doing something wrong?

EDIT: finaly got it installed :slight_smile:

just a hint for those who want to participate at the “open beta”:
Don’t try it on the play-Website @ your browser, there won’t be any link.
You need to do it at the Play-App

We added a new version 2023.4.1 (737) with new features:

  • Updated Smart Action Center
  • “Consider nearby devices” for Auto Unlock

I’ve read the explanation about this feature in the app more than twice and I am confused about what it is.
When it is enabled, does it mean auto-lock is not performed while there is the bluetooth device which performed auto-unlock near the smart lock?
If not, can you explain it please? :slight_smile:

The “Consider nearby devices” feature is for users with multiple Nuki devices in their home. When this feature is active for one device, Auto Unlock is performed for this device and at the same time Auto Unlock is canceled for other devices nearby.

An example
Your house has a front and a back door.
At each door a Nuki Smart Lock is installed.
Today, you enter your home via the front door.
Of course, Nuki should only unlock the door you use to enter your home. In this case the back door should stay locked.
As soon as Auto Unlock is executed for the front door, Auto Unlock for the back door is canceled.

1 Like

Hallo Stefan,

I’ve just realized some confusing design of the app:
in manage devices:

  • if I click on the Door Sensor, it says, is linked with a lock,
    • if I click on a lock, I get setup/status page incl. battery status
  • if I click on the Keypad, it says, is linked with a lock,
    • if I click on a lock, I get setup/status page - but battery status is missing
  • if I click on the Smart Lock and select my lock
    • to check the battery status I have to click on Configuration and then on Battery

so, to check the battery:

  • Door sensor: 4 clicks
  • Keypad: 4 clicks and info is missing
  • Smart Lock: 6 clicks

and, what I’m missing is some notification of brute force attempt on keypad - this is only visible in the Log (5 clicks) as no MQTT message is sent when wrong code is entered. I would like to suggest to send a push message (and associated MQTT message) when there are more than 10 consecutive wrong codes entered. I’ve already filled in the feature request (vote for it! :sunglasses:)


@ZoloN, thank you for your feedback. I’ve forwarded it.