Apps to configure MQTT are in beta

With the next release of our Nuki apps, MQTT can be activated and configured throughout the apps.

Please post your feedback in the appropriate forum thread.


The Android version is finally available in the public beta.


Having issues to connect to MQTT using the App. When I disable debug mode on my Nuki 3 Pro I see the following in my mosquitto log: I provided User and Password

2023-03-21 16:01:07: New connection from on port 1883.
error: received null username or password for unpwd check

When I enable debug mode I only get an error message within the app. Hostname could not be resolved ?? I use an IP address.

Yesterday I disabled debug mode, setup MQTT in NukiAPP and all is working w/o any problems till now.
Nuki 3 Pro, beta firmware 3.6.0
App verison 2023.4.1 (beta)
Mosquitto MQTT broker running on Odroid H3 with Ubuntu.

Include connection to Home Assistant.

Please disable the debug mode as otherwise the MQTT provisioning will not work via the Nuki App.

Hi, in that case I get on both of my MQTT servers the following error: on port 1883.
error: received null username or password for unpwd check

so far so good. I`ve disabled debug mode and configured my mosquitto broker - all is working fine without a glitch :+1:


1 Like

Activated the MQTT in the Android beta app, configured the MQTT settings and everything is working fine!

Nuki 3 Pro, beta firmware 3.6.1
App android verison 2023.4.1 (beta)
Mosquitto MQTT broker running on raspberry and home assistant

Everything works fine :slight_smile:

i get the same Error like the 1st Post. =/
I am not able to configure MQTT in the Nuki App.

I get the Message “Die Aktion konnte nicht ausgeführt werden. Bitte versuche es erneut.’”

1000 tries later, nothing happens.

2023-07-25 17:16:02: New connection from XXX.XX.X.XX:52435 on port 1883.
error: received null username or password for unpwd check

iPhone - iOS 16.6 - App Vers. 2023.7.1 (2417)
Home Assistant 2023.7.3 with MQTT Broker - 6.2.1

does anyone have any ideas what else can be done here?

the debug mode in the Nuki app is disabled


I don’t know why so many people have problems using MQTT? I have a Mosquitto broker running on a Raspberry PI and have had no problems since the stable version was released. Connection is never lost (or auto-reconnects). Google Home works fine and publishing from Domoticz scripts also. I barely use the Nuki app for locking/unlocking.

You need to be careful with this. There is a handful of people reporting problems here in the forum seeking an advice but there are hundreds or thousands of users out there which are happy and therefore do not show up here in the forum. Furthermore people often do not report back when the problem is solved for them. That’s the nature of such forums and this one of the reasons why we do not run a public support forum, but a developer forum.

1 Like

can you already say when the problem will be fixed?

Is it working for you now?

I’m in a network, too and I can’t connect with actual stable firmware and iOS version. Same error message.

Looks like as if 172.16 is not recognized as a private Adress!! Can you please add to

to the list please.

1 Like

Authoritative source: RFC1918

All RFC1918 ranges are added. This is not your problem.

Maybe this helps: I can't connect to my mqtt broker with the Nuki - #3 by Juergen

Don’t work for me. Already at the installation, no connection was possible. Mqtt connect not possible

This also doesn’t help for me, my broker has no password.
But I’m also on a 172 network and can’t get it working.

Is there anything else to test or information we can supply?
I also requested access to the MQTT beta group, no idea if this is still active or used.

I’m also already on the nuki testflight beta program

I also tried running Mosquitto (newest version 2.0.18) in a docker container, on a plain VM and on my Macbook using homebrew.

All different IPs and different machines and OS type / versions.,

everytime the same error “Die Aktion konnte nicht ausgeführt werden. Bitte versuche es erneut.”
What’s interesting: There’s now a nuki topic n all 3 MQTT brokers I tried.
Which means the connection to MQTT worked at least for a short time (and it shouldn’t be a authentication problem, as the nuki wouldn’t be able to post data to the broker otherwise).

1 Like

Any chance to get logs from your MQTT Broker to see what the SL is doing and/or how far it is comming? It will log in and then pusblish some topics and subscribe to topics.

Btw: I have a 172.16.16.x network and the SL connects to MQTT without problems.