SOLVED: AutoUnlock dead since App Version 2.0.6

Hello all,

AutoUnlock was always something that works based on some random principle on my phone (OnePlus 3T, Android 8.0.0). Since the App update to 2.0.6, where a background service is active, it stopped completely. The PlayStore is already having a lot of feedback on this. Firstly, please fix this problem. Secondly, please provide an option to hide things you add to Notifications. I tried hiding this in the notification settings, but Android complains that the App is taking a lot of memory and gives me the option to kill it, if I do this.

Another bug in 2.0.6: If I try to enable “Logging” with 7x Taps, the App simply crashes and closes at the 8th tap.


I have the same issue. When I spoof my location with Fake GPS, and I go to the Auto Unlock page -> Auto Unlock Settings -> Show Map, it still says in the message at the bottom that I am at home, and need to get out of the geofence zone to active unlock, while the map says I’m in France (Live in Holland).

Edit: My last auto unlock was on 12 december, the same time 2.0.6 was released… I’ve already completely reinstalled the app, rebooted my phone but nothing seems to trigger Auto Unlock.

Auch bei mir ist das Auto-Unlock, nach den letzten Updates, tot. letztes Auto-Unlook 12.12.2018

Ich habe jetzt ein APK für 2.0.4 gefunden und ein Rollback gemacht.

Jetzt was positives über 2.0.6 + neuste Firmware 2.3.11. Seitdem Update funktioniert Türsensor ohne Störung und zuverlässig.

In general: I am experiencing the same problem since the update to 2.0.6, although it worked with an earlier beta version 2.0.6-AU like a week ago.

I strongly advise anyone having these problems to enable their debug mode (Go to “Help” -> “Debug Mode”) in your Nuki App, take screenshots of your “Last Auto Unlock” screen and send your Nuki-Debug-Log with as much and as detailed information as possible to
For example including the exact timestamps when you expected an AU that did not fire etc. is very helpfull for the dev team.

The more people we get to deliver their log and detailed input to the devs, the higher is the chance to get this fixed mid to long term as the AU feature is dependant from many circumstances.

@nirmalts : I believe since Android 8 every app is somewhat “suffering” from a very restrictive energy plan that limits the usage of certain Android services like GPS, Bluetooth etc.
The most common way to work around this restriction is to keep the app alive which also leads to this permanent notification you mentioned. So as the Nuki team of course is very eager to improve their service they now implemented this as a part of the solution to provide a reliable Auto-Unlock service on Android devices.
If they remove the permanent notification, the app will no longer be able to provide anything that comes even close to a reliable AU service.



First of all, thank you very much for your feedback!

We are currently working on an update to fix this issue, which should be available very soon.
I’ll keep you updated about the state of the update here too.

Regarding the notification:
As Christian stated correctly, we need the foreground notification to keep the app alive.
One thing you can do however is to remove the notification icon from the statusbar.
On most devices this can be done by opening the notification center (pull down from top) and long pressing the nuki notification, then choose “Minimize”.

Thank you for your patience!


@Legedric Thanks a lot for the detailed explanation. I understand now why the notification has to be there, although it is quite annoying. @Martin_K Can the notification be reused to show the current status of the door (“Locked”, “Open” etc.) rather than saying that “Smart Actions are running” and clicking on it leading to a “Settings” page, which somehow is quite confusing I feel.

@Martin_K Good to know that you are working on a fix! Thanks a lot. I did not try it from the notification panel to minimize it but in the App Settings->Background Activity-> Importance, I tried setting “Low” (Notification shall not be shown in Status or Locked screen) and later “Medium”. But both resulted in Android complaining about “Nuki App” consuming too much memory. I will try the way you suggested when I upgrade to 2.0.6+ again.

@nirmalts We chose to link the notification this way for now to let the users know what the notification is about and where the according setting can be found in the app.
This does of course not mean that it will stay like this forever.

Concerning the notification settings:
The way of “minimizing” described above is the default way on phones using stock android so it can be different on your phone. I’ve also seen Huawei putting a toggle in the notification settings of the Nuki App saying “Show in status bar” which does the same.
In case you have problems disabling it you can send me a direct message with your phone model and OS version and I’ll look into that.

1 Like

We released an update including a fix for this issue earlier this afternoon to the beta group (App version 2.1.0). If you are not a beta tester yet you will receive the update later this week.


Thank you for the update!

PS: Any release notes for 2.1.0? Assuming you use semantic versioning I guess this is not only a bug fix release but it may also contain a new feature?

@Martin_K This is great. You guys are really fast. I installed the beta already. I will test it tomorrow.

Between that I found something on hiding the Nuki notification. In whatever way you hide it, Android Oreo will show a new status message that Nuki is running in the background. I found two ways of hiding this new message.

  1. Hiding this system message for all Apps
    Goto “Settings -> Apps & notifications” , then select “See all apps.”, press the three-dot menu button in the top-right corner, select “Show system.”, select the “Android System” app, select “App notifications”, find “Apps using battery” setting and disable it.
    This will disable the warning for all Apps and might not be that good an idea if you don’t want to override the Oreo warning for all Apps.
  2. Use a third-party App to selectively hide the message for Nuki only

I tested both ways and it works.

EDIT on 19.12.2018: The AU doesn’t work if the notification is forcefully hidden as above. Hence I wouldn’t recommend the above methods.

@Legedric You’re right, see the full release notes here

@nirmalts Thank you for testing this! Please be aware that we cannot guarantee that the app will stay alive if the notification is gone completely.
Do keep us updated if this works for you in the long run though, as this might also be interesting for other users.

Even after updating to version 2.1.0 the AutoUnlock still does not work. There is also no notification on the phone that you are in the SmartLock area. 2.1.0 behaves the same as under 2.0.6.
With the APP version 2.0.3 and firmware less than 2.3.10/2.3.11 it ran without problems. It is very frustrating!

Did you send your log file to to help them investigate your issues with the AU function after you updated to 2.1.0?

@Torsten_Rywelski I’m sorry to hear that.
First of all, please make sure you have not somehow force disabled the Nuki notification, as this will prevent the AutoUnlock from working.
Afterwards try restarting the AutoUnlock and also make sure you have the setting “Increase location accuracy” enabled. (Can be found under Menu -> Settings -> Smart Actions -> Auto Unlock Settings).

In case this doesn’t help please follow these steps:

  • Make sure you have Debug mode enabled (Menu -> Help -> Debug mode)
  • Try at least one AutoUnlock (Leave Home Area, stay outside for a few minutes, enter Home Area again) so we can see what’s going on in the log
  • Send the Debug Log (Menu -> Help -> Send error log) directly to

On OnePlus 3 seems fixed so far.
I will do some testing in the evening but it works.

On OnePlus 6T and Xiaomi Pocophone F1, both running Android 9, the issue seems fixed as well.

2.1.0 works fine on OnePlus3T with Android 8. I did not observe any battery issues with the service remaining active. The door sensor continues to work very precisely.

A minor issue I noticed. When the “location precision” setting is activated, it is enabled immediately with the notification. When it is switched off, it takes several seconds until the notification disappears, giving a feeling that the switching off did not work.

Good morning,
i have just sent a log to the email address.


I was only able to test AU with the new app version once yesterday and it worked as expected. If I run into any issues again I will provide a log via email again.