Smoobu integration

Hi Stephan,

I just reconnected, it seems to gather more bookings now, but still not all. I understood that it is supposed to gather all future bookings, right?

Feedback:

  • The connection now also imports cancelled bookings as valid ones; this is worse as before as clients that cancelled will now also receive an access code. Edit: This seems to be resolved, half an hour later the cancelled booking disappeard from the list and no code was sent in the mean time.
  • The connection also imports bookings of category ‘Blocked’. This is a feature in Smoobu that allows you to close the appartment/home for a certain time (because of renovation for example). There is no customer data (no emailadress, no phone number) and the Portal is ‘Blockierte Zeitraum’, yet still the connection imports it and displays it in the list on Nuki Web.
  • It seems that the connection now trips on the above (Blocked timeframes), as all bookings after the blocked timeframe are not displayed in Nuki Web.

It should show all upcoming bookings for the nest 7 days.
Cancelled ones should not be displayed (and in any case not create authorizaitons for those). I will let this be checked immediatly.
Thanks also for the note on “blocked timeframes”.

Update regarding this: Please be sure to refresh your browser (or delete cache for the page), to be sure to work on the latest version (which seem to have caused an issue here)!

Also note again, that only bookings for the upcoming 7 days are synced to avoid to many needed changes/cancelations in our system. If you think that it should be expanded please add a feature request for this so we can see if many hosts agree on that and may re-check the restriction.

Regarding “blocked” bookings. This is not documented in the Smoobu API, but we are in contact with Smoobu how to bester filter those out in the future and avoid similar issues.

I do have a smoobu booking tomorrow but I do not see it in NUKI. Stil problems?

Please try to disconnect and reconnt Smoobu again if you still don’t see current bookings.

tried, no joy. Stil no bookings.
Smoobu does not really offer an option to disconnect though.

You can disconnet from Nuki Web side (same button as to Link).

nope,
abgemeldet
cache gelehrt (Safari Macos)
immer noch keine Buchungen

O.k., thansk for the effort. Sent you a PM with further questions.

I was testing Smoobu integration last two days. In order to see bookings on nuki web I have to manually update it on web. After bookings appear, invitations are being send automatically. Should it not be automatically? Or it works like that? I tired to re-connect but same behaviour.

And additional questions. I have connected AirBnb and Smoobu, and off course I handle AirBnb with Smoobu. If somebody would book AirBnb how shall a guest get invitation codes? Over AirBnB plugin or Smoobo, or maybe both? Do I need to disconnect AirBnB from Nuki then?

Hello Stephan,
in the settings i have set that invitations will only be sent to me. If I deactivate an account by hand, the guest receives the deactivation email via Nuki> Smoobu> Booking.com
Is that the intention? Will there be a possibility in the future to get more control over the function or to connect to Smoobu using api instead?
Regards, Hans-Jörg

i can confirm this behaviour.
I have to manually press “refresh” in nuki web for updating the new bookings/cancellations/rebookings.
I even could activate/deactive canceled bookings from smoobu in nuki web.
Seems the update routine is not working as expected.

stil not working no reservations show up
even the airbnb connection seems now broken

please do only beta tests with end useres, not alpha. airbnb and smoobu customers earn their money with it.

We still have an issue with Airbnb-bookings coming through Smoobu due to an error in the API-documentation. We are currently testing the fix internally before we roll it out.
General connection issue should be fixed after reconnecting once (keeping in mind the remaining one described above).

@gramels: What issues do you have with the Airbnb-integration (which should not be affected from the Smoobu-problem)? The connection issues we had there had a different cause (changes on their API which have not been handled correctly automatically).

I do not see any bookings, neither via smoobu nor via airbnb direct connection.

deleted all connections reinstalled, stil no bookings (eg airbnb guests coming tomorrow)

the deletion of the connection is not well documented, it is quite confusingt that using the add butten one could also disconnect

further the beta site colides with the normal NUKI side, I alway have to re log in which is very annoyng using 2fa

it continiously gives me this

Error code: 400
API endpoint: https://api.nuki.io/address/1611205594/reservation
HTTP method: GET
Nuki Web Account: l*******@*****************.ch
Occured: 2020-05-20T06:04:52.316Z UTC

{“detailMessage”:“The supplied value ‘1611205594’ for parameter ‘addressId’ is not valid"¸"stackTrace”:[]¸"suppressedExceptions":[]}

Hi Stephan,

Keep up the good work; things seem to have become more and more stable recently!
One thing i noticed is that in the beginning of the beta, my codes seemed to be valid from 0:00 on arrival date until 23:59 on departure date. I found that very comfortable, knowing that my guests would always be able to enter and leave.

I understand this is not always wished for behaviour, and it seems that nuki now looks at the check-in and check-out times listed in smoobu, correct? Unfortunately, these times are not always accurate, because they are based on information passed on by channels connected to Smoobu. But OK; not Nuki’s problem :slight_smile:

My request would be to enable a ‘grace period’-setting where we can define an amount of hours of margin before checkin time and after checkout time for people to use the code.

If checkin-time is 14:00, i would set it to 2 hours for example for the code to work from 12:00 onwards. Checkout-time 11:00 would work until 13:00 in that case.

Any chance something like this would be possible?

Thanks!

Thanks. We are still working on further improvements!

We had this discussion already; the main problem is that some hosts don’t want to have any “grace period” at all; so the only way would be to have another setting - making things more complicated as to when the settings has to be done and how to handle changes of the booking afterwards etc.

On the other hand: Could the bookings details be changed in Smoobu to reflect the real “allowed time to enter” for guests?

Hi Stephan,

The additional setting is indeed what I would see as the best solution so that it fits every host with different requirements; it could be included in the ‘settings’-panel that is already there, that is now used to determine, for instance, the nuki opener timings and whether to send a keycode and appcode or just keycode. The setting should be general; for all bookings for that accomodation, so should not complicate the current process of managing changed bookings.

I don’t think it is possible to handle this in Smoobu, as the ‘check-in’-time parameter is often filled by third parties such as Booking.com and Expedia etc and is symantically something different then the ‘allowed to enter’ time. If the general setting is available, it would just be an addition and substraction on your side for every booking, for every generated code :wink: