Smart Lock / Position detection - Potential bug

Same issue for me

@Stefan_Reiterer When can we expect a fix to this problem? I have guests in my rental house that are starting to get annoyed from the lock making noise once every hour. It is affecting my business.

Same here, but with the problem that my door opens completely. I have the problem 2 times a day. It gets really bad when it’s 3 o’clock at night.

Hope there will be a solution soon. My guests rightly complain that the smart lock starts reposition every hour throughout the night.

SmartLock 3.0 pro
Firmware 3.3.5

I have the same issue in France. Firmwware 3.3.5 official.
Nuki smart lock 3 pro just installed 2 adays ago.
It is impossible that I keep this door lock with an issue like this.
Please give a solution very quickly.

Do not update to the beta, it does not fix this problem (for me).
In contrast, it gets more worse than before (almost all 3 minutes position detection) and as I noticed, downgrading is impossible

Received from NUKI SUPPORT, problem is concerning SSL certificates:

This position detection does not affect the functionality of the Smart Lock and after completion the device is available again without any restrictions. Please know: There can be no unwanted opening of your door - so there is no security risk whatsoever!

In the meantime, you can temporarily deactivate your built-in WiFi to avoid these unwanted position detections. You can do this in the Nuki app under Settings - Features & Configuration - built-in WiFi . Please note that the remote access to your device is not available when the built-in WiFi is disabled.

Of couse this solution can be used from private customer…
I hope bug will be solved asap.

Same here. Started 2 days ago and woke me up last night. I’ll disable the wifi in the meanwhile. Thank you!

Same issue with a brand new Nuki, it came with firmware 3.3.5 (or was updated automatically in the first setup) could never make it work with WIFI…
The lock is open and close itself once in a few minutes. i cant understand how come you are saying there is no risk in opening the door…

Something must be made and fast :((((
Yesterday my pro 3.0 just went nuts.
It detected position each 3 minutes for a whole day, draining almost completely the battery!!!
I was out of town and came back to 12:30 AM this morning… I believe whole building knew something happens in my apartment.
Had to remove the battery completely :((

Today, surprisingly, no issues up to this time

Attached a small capture from a very long log…

Indeed no issues, but no my Nuki is offline all the time.
No way to open the door without a key.
Starting to doubt about the product.

Same here, in the middle of the night. Hope fix will come soon!

@Stefan_Reiterer any update on the position detection issue? Seems it’s linked to the recent Nuki server update.

My 30 days of return guarantee are coming to an end…

Last week we did another update of the Nuki server which solves the issue of the rebooting and repositioning Smart Lock 3.0 Pro.

If your device is still behaving strange I’m kindly asking you to exchange/charge the batteries and perform a manual reboot by removing the batteries. Please DM me if the behavior still persists.

In parallel we are currently also working on a firmware fix for the stated issue to improve the overall system stability, you will be informed as soon as an update is available via following channel:

1 Like

A manual reboot fixed the problem for me.

No Position detection since 24hrs.

after taking out the battery (manual reboot?) and charging it to 100% the issue still exist for my device

I have disabled internal WiFi
Removed battery pack and charged it to 100%
Restarted Nuki and enabled internal WiFi.

Are you on 3.3.5 or in Beta?

I’m in 3.3.5 with completely new Nuki… the Wi-Fi feature never worked for me

serious problem. It also happens to us in a second home. As soon as it is connected to the Wi-Fi network, the Pro 3 lock cannot position itself. I had to disable wifi and it no longer does. but the option that I do not want to do is to disable the wifi. I hope ppr please correct this as soon as possible. because as this continues I return it. If there were Wi-Fi outages or problems with the Wi-Fi network, the lock should not do anything, because if

not, any attacker puts noise into the signal near the door and the lock begins to position itself (lock and unlock) and that is a problem security serious. I ask for a quick solution. Greetings.

Please install the newest available beta version 3.4.4 as this build includes potential fixes for the stated stability issues mentioned in this thread.

If you are not yet part of the Beta group please simply send me a DM.

Please report if the new Beta improves the reconnect/reboot/position run behavior on your Smart Lock 3.0 Pro device.