Smart Lock offline

The Nuki keeps on to go offline , Support is more or less inexistent.
I think all the people are not interested in a beta version… they are looking to see asap the new release

Glad to report that with last app version and standard lock firmware things finally seem stable.

Lock performs action. Gives feedback of not having done it. But returns online with correct door status .

1 Like

Installing latest firmware 2.5.4 seemed to fix the offline problem for me. Lock is online for more then 24h. Will monitor the lock closely through the next week to see if i can trust NUKI again.

1 Like

@Nicola_Reina @u.h Good to hear!

I’m also getting this - for the past week or so. The lock will go offline in the app, and the bridge does not respond to HTTP requests. I try rebooting the lock and it doesn’t seem to help; neither does rebooting the bridge.

Does this seem like an issue fixed in the beta firmware? Please let me know, this is quite frustrating and it’s only just started happening!

4 out of 5 times when I browse to the REST API I get ‘HTTP 503 Unavailable’.

Latest firmware on Smart Lock 2.0

all of the sudden it stopped working overnight - smartlock does not seem to be connected to bridge, keypad and is not searchable via app.

After re- inserting batteries it works again.

Btw. door sensor jammed error comes one, twice a month or more often.

Conclusion - not reliable to use without having key hidden somewhere nearby
and not usable for business. Will fall-back to ENTR from Yale as it was working reliably for two years.

I have installed a Smartlock 2.0 with release 2.5.2 and the lock looses the connectivity in the Webappliance after some time of inactivity. So i changed the bridge but nothing improved. I made an upgrade to 2.5.4 and now it seem to be more stable and i can reach it remote since upgrading to the new firmware.

Regards, Tom

Nuki offline again. A lot of money for a lot of frustration. Bridge at 1 mtr. WiFi full but Nuki offline. Never leave the house without the normal key! Ask me to send the logs or update with beta software?! Please just fix it.

Same here, Nuki Smart Lock 2.0 went offline for no reason today, I tried to reboot the bridge but the only solution was to open / close the battery compartment to reboot it.

Firmware version: 2.5.4

This is a critical reliability issue, you can’t leave the house without a key since there’s no guarantee the Nuki will work when you get back.

Hey there. Same issue here. The problems started after I installed my nuki opener last week. I already did a factory reset of all devices (smart lock 2.0, bridge, opener) and moved the bridge closer to the other deices (2-3 meter). The crazy thing: when showing the bridge in the nuki app it shows that it is connected to both locks (connection: very good) and also it tells me that it´s connected to the server. When showing the connection status of smart lock or opener: connected via bluetooth to the app, the app is connected to the server, but the connection between server and bridge is broken (different to the status the bridge shows). Also tried another wifi (i had some issues with the ipv6 tunnel of unitymedia for sonos which was not able to reach their backend url in the past) but no help.

so either there is an issue in the bridge code or have you deployed some changes on backend side which end up in random connectivity issues of some clients? my current workaround is to activate the http api and run a nuki plugin on homebridge to reach my opener from outside (which is just kind of a rest request bridge to my local network).

Weird: The /info endpoint says that the bridge is connected. Should i open some port in my router for nuki?

{“bridgeType”: 1, “ids”: {“hardwareId”: MYID, “serverId”: MYID}, “versions”: {“firmwareVersion”: “2.2.13”, “wifiFirmwareVersion”: “2.0.0”}, “uptime”: 83829, “currentTime”: “2019-10-15T19:46:55+00:00”, “wlanConnected”: true, “serverConnected”: true, “scanResults”: [{“deviceType”: 0, “nukiId”: MYID, “name”: “Nuki_ MYID”, “rssi”: -51, “paired”: true}, {“deviceType”: 2, “nukiId”: MYID, “name”: “Nuki_Opener_ MYID”, “rssi”: -72, “paired”: true}]}

Hi Guys,

i have a short Update, maybe a workaround.
After some tryouts and troubleshooting I got the finding, that a friend of mine I´ve invited to my locks got remote access to my locks (he´s using an pixel 3 phone running android q). Myself (iOS 13 on iphone 11 pro) got no remote access. So what I did:

  • I removed my own user from the locks (lock -> settings -> user management -> “Markus” -> remove).
  • Then the app shows “you´re not allowed to connect this lock” -> remove the lock.
  • Then I paired the locks and the app again (pressing the button 5 seconds and so on)

Tadaaa: I have remote access again.

So I assume that It´s kind of an issue in the initial setup routine when linking the locks with your phone, then with the bridge and so on. But if you have a working setup (bridge - locks network) and you add a phone/app to this it´s fine. I ran into the problems after I got a new phone and startet the setup from scratch, so maybe this was the trigger.

For me this helps (for now, not sure how long), maybe for some of you it will work too.


1 Like

I only have access to the lock although this still span of it if my users give them remote access, if I only give them access via bluetooth, since it is without concession to a span of the lock, this is a shame, I think it goes have to put these problems publicly on youtube, to be solved once by nuki

I am not sure I understand you correctly. If it is the same issue you posted in the other topic, you can find my anawer there:

Same issue to me. My configuration is Nuki Smart Lock 2.0 firmware 2.4.5 + Bridge + Keypad and Nuki unexpectly go offline leaving me outside the door. Nothing working, also with keypad!

Please fix it ASAP otherwise we cannot use it with our Airbnb clients, it will be a miss of accountability generating bad reviews and making us lose money.

First please update your Smart Lock to the latest firmware.
In general: Did you get any specific errors (in App or activity log)?

No. It goes only offline and my client cannot access to the flat with app or keypad.
Could I update smart lock remotely? Because actually it’s occupied by my client.

Currently there is no way to update the firmware from remote (for security reasons and as a position detection drive is done at the end).

Can you still check the activity log for errors or is the Smart Lock still not reachable?

This is the activity log:

There are no errors, but around 19 Nuki was offline, because my client cannot access to flat with app and keypad. And also from my device Nuki was offline.

Any news on this issue? We are losing credibility and accountability on smart locking with our clients. I hope that you can understand

Yesterday the rollout of the new Bridge firmware 2.4.8 startet, which should rule out stability problems at that point.
Have you already been able to update the firmware on the Smart Locks?