Smart Lock Firmware 3.8.x Beta

Dear Stefan,
how can I install a beta version of the firmware (my NUKI smart lock does not work with home assistant via Matt any more (since 2 days)). Maybe the new firmware solve the issues.
Thank you in advance for your reply.
Best regards Walter (Austria)

Sorry, already found the answer!,steps%20required%20on%20your%20part.

Original post has been updated with release notes for the Smart Lock 3.0 Beta 3.8.1

Please install this beta and provide your feedback via this channel - thank you!

MQTT bug with stable version 3.7.7
Up when restart nuki and after 10 minutes connection down on the nuki
On mqtt explorer all messages arrived so it’s a nuki issue

1 Like

No issues with both 3.8.0 and 3.8.1 found on my side!

MQTT disconnection happens also with this 3.8.1 Beta FW…

See also Inadequate support level (MQTT implementation)


mqtt disconnections happens also to mine at 3.8.1
it’s been happening since 3.7.x , and it’s super important for my usage…

1 Like

Other 2 things (one good, one bad) about 3.8.1 Beta

  1. the automatic Battery detection type now works (wrt Power Pack of Nuki 3 Pro)

  2. create battery report now doesn’t work anymore (it remains on “create report” forever)

Can someone else confirm?


No, but it took a longer time than before to create the report and bring me to the assistant which ask for type of battery to confirm all is find.
Now it takes more than a minute to display next step when it was less than a minute before.

OK… I didn’t wait so long as before it was much faster…

Do you use the iOS or Android App?

I use the Android App.

It takes 75sec in my iOS App to get the battery report. Never tried it before so I can‘t compare to earlier than 3.8.1

Before it was few seconds to start

Have to correct myself…
Autonomatic Battery detection still doesn’t work… PowerPack is detected as alcaline and of course it reports wrong battery percentage…

What are you waiting to fix also this issue?

Automatic Battery detection needs lock actions to properly determine the battery type. i.e. it might be wrong after a restart and change after a few lock actions. It also works best with full batteries / power pack. If you have problems just set the battery type that you have.

so it means it doesn’t work…
If it works you don’t need to set it manually… don’t you agree?

I want to give you a suggestion: if it’s so difficult to have this feature working fine (as it should) it’s better to remove it… and then users has to select manually the battery type


Original post has been updated with release notes for the Smart Lock 3.0 Beta 3.8.2
As mentioned in the release notes above this Beta contains several improvements affecting the MQTT API as well as the WiFi connection in general.

Please install this beta and provide your feedback via this channel - thank you!

Thanks for the news…
Just installed it…
Will see if it will really solve the annoying problem of disconnection…
I want to be positive … at least we have some new hope after a long waiting time with no news (I am glad to see that you was working on it)
Will share here my feedback

1 Like

The mqtt connection problem in the private network with the ip: 172.20… has been fixed in the current beta version 3.8.2. It really took a long time. Thanks anyway.