Inadequate support level (MQTT implementation)

Sorry but have to officially complain that Nuki support level is very vey bad

There is a lot of people reporting issues of disconnection with MQTT and it seems that nobody is seriously taking it in consideration

I was proposed to join Beta FW (and I did it, currently using 3.8.1) because it was supposed to improve the functionality but it was not the case …

I tried to contact the official support but the anwer was the typical predefined answer asking to reset the device (which means that they didn’t understand the issue)

I am/was in contact with Jurgen here in the forum but answers doesn’t arrive…

Frankly speaking I was expecting a much better (and faster) support level/attention for a high quality (and expensive) product like Nuki Pro 3

I hope that someone soon will come up with some solution… and the I will be happy to change my opinion on that… but for now my feeling is very bad.



I’m with you.
almost all the forum raging about mqtt disconnections…
nothing have done to fix it for over 2 months …

1 Like

It seems the solution arrived… :slight_smile:

I’ll keep you posted once I am sure the problem is really solved…

1 Like

I singed victory to soon… :frowning:
Problem is still there and I am struggling to get some concrete support…
Really sad

1 Like

Thank you for making this post - it echoes my frustration and gives me a place to vent how unhappy I am about this

Many of us spent good money for this product _because_of its purported mqtt support, but it’s actually unusable for me with the disconnects. So currently sitting unused in the hope that it gets fixed.

It reminds me of the issue with the bridge not handling multiple connections every within every x seconds, really should have learnt my lesson, but for some reason thought the mqtt implementation would be sufficiently’standard’as to be less prone to trouble.

And I (and I guess many) don’t care about power saving, happy to plug it in if that works make it work, but it doesn’t.

1 Like

Same experience on my side. MQTT never worked with my Nuki Pro 3.0 lock. On each setup I get error E8. Support says its an unspecific error and then closed the issue three times in the last 6 month. I asked if the lock might be broken, but this question has just being ignored.

Now, I will try sending my lock back.

1 Like

Hi Joannes
Error 8E happens also to me 80% of the time… then insisting and insisting sometimes it connects successfully… and it stays connected for few hours… then disconnect again.
I don’t think it’s broken… it’s their MQTT implementation that’s orrible (unless you have other issues).
Their standard support is totally useless… they just do copy and paste of predefined answers and eventually ask to return the product when they don’t know what to say
Also the support level in this forum, that should be a developer forum, is totally absent… we are alone…
Very bad

1 Like

I’m using the ESP32 Nuki Bridge cause I can’t use the internal mqtt in a 172.16/12network and Nuki seems not to care about it.

And this way it doesn’t depend on a cloud connection to control locally.

Maybe it could be a solution for you too, if this post won’t be deleted like my last (critical) posts and questions before. :wink:

p.s. The bridge seems not to work with the 4.0 devices. But regarding the 4.0 threads and reported problems, it doesn’t seem to be working stable anyway, at the moment…

This is offtopic here. If you want to discuss it, please post in the correct thread. It’s also wrong because we have tested it and it works in 172.16/12 networks without problems, so it’s not a general problem but an individual one. Also there is not restriction in the firmware why it should not work.

This is off topic and wrong too. Of course the bridge works with 4th gen devices. And of course the devices are stable. As usual with a launch of a new product, there are a few minor bugs that will be sorted out with upcoming firmware updates.

As mentioned already several times, please respect the rules of the forum and stay on topic. Thank you.


So why do so many people report, that it doesn’t work until they change the tip area? :wink:

I’m talking about the ESP Bridge, which I’ve linked in my post. But I’m glad if you’ve tested it too. :wink:

And sry, caused by the issue posts about the 4.0 in the last days it seemed like there would be problems. My fault.

And the deleted posts weren’t off-topic but critics.

1 Like

It seems that at the end… after long wait… the new FW (3.8.2 beta) solved the MQTT disconnection…

Will update in the next days… but the 1st impression is positive!


BTW do you also have the following problem (from time to time) with the current Beta 4.8.0 ?