Smart Lock Firmware 3.6.x Beta

Smart Lock 3.0 Updates

Smart Lock 3.0 Beta 3.6.0

  • improved self-healing capabilities for Smart Lock 3.0 Pro
  • bugfix for reconnect handling in case MQTT API is not reachable

Smart Lock 3.0 Beta 3.6.1

  • improved system stability for Smart Lock 3.0 and Pro
  • bugfix for allowing to disable MQTT API even it WiFi got disabled

Smart Lock 3.0 Beta 3.6.2

  • improved system stability for Smart Lock 3.0 and Pro
  • stability improvements for the WiFi connection (Smart Lock 3.0 Pro only)
  • minor adjustments on the MQTT API

Smart Lock 3.0 Beta 3.6.3

  • stability improvements for the WiFi connection (Smart Lock 3.0 Pro only)
    • improved compatibility with Netgear Orbi environments
  • bugfix for allowing the Smart Lock to reposition itself in case of position loss
  • Exclusion of Debug MQTT API :rotating_light:

Smart Lock 3.0 Beta 3.6.4

  • stability improvements for the WiFi connection (Smart Lock 3.0 Pro only)
    • improved power saving methods
  • bugfix for repositioning issue

Smart Lock 3.0 Beta 3.6.5

  • Improved power consumption of the WiFi chip (Smart Lock 3.0 Pro only)

It looks like reconnect mechanism works worse.

I had to restart my Odroid N2+ where Mosquitto is running, near an hour after mosquitto restarted and my SL3P still did not try to reconnect, I had to really wait for an hour, is not it twice per hour to reconnect?

having to wait for a full hour looks too long IMHO, with version 3.5 last time I had to restart Mosquitto my smart lock reconnected only a few minutes after.


I have big Wi-Fi connectivity issues after I made upgrade to 3.6.0.
On 3.5.x there was no problem, but on 3.6.0 the connection is very very unstable, ping is not responding, device is offline.
What you changed? Is there any way how to get back to 3.5.11 please? Currently my Nuki device is in unusable state. I can manage my device only via BT.

PS: I made some test. I have one Wi-Fi router and one Wi-Fi extender. If the extender is powered off, Nuki receives IP address from DHCP but the ping response is very slow and device disconnects again and again. If the extender is powered on, Nuki does not obtain IP from DHCP and is unreachable.
But as I wrote, with 3.5 11 there were no issues and I didn´t made any changes on my Wi-Fi networks.

Hi there,

I have the same problem with the WiFi connection by using the firmware 3.6.0. After a new integration into my WLAN, I have fully access to the Smartlock 3.0 again, but it does not work for a long time (for about 12 hours). Also after opening the door by using the keypad 2.0, the SmartLock is connected by WiFi again.

It is just confusing that there are no problems with my second Nuki 3.0, firmware 3.6.0. It works perfectly.

1 Like


personally I’ve got the Wi-fi issue on the 3.5.11 and I moved to the beta hoping to quicker solve it.
nobodyels got the wi-fi problem on the stable too?

Yes i had it also with 3.5.11 the wifi issue. A complete Restart of the Nuki and all AccessPoints at the same time solved the issue. So far no change detected on 3.6.0 regarding WiFi send Signal strength seems to change every 5 minutes… but at least it is always connected now.

Are there some other users who use TP-Link Deco M5 for Wi-Fi with Nuki Smart Lock 3.0 pro?

If yes, do you have really stable connectivity or are there some random series of disconnection which make the smart lock unavailable on MQTT?

I have Zyxel router but the Nuki is disconnected permanently.

I got a second issue too, it should be "Update system time " (I’ve the italian language, not sure how it appear on eng)
everyday it appears and if I ignore it any schedule won’t work

When I configure WIFI I always obtain this error but WIFI connection works fine!


I had the same issue. It is true that these latest version has some issues with wifi, but the technical support ignores all request to explain it and make repair.

Same here. Connectivity issues since yesterday. Today my nuki didn’t locked itself

Original post has been updated with release notes for the Smart Lock 3.0 Beta 3.6.1.

Please install this build and share your experience. Any feedback is highly appreciated.

The update to this build process has been very strange:

  • During the update, I had an error 500, I was not more than a meter fare from the smart lock with my Android smartphone (Pixel 4A)
  • When I pressed retry, some seconds after I had an error 506
  • Pressed retry again, same 506
  • Near immediately after I pressed retry, I had an error 23
  • I tried to press retry again (two times) with same error 23
  • So I cancelled the update and noticed my smart lock was updated successfully to 3.6.1

It is a happy end :slight_smile: but this is really not an usual update process in my opinion.

No update errors on iOs but still the same Wi-Fi connectivity issue

Same issue, in addition access with Nuki Web is even worse with 3.6.1 than 3.6.0. Today it took 10sec until the door unlocked - with 3.5 it was 1sec

You mean while updating?

This is most likely not related to the firmware update as there has been no change in the firmware that could have an impact on Nuki Web.

To add a precision, a friend also experienced the same strangeness while updating, alson on Android.

Issue = Wi-Fi connectivity, nothing realized during update

Nuki Web needs to reach the Smartlock what is not that smooth like before due to the issue on connectivity

You can hardly judge that based on Nuki Web response times. If you want to judge the quality of remote access the best method is to use the Nuki App with a phone that has BLE switched off.