Smart Lock (4th Generation) - Set up Home Assistant for Remote Access via Thread


The main aim of this page is to summarize all relevant information for being able to setup and use Home Assistant for achieving full remote support via the Thread connection of a Matter pairing between a SL4G and the Home Assistant.

Hardware requirements

  • Home Assistant Yellow or
  • Any Home Assistant compatible hardware (Intel NUC, Raspberry Pi, …) in combination with a Home Assistant SkyConnect stick (or something comparable, which acts as OpenThread RCP)

Setup flow

  1. Install OTBR Addon on your Home Assistant
    Open Thread Border Router - Home Assistant
    Note: Do not install the “Silabs Multiprotocol” Addon as this one is not supporting NAT64

  2. Enable NAT64 in the OTBR Addon

  3. The Thread interface is now visible in the device list

  4. Click onto the entry and make sure that only one border router is listed
    Note: This is important as otherwise the Smart Lock (4th Generation) is paired to the wrong border router, which may not provide any internet uplink via NAT64

  5. Activate Matter on the Smart Lock (4th Generation) by using the Nuki App - Go to the Administration section / Smart Home / Matter and follow the screen-flow

  6. Open Home Assistant Companion app on your Android / iOS device and perform the Matter pairing by selecting “Add new device” and then “Matter device”. Follow the screen-flow for further guidance to conclude the Matter pairing.

  7. Your Smart Lock (4th Generation) is now paired to the Home Assistant via Matter and has now also the full remote access capabilities via the Nuki App.

Thanks Stefan.

As far as I know, NAT64 is not available for Nest Hub, isn’t it? so this would not work.


Inside the Google environment NAT64 is only available on the Nest WiFi Pro at the moment.

1 Like

Thanks Mark, would an Apple HomePod mini work?

The HomePod Mini also supports NAT64, yes.
So if your Smart Lock 4th gen is connected to a HomePod (Mini) via Matter it will also be able to use the Thread network for online connectivity.

But please note that this topic is about setting up Home Assistant to act as a border router (instead of Apple, Google, … ecosystems).

Thank you, Mark. Now it’s clearer. I thought that using the Thread network of the Nest Hubs would be possible, will wait if Google updates them wit NAT64 support.

I have several Aqara devices connected to my SkyConnect via ZigBee. Does this mean I can’t use my SkyConnect to control them anymore after enabling a Thread firmware? I actually thought Thread and ZigBee would work simultaneously with the SkyConnect stick? Or am I understanding something completely wrong? Do I have to wait for the multiprotocol firmware to come out? Will it work then? Thanks

Currently the Silabs Multiprotocol Addon does not offer the NAT64 support.
Please reach out to the Home Assistant team if you want to get any further information if and when they intend to add this functionality to the Multiprotocol Addon as well.

It should work in theory but the feature needs to be added to the OTBR which is included in the Multiprotocol Addon by the Home Assistant team.

Thanks for your quick answer! So a second SkyConnect stick is the way to go for now? Is the ConBee III able to do that? Do you know that coincidentally?

A second stick would be the way to go for now, yes.
I don’t know which sticks are compatible with the OTBR addon but I think that any stick running the OpenThread RCP firmware should work.

Got a ZBDongle-E, I will flash it with the Openthread RCP firmware and check if it works.

Hey, I have this set up with HA and SkyConnect.

I have NAT64 enabled and can access it remotely using HA but not the Nuki app. Am I missing something?

Please send my your Nuki-ID via PM.

1 Like

Hi Mark,

I have been able to connect the smart lock using a ZBDongle-E flashed with the openrouter firmware to HA.

NAT64 is enabled in OpenThread Border Router and working inside HA.

I alredy sent you my nuki ID and in the app in matter option there is a banner telling that my Nuki is online using the nuki brigde. But I have no idea what is next step, if I disable bt of my phone app is not able to connect.


Working the online with matter here! Thanks Marc for your help.

I had to remove the bridge connection from my esp32 nuki hub and remove the bridge connection from the nuki. After that an option to enable the online appeared in matter section.

I can manage the app without the bt connection and in nuki web :v:

1 Like

Hello, I have ZBDongle-E, with openrouter firmware, nat64 enabled, but it doesn’t work for me.

NEST-PAN-xxxx is the Thread network of a Google Nest Hub.
So you’re actually not adding the Smart Lock to the network named home-assistant as shown in the other screenshot.

Try to run Troubleshooting => “Sync thread credentials” in Home Assistants companion app.

I previously had the Nuki Smart lock connected with thread to the nest hub. Now I have the home assistant recently installed, the Nest hub disconnected from the electrical network. I have everything right and I get this error. Could it be that the Nuki smart lock has it in memory? How do I delete the nuki smart lock credentials?