Smart Lock 4th gen problems with iOS 17.4 Matter integration (missing notifications and slow state updates)

Hi,
17.5 beta not fix the problem with Matter .
The matter issue not just from Apple !also with nuki smart lock 4 .
The only solution is to connect via Wi-Fi ( The Wi-Fi connection is also currently unstable ) But it is the best solution until a new update is released from nuki

1 Like

Hi,

Facing same issues that notifications not popup from HomeKit only from
Nuki app not responding was solved after update HomePod mini to 17.5 but about the notifications from HomeKit

Hi @Juergen

The notifications from HomeKit should be fixed from Nuki side or Apple also the delays from
Nuki

17.5 beta?

Hi @Juergen Yes it’s final beta status on home is ok after the upgrade notifications still have some delays less delay but still delays notifications from
HomeKit still not working

What do you mean by that? Is it that Nuki notifications are working but Apple Home notifications not?

Hi @Juergen

Yes Nuki app notifications are working with small delay but notifications from HomeKit completely not working when you open from Nuki app.

Usually the notifications was from both with no relation from where you do operations like locking unlocking.

Also noticed that on HomeKit the device firmware is not updated for example I’m using 4.3.4 and if I go to properties from HomeKit for the device firmware is 4.1.0 I have also Nuki 3 that works perfect just as fyi. And firmware is also correct.

I tried also reset the Nuki reads to home still firmware is not correct and not only on my device also my friend device

I have just updated my Apple TV 4k (which is acting as border router) to tvOS 17.5 final, and now its status does not get updated at all in the Home app (with tvOS 17.4.1, status updating was simply slow). It constantly reports “No response”. Tested from iOS 17.5, iPad OS 17.5 and macOS 14.5.

Also, the Home app continues reporting that the SL4P firmware version is 4.1.0 (actually, it is running 4.2.8). This was also happening with tvOS 17.4.1.

My S4LP connection status (on the Nuki app) shows that everything is fine. It is not using Wi-Fi; only Thread (with remote access) and Bluetooth.

I installed tvOS 17.5 and the state is working normal. Maybe you can restart Nuki and aTV? I hope that it works for you too…

1 Like

I just restarted the Apple TV and now the status of my SL4P gets updated correctly in the Home app. I did not tried that before, because the Apple TV is automatically restarted as part of the tvOS updating process. Still reporting 4.1.0 firmware, however.

Thank you very much for your advice!

Hello, iOS 17.5 is installed but I still don’t get any notification from HomeKit when my smart lock 4 pro is locked or unlocked, either through Siri or by pushing the button directly.

Should I set something up on nuki side ? In HomeKit notification is set. Thanks for your help.

My nuki firmware is up to date. My nuki and Apple devices have been restarted.

With 17.5. all works great with HomeKit → Can you restart your matter border router (HomePod oder AppleTV) and the Nuki lock? Does it help?

Hello, Thanks.

I have restarted my appleTV and the nuki (by removing the battery) but the result is the same. I own HomePod as well, I can try to force them to become the matter bridge, I will try.