Smart Lock 4th gen problems with iOS 17.4 Matter integration (missing notifications and slow state updates)

Hello,

without doing anything with my nuki device nor iOS app, since ios17.4 the activity notification is not sent anymore by Apple HomeKit whereas it worked fine before the ios update.

It seems to be an Apple issue. Have you experienced similar thing ? Maybe should I set something up in my device or on ios side ? Thanks.

Same issue

1 Like

Yes, we’re also seeing this behaviour. It was also reported by other users already e.g. here Smart Lock (4th generation) Firmware Beta 4.2.x - #32 by simone_piccinocchi

Yes, there has been no change on Nuki side.

The only thing you can do for the time beeing is to report the issue to Apple via this site. Please do so. This has proven to be valuable in the past already several times.

We’re looking into it as well and will update you once we know more.

P.S.: I changed the title of topic to reflect better what we’re talking about here.

2 Likes

Yes I confirm the same issue.
If you simply act on the tile (i.e. open the option), despite the “not reachable” state, the smart lock state return to be correct.

Same issue here, since Homepod OS17.4.
Now I tried to disconnect my Nuki 4 Pro from Matter and reconnected it. The issue is still there. Reboots of the Lock and the Homepod Mini, changing the batterymodes - nothing has solved the problem.
I also have the feeling that the many requests via Homekit are draining the battery.
I have now also reported this to Apple.

We’ll see if that helps

Thanks.

I can report that the issue is with the HomePod last gen and the Apple 4k last gen. Both received the 17.4 update. Both can act as a HomeKit hub but not at the same time of course . I have checked it by powering off them one by one.

Everything is totally broken for me now!

Matter, Remote Access, Apple Home - all broken!

The Nuki app barely works when connected via Bluetooth as well - I am not sure if it is due to Matter not working and making the app ‘unstable’ - but it either doesn’t connect or is extremely slow. Thankfully the physical buttons still work!

The accessory in Apple Home was working intermittently for a while but is now permanently showing “No Responce”!

How can iOS 17.4 break things so badly? I have many Apple Home and Matter accessories, and none of the others have any issues.

I have only had Nuki for a few weeks, and although I love it, I haven’t had the best experience. I am a little more forgiving than my family, too, who have been swearing a lot the last few days! :see_no_evil:

I am wondering when this will be fixed? If this is a 100% Apple issue I guess it could be a while which would leave me/us with a none functioning door lock for a while :sob:

There is no known interference of Matter with BLE. Looks more like the Nuki App might have problems to choose the right path because of an intermittentily connected Smart Lock. If you want to test BLE performance you have to switch the phone in flight mode and turn on only BLE.

Please install the latest beta and DM me your Nuki ID.

Yes, I guess I should have been clearer here.

When in flight mode (and before I had Matter enabled) the app via just BLE was speedy.

With Matter enabled, even when I am connected via BLE and stood a few inches from the lock, it is very slow.

It is almost like the app is checking for the Matter connection first even though it already has a BLE connection. And this is where the delay is happening. With just BLE (in flight mode for example) it connects instantly. With a BLE connection and Matter enabled (regarding of whether there is an active Matter hub connection) it takes 3-10 seconds to connect. If it has an active BLE connection, it should just ignore Matter, which the app seems not to do. Something somewhere is causing this delay and it’s related to Matter.

Since there has been some Matter issues before iOS 17.4, it was very slow to connect and since iOS 17.4 it regularly fails to connect despite being connected to BLE and being in BLE range.

1 Like

The App does not check for a Matter connection but in general for remote access (via Thread/Matter, WiFi or a bridge) and it always prefers that over BLE because it is usually faster and more reliable than BLE. Only if there is no remote access possible it falls back to BLE. So now in your scenario, if remote access is unreliable, you can have this weird behaviour that you see.

Please update to the latest beta and test if the problem still remains.

With the last iOS update 17.4.1 the still in place.
@Juergen Is there any news about this very annoying issue?

That is not ios problem. That ist home os or apple tv os problem as a border router for nuki.

No. It’s reported and now up to Apple to fix it.

Has the problem with tv os/homepod os 17.5 beta been fixed?

Yes🎉

Did you have to remove and add your Smart Lock to Apple Home again after the update or was everything working right after the HomePod/AppleTV update?

So if I install beta Homepod 17.5, the “no response” issue should be gone?

Only hompod mini have 17.5 apple tv still on 17.4 no remove from apple home

1 Like

Yes. It might take some time for your Smart Lock until it appears as available right after the update though.

Actually, it was ok right after instalation

2 Likes