Smart Lock 3.10.x Beta

Lock did not come online in Home Assistant after 3.10.3, the MQTT config was gone? After reconfigure it seems to work, will keep an eye on it next few hours/days.

3.10.3 looks good for about 5 hours so far…

After one day, it iss not working at all. Even it is green the lock needs almost 1 minute to respond.

Hi,

yes I can also confirm that 3.10.3 is working since yesterday without major outages. The connection interrupted from time to time for ~1 minute. But it was only 3 times in ~12 hours.

-Thomas

3.10.3 looks good for me, really better than 3.10.2. Until yesterday at about 20:10GMT+2 the smart lock has not become “unavailable”, strangely the status was “Unknown” at 22:35, it is the first time I have this state in Home Assistant.

Could it change something if night mode is disabled? I ask because in night mode the energy saving is changed so is it the same for Wi-Fi behavior?

EDIT: The “unknown” status is not strange in fact, after some investigation it is due to my HA which restarted at this time which I did not carefully checked when I posted. Firstly entities are unknown before getting their state from the MQTT broker.

Updated yesterday my 3.10.2 lock to 3.10.3.
My “beta” lock was far less reliable then my 3.9.5 lock before this upgrade. It seems now it’s far more reliable. 24 hour without disconnection !
Hope its the end of this problem because its very annoying for a connected lock to be disconnected 75% of the time…
Regards.

PS: Falses hopes… reverted back to it’s old connection scheme, where it s connected 10-15 min and disconnected during one hour.

Same here, WIFI was broken in the latest production version so I tried to install the latest beta. Same result.

Cannot connect to the lock in a timely fashion. Also the app says WIFI is not configured.

But when I goto the settings WIFI is enabled just fine.

WIFI is more disconnected then connected.

After rebooting the lock it’s working for an hour or so and then it’s crooked again.

Other remote battery devices such as my battery powered Eufy doorbell camera are working reliably without any problem. How hard can it be to just make this work?

Not sure where to go from here because support is a hassle and I my partner has removed the app because she doesn’t trust it anymore.

I think NUKI should just sent bridges free of charge because their product is just broken.

If you have problems with the WiFi connection of your Smart Lock, please follow the advice in the FAQ. If you still encounter issues, please send me the Nuki ID of your lock in a direct message.

There are also a few threads with suggested settings for unifi routers. You might check them out too.

After being in contact with NUKI support I’ve added a seperate WIFI network for 2.4Ghz only and did a soft reset. I’m happy to inform that since that moment (2 days ago) it’s working reliably. When I’m in WIFI range I can actually connect to the lock and open the door!

I hope this is not short lived but it looks promising!

To be sure, it is a 2.4 Ghz only Wi-Fi but with access to the rest of the network?

I get the update in the stable firmware by mistake as it was marked with the auto-update funcion. Since then the 3Pro became nearly inusable.
As i found no other way, as no rollback was possible (sounds stupid to not let that, really), I joined the beta test about little more thatn a week ago.
3.10.2 was installed, and really it was a mess. Connections for less than a minute every several hour.
Automatic mode impossible to be used. The others don’t help at all. (With the previus stable firmware it was with the automatic for several months).

3.10.3 was installed. It becomes a little bit better but far from really usable. If the battery pack was removed to restart it, you have some glimpses of stability for the next 2 hours. Then it comes back again to the bad mood of “disconnecting/connecting”, but the disconection times grow. Starts with less than 1 min, to be for 2-3 min, to be for 30min… and up to 1h from my tests.

Just now it’s reconnecting to the wifi every 20-30min, for less than 1 min. The thing is that i see it connecting, it replies to pings, but you are unable to connect to it from the Web management or the app. Appears as offline. Tried several times in this short connection period, no success.

One friend told me to buy the Smart 3 (not pro) with the bridge, saying that was really solid and will have no problems. He must me laughting now for days…

1 Like

Or if you have an ESP32 you can create your own bridge with the Nuki Hub project.

Same here, I wonder when a stable solution will arrive. I have installed the Bridge again to at least a basic function. However, I think this is very unprofessional from Nuki leave us alone for such a long time.
Alternatives will be examined.

I have beta 3.10.3 and my lock works fine, Unify report it connected almost all the time
image
Far better that stock and 3.10.2 firmware. So far all the time I needed to open or close the door it was right away available in the nuki app

Updated to 3.10.3 recently. MQTT is still not usable, so I’m relying on Web API for now in production. 3.10.2 showed quite stable results here, but with 3.10.3 even that API got worse. When lock switches to night mode now and locks the door automatically, status isn’t reported any longer. Can’t you get at least one API working reliably?

Since the update to 3.10.3 your Smart Lock has been permanently connected to the Nuki server without a single reconnect. Looks all perfectly fine.

Please send me a DM with a failure description or some logs from your MQTT server.