Smart Lock 3.10.x Beta

It´s still not working with this latest firmware for me either, maybe who says it was fixed, share the info to compare. The problem is, Nuki don´t allow us to know much.

btw, I did a very similar scenario (not so clean tbh) but with the same results.
Could you try to add something else?
Add a machine/HA/vm/something, pinging nuki local ip every second. Check if with that active the whole time, it changes something

I have setup a ping every second to both of my devices. Tomorrow I will share the results.

1 Like

Here we go… with pinging the NUKI lock it is not possible to keep it online. It is also nice to sse that the MQTT status still exists for some time (few minutes) before it is reset by timeouts.

This corresponds to my previous finding from the WiFi log, that it seems that the NUKI lock does not log off correctly before going into some kind of sleep mode to save battery. I think the NUKI lock does not send any association request frame when saving battery to the WiFi AP to keep its authenticated status before its authentication timeout expires - or the timings are to tough for saving more battery as in the previous software versions (earlier as 3.9.5).

This is not what’s going on. I’ll send you a DM with more informations.

There was no change in regards to this from 3.8.x to 3.9.x or 3.10.x.

I am still not able to update from 3.10.0 to 3.10.1
I enabled the auto update and it does not work and I also tried directly to trigger the update and it does not work. I klick on “update now” and then I get: “Um die Firmware deines Smart Locks zu aktualisieren, musst du dich in Bluetooth-Reichweite befinden.”

Why is it not possible to update my smart lock?

hello,
Is there some known issue between FOB and 3.10.1?
My FOB seems to be connected (as per the Nuki Android app) but pressing the button do nothing…

Hi,

any idea, when a Fixed Firmware will be released?

It is now more than one month ago, when the MQTT problems appeard for near all (perhaps all) NUKI 3 Pros.

I hope that it will be solved soon, because the trust in Firmware upgrades is near gone for me.
I was asked to upgrade Firmware of Keypad. But I have not installed immediately, because I somehow didn’t trust the Firmware updates anymore 100%.
As we see, the problem is, that problems, which will come in, will not immediately be solved :frowning:, which show, that it would be better to wait several month, before installing Firmware update.

I have seen, that question was already raised. Why it is not possible to roll back to previous version before 3.9.5? Everything was fine with older Firmware.

Is there any way to rollback?

BR
Thomas

2 Likes

It is much more then a month…

i have the same problem. Nuki 3.0 Firmware 3.9.5
Wifi is OK but MQTT continue to disconnect.

2024-06-09 15:18:49: New client connected from 192.168.178.85:52956 as SL3P_38B8DB64 (p2, c1, k300, u’mqtt_user’).
2024-06-09 15:36:55: Client SL3P_38B8DB64 closed its connection.
2024-06-09 16:00:57: New client connected from 192.168.178.85:52966 as SL3P_38B8DB64 (p2, c1, k300, u’mqtt_user’).

it is really too long that the problem persists. bring out a stable firmware (not beta) that can solve this situation. The product remains unmanageable, using wifi allows use but the response times are slower than mqtt. Restore as soon as possible now we have been waiting for months and given the cost of the product compared to the competition I expect quality and that the resolution of such a problem should be your priority.

This is exactly what I see in my setup with Nuki 3.0 Pro, Firmware 3.9.5, Home Assistant 2024.6.1 and Mosquitto broker 6.4.1 Add-on. How can we get back to a MQTT-stable Firmware???

This thread is for the 3.10.x Beta. Please only post here if you are testing beta firmware.

If you do not want to join the beta, please contact our support via the Nuki App (Menu > Help > Contact Customer Support) in order to report problems. They will be gathered and forwarded to the development team.

And because most of the problems are coming from WiFi problems, please make sure to also look at this FAQ.

Hi, just wanted to share that since I’m on 3.10.1 the MQTT-problems with my smartlock 3.0 pro are over. I use the lock with Home Assistant and it is working as expected again. So thanks!

1 Like

Hi,

I was affraid updating to Beta 3.10.1, but at least since update of one of my NUKIs, MQTT is stable since more than one day.

Other NUKI is still on 3.9.5 and for this one it is enough to switch to “Wartungsmodus” to get it working for some days.

Switching to “Wartungsmodus” was not working for the other one, where I have installed now 3.10.1.

I hope that a final version will fix it permanently on both NUKIs.

BR
Thomas