Smart Lock 2.0 Firmware 2.6.2 Beta

We released the new Smart Lock 2.0 firmware version 2.6.2-Beta .

Release notes

  • Further performance improvements and bug fixes.

Please update your Nuki Smart Lock 2.0 and give us your feedback.
Especially iOS App Beta users (2.4.2) give us your feedback on the firmware update process itself, as there have been changes in the latest version!

I updated from the previous 2.6.1 update to this version.

The update itself completed successfull, but received message in app that update had failed and needed to be reinstalled.

After Bluetooth off/on and app restart all was fine.

Also the firmware update needs to check the current state of the lock. Because after the update the lock does a drive test. If lock is locked it starts and unlocks the lock. Then the lock has to be locked manually again.
I understand that this is difficult.

So maybe it’s better to unlock the lock before applying firmware update, so after update the the initial test drive returns it to state it was before update.

MrZapper61.

What you call “test drive” is a position detection. The Smart Lock always does that when you restart it (e.g. during a firmware update or when you change the batteries) in order to ensure that the lock state is correct (because in theory you can remove it from the lock and mount it again in a different state of the lock). During a position detection it moves from the current position to full close and back to the current position.

@Stephan @Juergen Is the AutoUnlock issue i have reported solved?
Stephan i pm’ed you antoher log yesterday.

thx
Tobias

Hi,
i am unable to upgrade as long as the app tells me failure 814. My handy after the upgrade to 2.6.1 does not longer interact with the smartlock via bluetooth! What can i do?

Reboot your Smartphone.

Your problem may be related to this: Smart Lock 2.0 Firmware 2.6.1 Beta

Hi, I tried that but gave me no result. My son was the only one who could initiate the firmware upgrade. Are those problems resolved with the new update? Before 2.6.1 I had no problems.

Which phone do you have and which version of the Nuki App?

I have a Samsung S10 and the app version is 2.4.2

Hi…
Now every time i have an Auto Unlock when i return at home a notification send me a message if i want to open the door…if i don’ t see the notification the Smart Lock don’t open the door…
It’ a bug or i have a wrong settimo?
Fw 2.6.2
iOS 13.1.2 app 2.4.1

@lucaper88 It’s the same for me on android with FW 2.6.1 & App 2.4.2. I have already sent two logs to @Stephan. Could you please also make debug logs and send it to Nuki so they can identify and fix the issue?

PS.: @Stephan Any news on analysing the logs?

thx

1 Like

Hello Dear Nuki team,

I really enjoy your product but unfortunately starting wit firmware 2.5.4 we have a lot of problems regarding the unlocking where it says it’s blocked very often. When I recalibrate the lock it works fine for a (very short) while, but the problem always comes back.
I would therefore really appreciate it if you could add me to the beta group so I could try out the Position Detection Improvements introduced in your latest 2.6.x betas.

Thank you very much and keep up the good work.

Cheers,
Greg

This strongly reminds me an intended HomeKit security behavior and, maybe, it’s intended in Nuki app too.
With Apple HomeKit you can setup geofencing automations, but if they set any security device (lock, door, security system, etc.) in an unsafe state (unlock, open, unarmed, etc.) , the user must confirm (so unlock with TouchID or FaceID) the action. This is for preventing anyone who stole your phone to have an easy access to your home.

Regards.

1 Like

After updating from 2.6.0 to 2.6.2 I lost the connection to my Bridge and had to reconnect everything.
Beside this, it’s working.

Activated Auto lock/Unlock.
Have the same problems as the others, sometimes it works but most of time it does not work.
When it does not work it looks like it is a problem of communicating with lock.

Tried to open the lock through the app but that also did not work, despite several attempts.
So I opened the lock with my key.

The worrying part is that after a delay of half an hour or so, the attempts of me through the app came through and the door unlocked several times!!
This is actually a security risk and not acceptable for a lock! Looks like commands that not get through to the lock are queued and executed on later time when communication with Nuki WEB (?) is restored resulting in unlock of the lock (in my case).

Hope you can solve these problems, because they are very serious security issues.

I updated from 2.60 to 2.62.
The installation of the new FW on the lock wasn’t working initially: the download to the iPhone and upload to the lock was fine, but the installation on the Nuki didn’t suceeed. The Nuki always stopped the installation progress and restarted. When I removed lock batteries and restarted the iPhone app, then no problem, update process worked.
I have no problems with the AU, it works with iPhone (latest Beta) and Android phones (regular App). Only thing I notice is that the Nuki doesn’t seem to note anymore when someone opens the door from outside with a key (I can see that in the log), and therefore doesn’t send a notification anymore. Can you replicate that issue?

Updated from 2.6.1 with 2.4.2 App:

Download, transfer and update, reboot went fine.

Only thing I realized: it took quite some while (about 40 sec.) until the transfer started, when standing beside the door.

I checked again, notifications about manual opening are working. Maybe I did a mistake or simply missed the notification.

My Smart Lock see fw version 2.6.3!! It’s an update?

Installation from 2.6.2 -> 2.6.3 without any problems.