Smart Lock 2.0 Firmware 2.6.1 Beta

We released the new Smart Lock 2.0 firmware version 2.6.1-Beta .

Release notes

  • Many small performance improvements and bug fixes.

Please update your Nuki Smart Lock 2.0 and give us your feedback!

1 Like

After installation of this version it’s not possible to calibrate the lock.
Getting error that I have to be in Bluetooth range of lock, while I am standing in front of it.

Also Lock&Go still only clicking, not opening the lock all the way.
It does lock it after opening and closing door.


I have the same problem! And every time i open the door i have a notification of door sensor blocked…i close the door and the problem not appear… i try to recalibrate with no success…

Does it work, when you switch BLE off and on again in your iPhones system settings?

I want to try to return in the fw version 2.5.4…is possible?
Now with this release i ave a malfunction to the door sensor and for me is a problem !

After restarting the iPhone I was able to recalibrate the lock, also the door sensor recalibration was succesfull.
Noticed the procedure for recalibrating of the magnetic door sensor has changed.

@Luca, Try if restarting your mobile phone solves the recalibration problem. Maybe after recalibration of door lock en sensor your problems will be solved.

Still problem with Lock&Go, only click noise but have to open door with door handle.In previous FW (before 2.5.*) this was working fine.

same issues here.
After installing 2.6.1 recalibration of the lock wasn’t possible. Switching BLE on and off solved that issue for me. Still problems with lock&go as described above. In HomeKit it isn’t possible to rename the lock (Nuki_7digit number) and after a short period Nuki isn’t responding anymore (‘No response’). App (ver. 2.4.1) status responses seem to be very laggy since updating to 2.6.1

@Juergen i have written an PM to @MatthiasK with an Log regarding AutoUnlock didnt work with the newest beta.

Also for me the door sensor showed an error after the update. I have recalibrated it and it showed the error one time after openeing the door. After closing it, it disappeared. Maybe you can see something in the logs.


After installing this Beta Firmware, the clutch is no longer opening.

So it is no longer possible to open the door manually without working against the gear.

The lock is just not opening the clutch after opening or closing the door.

Important note: The 2.6.1 build does offer a new BLE service (Device information service), which is not used by the Nuki Apps, but seems to have disturbed iOS in connecting to the Smart Lock. Therefore iPhones which have been connected to the same Smart Lock in the past, could not connect via Bluetooth anymore until the Bluetooth cache of the OS was flushed (which happens when you switch Bluetooth off/on or reboot the phone). As a consequence commands that are never sent over a bridge but always directly via Bluetooth did fail (e.g. Auto Unlock, Calibration, Door sensor configuration). This is the root cause of most of the problems mentioned in this thread.

A new binary with a workaround has been uploaded on Monday 7.10., 1pm. Everybody who did update after this is not affected by any problems. The ones who updated before will get the old status restored with an upcoming 2.6.2 update, but will - unfortunately - have to restart their iPhones (or switch Bluetooth off/on) again …

Is this also the case for android?
AutoUnlock does not find the lock anymore since 2.6.1…
Will try it again today but yesterday, th exact same happend (AutoUnlock was active (countdown running) i was in front of the door for over ~1min with nuki app opened, autounlock did not occur. I have manually opened the door in the app, which worked).

I have the same Problem. Auto Unlock sends me a notification, but even waiting in front of the door will not open it. It does not react,and when i try to open manually, it has a malfunction. When will the fix for android be out?

I’m not using the beta firmware, but out of curiosity does this affect AppleTVs (or iPads) used as HomeKit hubs, affecting HomeKit and requiring a reboot?


So far the necessity to daily re-calibrate is gone since using the beta. One calibration and good batteries (Li-Ion) works perfectly.

1 Like