Siri Shortcuts for Opener

Hi @crazykevin , unfortunately no news. Going to address it further.

Sorry guys, I haven’t checked my mails so I just saw your reply.
Here is the link to a sample shortcut: Shortcuts
I removed my smartlockid and my api token, you NEED to get them yourself.
Here is what you need to do:
Go to and set it up for your opener. In your devices overview when you see your opener you need to open developer tools in your browser and go to the network tab (F12). Then you click “Choose action” and then “Open”. You will see a new entry inside your network tab and if you click on it you will find the smartlockid of your opener. Put that into the url of the shortcut I provided. Then in nuki web you need to create an API token that can “operate devices”. Once you did that paste that into the shortcut where it says PASTE_YOUR_API_TOKEN_HERE but the important thing is that the word Bearer is written in front of it, just like in the shortcut I provided. If you still need assistance I will create a step by step guide and post it here.


This worked like a charm, thanks for figuring that out and taking the time to document it!

It took me a sec to figure out where the API key goes — the “Get contents of [URL]” action needs to be expanded so you can edit the headers:

1 Like

Thanks for your research, glad to hear it is doable
I followed the instructions but the shortcut gives me this error message: {“suppressedExceptions”:[],“detailMessage”:“Your access token is not authorized”,“stackTrace”:[]}
Any ideas?

Solved it, I just needed to add a space after “Bearer”! Thanks a lot!

To make things easier, I prepared a Shortcut with 2 setup questions for easily adding your smartlock id and API Key as 2 variables:
Nuki Opener Shortcut


Thanks for sharing this. Makes it much easier to set up. :+1:

1 Like

Where I can find my API Token?

Is this the one from nuki web which I can acitvate under “API”?

With this shown token i get this error message:

“A server with the specified hostname could not be found”

Thanks for help

You can find it in your nuki web account but I haven’t been able to access it for the last few days. Maybe it’s down?

I can access it without problems, but which one to take? The second one doesn’t work.

I managed to log in again but with another web browser. Safair can’t load the page for some reason…

I used number 2

And this works for you? Can you please share Screenshots from den Shortcuts App?

I get this Error:

“A server with the specified hostname could not be found”

ich bekomme die Fehlermeldung

{“code”:404,“homeRef”:"/",“description”:“The server has not found anything matching the request URI”,“reasonPhrase”:“Not Found”,“uri”:“HTTP/1.1: Status Code Definitions”}

was hab ich falsch gemacht ?

Mmm hard to say from this error message.
I would double check if the device ID and device token are correct and make sure to not insert any blank space when pasting them in the variable fields.

Currently using the shortcut via nuki web solution but would like to see direct nuki opener support. Please +1 this on the road map :slight_smile:

thank you for the easy way to include the opener in the Siri shortcuts. How would I have to adjust the https command to enable ring to open instead of opening the door?
thank you!

After checking the web API, I couldn’t find an action for ring to open. I faked my way using the ID of the opener and the same url used for opening the Smart lock which is common to both devices.

Hello there.
Anyone with this same problem?

Just wanted to report that this works like a charm!
I recommend triggering this shortcut with a triple backtap: Use Back Tap on your iPhone - Apple Support

1 Like

Make sure you also enter the API token in the headers (tap on the (>) right after the URL up top)