Ritto 7630/x0 detects every ring from other apartments

I wired my opener as described in the app. During setup, I wasn’t able to open the door, so I skipped that part for further testing.

After that the opener was able to detect the ring of the bell, but shortly after that I recognized, that it detects every ring for any apartment.

Any idea how to fix that?
Thank you,

Hi! Picture of wiring please!

Sorry, here is the initial wiring. I then connected the red ones (Ritto) with the red and yellow one (Nuki) with the clamp, put the black one (Nuki) in b and orange and green (Nuki) in a.

Ok. Red intercom wire out of “a” and in nuki connector port1 (2-port connector for wires what was with the opener), then red and yellow from nuki in port2, - now green and orange from nuki in “a” of intercom, black from nuki in “b” of intercom. This way the right wiring should be, do you have it that way!?

Thank you for your reply. Exactly this was what I did. Except that I had two red cables in “a” which I put in port1 of the connector which came with the opener together.

No problem. Please try to put one of the two wires what was in “a” back to “a” and test, if no change, try the other one what was in “a” before.

Same behavior as before :frowning:

Ok, then please try this, - put the wire back in the nuki clamp, and make a new setup with generic bus.

I did, It detects the opener and the ring but won’t open the door during setup. If I skip the opening during setup it doesn’t detect any ring.

Ok. Please try generic bus in a new setup.

What do you mean with new setup?

This is the part in the basement, if that helps.

I mean reset the opener, and make a full new configuration, but choose generic bus as intercom.

Okay I’ll try that tomorrow. I just tried it without a complete reset and the generic bus profile and now I get notifications only for my bell. However the opener still doesn’t work.

An interesting thing: During the setup of the generic bus, after the step which told me to go outside I could here the ring trough the speaker from outside after ringing for some seconds.

Thats good, I think we can sort the rest out! Contact me here again, when you try further!

I just resetted it and configured as Bus (Generic). Setup went fine again until the step where it should open the door.

But now I also don’t get notifications again if someone rings.

I just reconfigured it with Generic Bus, now it detects the ringing again. However, the door still won’t open.

I found this image online. Could I just solder some cables of the opener to these pins and configure it as analogue? If yes, in which order?

Hi Tim,
I have the same issue on same Ritto with detecting every ring from neightbors. I connected everything as described in configuration steps.

Did you fixed it? Maybe with this other workaround from Rose?

In my case, ringing (additionally all neightbors) and opening works.

Yellow opener wire and bell intercom wire in nuki clamp, green opener wire to Klingelsignal, blue opener wire to Öffner, purple opener wire to gnd what is right of Öffner.