Nuki opener + TCS ISW5031-0145

Did anybody managed the configure TCS ISW5031-0145 after the Nuki dropped the support for it?

Just an info for others. As support for TCS is discontinued from 01.06 I thought it was done via new FW which would be Firmware v. 1.8.1 (01.06.2022). I thought maybe the config for TCS would be available with previous FW. So I managed to find Nuki opener with Firmware v. 1.7.3 (18.01.2022). No luck, TCS was not available. Then I tried to install some previous version of nuki app. Again no luck, no TCS. In process of configuration at one point I got a message that in order to select intercom brand I need an active internet connection. So now it is clear. Support is disabled on Nuki’s server… At least I know little bit more about architecture of Nuki :smiley:

Hi! Not fully right, it is true that TCS is taken out of the official Compatibility-List, but to 90% you can still setup it with generic bus/analogue. I have a TCS, and use the opener with it.

Edit: Koch uses mostly exactly same tech than TCS, and setup TCS as Koch also often works.

Hi,
at least for this model works if you use Koch as bus during the setup.

Hi! So it works now, right?

yes it works.
first select generic then bus Koch…and it works…

1 Like

Do you have a photo of your cable management? Thx


1 Like

Thx, I have the ISW 5010 and the cable looks different , i have just a red on a and a yellow on b.
Now I try to install the opener, like you in your photo. It gets a signal but the door doesn’t open. I need some help. Thx

You need to set bus to Koch, not generic.

So you mean not generic and than koch. At first koch and then ? Thx

When doing configuration for Brand select “generic”, for Bus select “Koch”

I do , but it doesn’t open the door.

Did you try to delay signal for e.g. 3sec?

My config of the same items is also not working anymore.
I tried Koch, but all lights on the TCS are blinking.
See my wiring in the picture

How i have to rewire them, that it works with Koch?
Thanks in advance!

You have pics of my config in the thread. Try that.